]> git.pld-linux.org Git - packages/dict-misc.git/blob - dict-misc.spec
b8ceab13cdb06756463a916c82e3dad7c3fb1534
[packages/dict-misc.git] / dict-misc.spec
1 %define         dictname misc
2 Summary:        misc dictionaries for DICTD
3 Summary(pl):    Ró¿ne s³owniki dla dictd
4 Name:           dict-%{dictname}
5 Version:        1.5
6 Release:        1
7 License:        GPL
8 Group:          Applications/Dictionaries
9 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
10 URL:            http://www.dict.org/
11 BuildRequires:  dictzip
12 BuildRequires:  autoconf
13 Requires:       dictd
14 Requires:       %{_sysconfdir}/dictd
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This package contains misc dictionaries for use by the dictionary
19 server in the dictd package.
20
21 %description -l pl
22 Ten pakiet zawiera ró¿ne s³owniki do u¿ywania z serwerem s³ownika
23 dictd.
24
25 %package -n dict-hitchcock
26 Summary:        hitchcock dictionary for DICTD
27 Summary(pl):    S³ownik hitchcock dla dictd
28 Group:          Applications/Dictionaries
29 Requires:       dictd
30 Requires:       %{_sysconfdir}/dictd
31
32 %description -n dict-hitchcock
33 This package contains hitchcock dictionaries for use by the dicitonary
34 server in the dictd package.
35
36 %description -n dict-hitchcock -l pl
37 Ten pakiet zawiera s³ownik hitchcock do u¿ywania z serwerem s³ownika
38 dictd.
39
40 %package -n dict-world95
41 Summary:        world95 dictionary for DICTD
42 Summary(pl):    S³ownik world95 dla dictd
43 Group:          Applications/Dictionaries
44 Requires:       dictd
45 Requires:       %{_sysconfdir}/dictd
46
47 %description -n dict-world95
48 This package contains world95 dictionaries for use by the dicitonary
49 server in the dictd package.
50
51 %description -n dict-world95 -l pl
52 Ten pakiet zawiera s³ownik world95 do u¿ywania z serwerem s³ownika
53 dictd.
54
55 %package -n dict-foldoc
56 Summary:        foldoc dictionary for DICTD
57 Summary(pl):    S³ownik foldoc dla dictd
58 Group:          Applications/Dictionaries
59 Requires:       dictd
60 Requires:       %{_sysconfdir}/dictd
61
62 %description -n dict-foldoc
63 This package contains foldoc dictionaries for use by the dicitonary
64 server in the dictd package.
65
66 %description -n dict-foldoc -l pl
67 Ten pakiet zawiera s³ownik foldoc do u¿ywania z serwerem s³ownika
68 dictd.
69
70 %package -n dict-easton
71 Summary:        easton dictionary for DICTD
72 Summary(pl):    S³ownik easton dla dictd
73 Group:          Applications/Dictionaries
74 Requires:       dictd
75 Requires:       %{_sysconfdir}/dictd
76
77 %description -n dict-easton
78 This package contains easton dictionaries for use by the dicitonary
79 server in the dictd package.
80
81 %description -n dict-easton -l pl
82 Ten pakiet zawiera s³ownik easton do u¿ywania z serwerem s³ownika
83 dictd.
84
85 %package -n dict-elements
86 Summary:        elements dictionary for DICTD
87 Summary(pl):    S³ownik elements dla dictd
88 Group:          Applications/Dictionaries
89 Requires:       dictd
90 Requires:       %{_sysconfdir}/dictd
91
92 %description -n dict-elements
93 This package contains elements dictionaries for use by the dicitonary
94 server in the dictd package.
95
96 %description -n dict-elements -l pl
97 Ten pakiet zawiera s³ownik elements do u¿ywania z serwerem s³ownika
98 dictd.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__autoconf}
105 %configure
106 %{__make} db
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_sysconfdir}/dictd}
111 %{__make} install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
112
113 # jargon has separate package
114 rm -f $RPM_BUILD_ROOT%{_datadir}/dictd/jargon.*
115
116 for i in easton elements foldoc hitchcock world95; do
117 dictprefix=%{_datadir}/dictd/$i
118 echo "# Misc Dictionaries - $i
119 database $i {
120     data  \"$dictprefix.dict.dz\"
121     index \"$dictprefix.index\"
122 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/$i.dictconf
123 done;
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %postun -n dict-easton
129 if [ -f /var/lock/subsys/dictd ]; then
130         /etc/rc.d/init.d/dictd restart 1>&2 || true
131 fi
132
133 %post -n dict-easton
134 if [ -f /var/lock/subsys/dictd ]; then
135         /etc/rc.d/init.d/dictd restart 1>&2
136 fi
137
138
139 %postun -n dict-elements
140 if [ -f /var/lock/subsys/dictd ]; then
141         /etc/rc.d/init.d/dictd restart 1>&2 || true
142 fi
143
144 %post -n dict-elements
145 if [ -f /var/lock/subsys/dictd ]; then
146         /etc/rc.d/init.d/dictd restart 1>&2
147 fi
148
149
150 %postun -n dict-foldoc
151 if [ -f /var/lock/subsys/dictd ]; then
152         /etc/rc.d/init.d/dictd restart 1>&2 || true
153 fi
154
155 %post -n dict-foldoc
156 if [ -f /var/lock/subsys/dictd ]; then
157         /etc/rc.d/init.d/dictd restart 1>&2
158 fi
159
160
161 %postun -n dict-hitchcock
162 if [ -f /var/lock/subsys/dictd ]; then
163         /etc/rc.d/init.d/dictd restart 1>&2 || true
164 fi
165
166 %post -n dict-hitchcock
167 if [ -f /var/lock/subsys/dictd ]; then
168         /etc/rc.d/init.d/dictd restart 1>&2
169 fi
170
171
172 %postun -n dict-world95
173 if [ -f /var/lock/subsys/dictd ]; then
174         /etc/rc.d/init.d/dictd restart 1>&2 || true
175 fi
176
177 %post -n dict-world95
178 if [ -f /var/lock/subsys/dictd ]; then
179         /etc/rc.d/init.d/dictd restart 1>&2
180 fi
181
182 %files -n dict-hitchcock
183 %defattr(644,root,root,755)
184 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/hitchcock.dictconf
185 %{_datadir}/dictd/hitchcock*
186
187 %files -n dict-world95
188 %defattr(644,root,root,755)
189 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/world95.dictconf
190 %{_datadir}/dictd/world95.*
191
192 %files -n dict-foldoc
193 %defattr(644,root,root,755)
194 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/foldoc.dictconf
195 %{_datadir}/dictd/foldoc.*
196
197 %files -n dict-easton
198 %defattr(644,root,root,755)
199 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/easton.dictconf
200 %{_datadir}/dictd/easton*
201
202 %files -n dict-elements
203 %defattr(644,root,root,755)
204 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/elements.dictconf
205 %{_datadir}/dictd/elements.*
This page took 0.081213 seconds and 3 git commands to generate.