]> git.pld-linux.org Git - packages/dibbler.git/blob - dibbler.spec
- unified, fixed perms
[packages/dibbler.git] / dibbler.spec
1 Summary:        Dibbler - a portable DHCPv6
2 Summary(pl):    Dibbler - przeno¶ny DHCPv6
3 Name:           dibbler
4 Version:        0.3.1
5 Release:        0.2
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Source0:        http://klub.com.pl/dhcpv6/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  6bc2b0932f1000ad50624789873115d8
10 Patch0:         %{name}-Makefile.patch
11 URL:            http://klub.com.pl/dhcpv6/
12 #BuildRequires: bison++ >= 1.21.9
13 BuildRequires:  flex
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libxml2-devel
16 BuildRequires:  pkgconfig
17 Requires(post,preun):   /sbin/chkconfig
18 #Provides:      dhcpd?
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Dibbler is a portable DHCPv6 implementation. It supports stateful
23 (i.e. IPv6 address granting) as well as stateless (i.e. option
24 granting) autoconfiguration for IPv6. Currently Linux 2.4/2.6 and
25 Windows XP and Windows 2003 ports are available. It features easy to
26 use install packages (Clickable Windows installer and RPM and DEB
27 packages for Linux) and extensive documentation (both for users as
28 well as developers).
29
30 %description -l pl
31 Dibbler to przeno¶na implementacja DHCPv6. Obs³uguje stanow± (tzn. z
32 nadawaniem adresów IPv6), jak i bezstanow± (tzn. z nadawaniem opcji)
33 autokonfiguracjê IPv6. Aktualnie dostêpne s± porty dla Linuksa 2.4/2.6
34 i Windows XP oraz Windows 2003. Zalety to ³atwa instalacja (klikalny
35 instalator pod Windows i pakiety RPM/DEB pod Linuksa) i wyczerpuj±ca
36 dokumentacja (zarówno dla u¿ytkowników, jak i programistów).
37
38 #%package doc
39 #Summary:       Documentation for Dibbler - a portable DHCPv6
40 #Summary(pl):   Dokumentacja dla Dibblera - przeno¶nego DHCPv6
41 #Group:         Documentation
42
43 #%description doc
44 #Documentation for Dibbler - a portable DHCPv6
45
46 #%description doc -l pl
47 #Dokumentacja dla Dibblera - przeno¶nego DHCPv6
48
49 %package client
50 Summary:        Dibbler DHCPv6 client
51 Summary(pl):    Dibbler - klient DHCPv6
52 Group:          Networking/Daemons
53
54 %description client
55 DHCPv6 protocol client.
56
57 %description client -l pl
58 Klient protoko³u DHCPv6.
59
60 %prep
61 %setup -q -n %{name}
62 %patch0 -p0
63
64 %build
65 %{__make} server client \
66         ARCH=LINUX \
67         CFLAGS="%{rpmcflags}" \
68         CPP="%{__cpp}" \
69         CXX="%{__cxx}" \
70         CC="%{__cc}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
75         $RPM_BUILD_ROOT{%{_sharedstatedir}/%{name},%{_sysconfdir}/%{name}}
76
77 install dibbler-{client,server} $RPM_BUILD_ROOT%{_sbindir}
78 install *.conf $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}
79 install doc/man/* $RPM_BUILD_ROOT%{_mandir}/man8
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 ln -s %{_sharedstatedir}/%{name}/server.conf %{_sysconfdir}/%{name}/server.conf
86 /sbin/chkconfig -add dibbler
87
88 %preun
89 if [ "$1" = "0" ];then
90         if [ -f /var/lock/subsys/dhcpd ]; then
91                 /etc/rc.d/init.d/dhcpd stop >&2
92         fi
93         /sbin/chkconfig --del dhcpd
94 fi
95
96 %post client
97 if [ -d %{_sharedstatedir}/%{name} ]; then
98 install -d %{_sharedstatedir}/%{name}
99 ln -s %{_sharedstatedir}/%{name}/client.conf %{_sysconfdir}/%{name}/client.conf
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc CHANGELOG FUN LICENSE GUIDELINES RELNOTES TODO VERSION WILD-IDEAS 
105 %doc server.conf server-stateless.conf doc/man/dibbler-server.8
106 %attr(755,root,root) %{_sbindir}/dibbler-server
107 %dir %{_sharedstatedir}/%{name}
108 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/server.conf
109 %{_mandir}/man8/*.8*
110
111 %files client
112 %defattr(644,root,root,755)
113 %doc CHANGELOG FUN LICENSE GUIDELINES RELNOTES TODO VERSION WILD-IDEAS
114 %doc client.conf client-stateless.conf doc/man/dibbler-client.8
115 %attr(755,root,root) %{_sbindir}/dibbler-client
116 %dir %{_sharedstatedir}/%{name}
117 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/client.conf
118 %{_mandir}/man8/*.8*
119
120 #%files doc
121 #%defattr(644,root,root,755)
122 #%doc doc/*.blah
This page took 0.140336 seconds and 4 git commands to generate.