]> git.pld-linux.org Git - packages/dibbler.git/blob - dibbler.spec
- fixed problems with running as a deamon
[packages/dibbler.git] / dibbler.spec
1 Summary:        Dibbler - a portable DHCPv6
2 Summary(pl):    Dibbler - przeno¶ny DHCPv6
3 Name:           dibbler
4 Version:        0.3.1
5 Release:        0.3
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Source0:        http://klub.com.pl/dhcpv6/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  6bc2b0932f1000ad50624789873115d8
10 Source1:        %{name}.init
11 Patch0:         %{name}-Makefile.patch
12 URL:            http://klub.com.pl/dhcpv6/
13 #BuildRequires: bison++ >= 1.21.9
14 BuildRequires:  flex
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libxml2-devel
17 BuildRequires:  pkgconfig
18 Requires(post,preun):   /sbin/chkconfig
19 #Provides:      dhcpv6-server ?
20 Obsoletes:      dhcpv6
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Dibbler is a portable DHCPv6 implementation. It supports stateful
25 (i.e. IPv6 address granting) as well as stateless (i.e. option
26 granting) autoconfiguration for IPv6. Currently Linux 2.4/2.6 and
27 Windows XP and Windows 2003 ports are available. It features easy to
28 use install packages (Clickable Windows installer and RPM and DEB
29 packages for Linux) and extensive documentation (both for users as
30 well as developers).
31
32 %description -l pl
33 Dibbler to przeno¶na implementacja DHCPv6. Obs³uguje stanow± (tzn. z
34 nadawaniem adresów IPv6), jak i bezstanow± (tzn. z nadawaniem opcji)
35 autokonfiguracjê IPv6. Aktualnie dostêpne s± porty dla Linuksa 2.4/2.6
36 i Windows XP oraz Windows 2003. Zalety to ³atwa instalacja (klikalny
37 instalator pod Windows i pakiety RPM/DEB pod Linuksa) i wyczerpuj±ca
38 dokumentacja (zarówno dla u¿ytkowników, jak i programistów).
39
40 #%package doc
41 #Summary:       Documentation for Dibbler - a portable DHCPv6
42 #Summary(pl):   Dokumentacja dla Dibblera - przeno¶nego DHCPv6
43 #Group:         Documentation
44
45 #%description doc
46 #Documentation for Dibbler - a portable DHCPv6
47
48 #%description doc -l pl
49 #Dokumentacja dla Dibblera - przeno¶nego DHCPv6
50
51 %package client
52 Summary:        Dibbler DHCPv6 client
53 Summary(pl):    Dibbler - klient DHCPv6
54 Group:          Networking/Daemons
55
56 %description client
57 DHCPv6 protocol client.
58
59 %description client -l pl
60 Klient protoko³u DHCPv6.
61
62 %prep
63 %setup -q -n %{name}
64 %patch0 -p0
65
66 %build
67 #%{__make} server client \
68 #       ARCH=LINUX \
69 #       CFLAGS="%{rpmcflags}" \
70 #       CPP="%{__cpp}" \
71 #       CXX="%{__cxx}" \
72 #       CC="%{__cc}"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
77         $RPM_BUILD_ROOT{%{_sharedstatedir}/%{name},%{_sysconfdir}/{rc.d/init.d,dibbler}}
78
79 install dibbler-{client,server} $RPM_BUILD_ROOT%{_sbindir}
80 install *.conf $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}
81 install doc/man/* $RPM_BUILD_ROOT%{_mandir}/man8
82 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dibbler
83 ln -sf %{_sharedstatedir}/%{name}/server.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/server.conf
84 ln -sf %{_sharedstatedir}/%{name}/client.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/client.conf
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 /sbin/ldconfig
91 if [ "$1" = "1" ]; then
92         /sbin/chkconfig --add dibbler
93         if [ -f /var/lock/subsys/dibbler ]; then
94                 /etc/rc.d/init.d/dibbler restart 1>&2
95         else
96                 echo "Run \"/etc/rc.d/init.d/dibbler start\" to start dibbler DHCP daemon."
97         fi
98 fi
99
100
101 %preun
102 if [ "$1" = "0" ];then
103         if [ -f /var/lock/subsys/dibbler ]; then
104                 /etc/rc.d/init.d/dibbler stop >&2
105         fi
106         /sbin/chkconfig --del dibbler
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGELOG LICENSE RELNOTES VERSION 
112 %doc server.conf server-stateless.conf doc/man/dibbler-server.8
113 %attr(755,root,root) %{_sbindir}/dibbler-server
114 %attr(754,root,root) /etc/rc.d/init.d/dibbler
115 %dir %{_sharedstatedir}/%{name}
116 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/server.conf
117 %dir %{_sysconfdir}/%{name}
118 %{_sysconfdir}/%{name}/server.conf
119 %{_mandir}/man8/*.8*
120
121 %files client
122 %defattr(644,root,root,755)
123 %doc CHANGELOG FUN LICENSE GUIDELINES RELNOTES TODO VERSION WILD-IDEAS
124 %doc client.conf client-stateless.conf doc/man/dibbler-client.8
125 %attr(755,root,root) %{_sbindir}/dibbler-client
126 %dir %{_sharedstatedir}/%{name}
127 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/client.conf
128 %dir %{_sysconfdir}/%{name}
129 %{_sysconfdir}/%{name}/client.conf
130 %{_mandir}/man8/*.8*
131
132 #%files doc
133 #%defattr(644,root,root,755)
134 #%doc doc/*.blah
This page took 0.10136 seconds and 3 git commands to generate.