]> git.pld-linux.org Git - packages/dhcpv6.git/blob - dhcpv6.spec
- use _sbindir macro
[packages/dhcpv6.git] / dhcpv6.spec
1 Summary:        DHCPv6 - DHCP server and client for IPv6
2 Summary(pl):    DHCPv6 - serwer i klient DHCP dla IPv6
3 Name:           dhcpv6
4 Version:        0.10
5 Release:        0.2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/dhcpv6/dhcp-%{version}.tgz
9 # Source0-md5:  72b802d6c89e15e5cf6b0aecf46613f2
10 Patch0:         %{name}-initscripts.patch
11 #Patch1:                %{name}-0.10-change_resolv_conf.patch
12 Patch1:         %{name}-DESTDIR.patch
13 URL:            http://dhcpv6.sourceforge.net/
14 BuildRequires:  bison
15 BuildRequires:  flex
16 Requires(post,preun):   /sbin/chkconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _sbindir        /sbin
20
21 %description
22 Implements the Dynamic Host Configuration Protocol (DHCP) for Internet
23 Protocol version 6 (IPv6) networks in accordance with RFC 3315 :
24 Dynamic Host Configuration Protocol for IPv6 (DHCPv6). Consists of
25 dhcp6s(8), the server DHCP daemon. Install this if you want to support
26 dynamic configuration of IPv6 addresses and parameters on your IPv6
27 network. See man dhcp6s(8), dhcp6s.conf(5), and the documentation in
28 /usr/share/doc/dhcpv6* .
29
30 %description -l pl
31 Ten pakiet jest implementacj± protoko³u Dynamic Host Configuration
32 Protocol (DHCP) dla sieci IPv6 zgodnie z RFC 3315: Dynamic Host
33 Configuration Protocol for IPv6 (DHCPv6). Zawiera demona serwera DHCP
34 - dhcp6s(8). Nale¿y zainstalowaæ ten pakiet, je¶li potrzebujemy
35 obs³ugi dynamicznej konfiguracji adresów i parametrów sieci IPv6.
36 Wiêcej znajduje siê w manualach dhcp6s(8), dhcp6s.conf(5) oraz
37 dokumentacji w /usr/share/doc/dhcpv6* .
38
39 %package -n dhcpv6_client
40 Summary:        DHCPv6 client
41 Summary(pl):    Klient DHCPv6
42 Group:          Applications/Networking
43 Requires:       initscripts >= 7.73
44
45 %description -n dhcpv6_client
46 Provides the client for the DHCPv6 protocol (RFC 3315) to support
47 dynamic configuration of IPv6 addresses and parameters. See man
48 dhcp6c(8), dhcp6c.conf(5), and the documentation in
49 /usr/share/doc/dhcpv6_client* .
50
51 %description -n dhcpv6_client -l pl
52 Ten pakiet dostarcza klienta protoko³u DHCPv6 (RFC 3315) do obs³ugi
53 dynamicznej konfiguracji adresów i parametrów sieci iPv6. Wiêcej
54 znajduje siê w manualu dhcp6c(8), dhcp6c.conf(5) oraz dokumentacji w
55 /usr/share/doc/dhcpv6_client*
56
57 %prep
58 %setup -q -n dhcp-%{version}
59 %patch0 -p1
60 %patch1 -p1
61
62 %build
63 %configure \
64         --prefix= \
65         --mandir=%{_mandir}
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/sysconfig,%{_localstatedir}/lib/dhcpv6,/etc/rc.d/init.d}
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install dhcp6s.sysconfig        $RPM_BUILD_ROOT/etc/sysconfig/dhcp6s
77 install dhcp6c.sysconfig        $RPM_BUILD_ROOT/etc/sysconfig/dhcp6c
78 install server6_addr.conf dhcp6s.conf dhcp6c.conf               $RPM_BUILD_ROOT%{_sysconfdir}
79 install dhcp6s.sh       $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6s
80 install dhcp6c.sh       $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6c
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post
86 /sbin/chkconfig --add dhcp6s
87
88 %preun
89 if [ "$1" = "0" ]; then
90         /etc/rc.d/init.d/dhcp6s stop >/dev/null 2>&1
91         /sbin/chkconfig --del dhcp6s
92 fi
93
94 %postun
95 if [ "$1" -ge "1" ]; then
96         /etc/rc.d/init.d/dhcp6s condrestart >/dev/null 2>&1
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %doc ReadMe docs/* dhcp6s.conf
102 %attr(754,root,root) %{_sbindir}/dhcp6s
103 %attr(754,root,root) /etc/rc.d/init.d/dhcp6s
104 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6s
105 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
106 %{_mandir}/man8/dhcp6s.8*
107 %{_mandir}/man5/dhcp6s.conf.5*
108 %attr(754,root,root) %dir %{_localstatedir}/lib/dhcpv6
109
110 %files -n dhcpv6_client
111 %defattr(644,root,root,755)
112 %doc ReadMe dhcp6c.conf
113 %attr(750,root,root) %{_sbindir}/dhcp6c
114 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6c
115 %attr(754,root,root) /etc/rc.d/init.d/dhcp6c
116 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6c.conf
117 %{_mandir}/man8/dhcp6c.8*
118 %{_mandir}/man5/dhcp6c.conf.5*
119 %attr(750,root,root) %dir %{_localstatedir}/lib/dhcpv6
This page took 0.083223 seconds and 4 git commands to generate.