]> git.pld-linux.org Git - packages/dhcpcd.git/blob - dhcpcd.spec
aae06ad3eede89271f10135674eee49c3ea51bbc
[packages/dhcpcd.git] / dhcpcd.spec
1 # TODO:
2 # - review Gentoo patches: http://www.gentoo.org/cgi-bin/viewcvs.cgi/net-misc/dhcpcd/files/
3 Summary:        DHCP Client Daemon
4 Summary(de):    DHCPC-Dämon
5 Summary(es):    Cliente (daemon) DHCP
6 Summary(fr):    Démon DHCPC
7 Summary(pl):    Klient (daemon) DHCP
8 Summary(pt_BR): Servidor DHCPC
9 Summary(tr):    DHCPC sunucu süreçi (daemon)
10 Name:           dhcpcd
11 %define ver     1.3.22-pl4
12 Version:        %(echo %{ver} | tr -d - )
13 Release:        5
14 License:        GPL v2
15 Group:          Networking/Daemons
16 Source0:        http://www.phystech.com/ftp/%{name}-%{ver}.tar.gz
17 # Source0-md5:  dd627a121e43835bead3ffef5b1a72fd
18 Patch0:         %{name}-configure.patch
19 Patch1:         %{name}-ntpdrift-66136.patch
20 Patch2:         %{name}-noMoFakery.patch
21 Patch3:         %{name}-noNISfakery.patch
22 Patch4:         %{name}-paths_fixes.patch
23 Patch5:         %{name}-security.patch
24 BuildRequires:  automake
25 BuildRequires:  autoconf
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _sbindir        /sbin
29
30 %description
31 dhcpcd is an implementation of the DHCP client specified in
32 draft-ietf-dhc-dhcp-09 (when -r option is not specified) and RFC1541
33 (when -r option is specified).
34
35 It gets the host information (IP address, netmask, broadcast address,
36 etc.) from a DHCP server and configures the network interface of the
37 machine on which it is running. It also tries to renew the lease time
38 according to RFC1541 or draft-ietf-dhc-dhcp-09.
39
40 %description -l de
41 dhcpcd ist eine Implementierung des DHCP-Client, spezifiziert in
42 draft-ietf-dhc-dhcp-09 (wenn -r option nicht angegeben) und RFC1541
43 (wenn -r option angegeben).
44
45 Es bezieht die Host-Infos (IP-Adresse, Netmask, Broadcast-Adresse,
46 usw.) von einem DHCP-Server und konfiguriert die Netzschnittstelle des
47 Computers, auf dem es läuft Es versucht, die Verleihzeit gemäß RFC1541
48 bzw. draft-ietf-dhc-dhcp-09 zu verlängern.
49
50 %description -l es
51 dhcpcd es una implementación del cliente DHCP especificado en
52 draft-ietf-dhc-dhcp-09 (cuando la opción -r no está especificada) y
53 RFC1541 (cuando la opción -r está especificada). Captura la
54 información del host (dirección IP, máscara de red, dirección de
55 broadcast, etc.) de un servidor DHCP y configura la interface de red
56 de la máquina donde esté ejecutando. También intenta renovar el tiempo
57 de alquiler de los direcciones de acuerdo con RFC1541 o
58 draft-ietf-dhc-dhcp-09.
59
60 %description -l fr
61 dhcpcd est une implantation du client DHCP spécifié dans les
62 draft-ietf-dhc-dhcp-09 (sans l'option -r) et RFC1541 (avec l'option -r).
63
64 Il obtient l'information sur l'hôte (adresse IP, masque réseau,
65 adresse de diffusion, etc.) à partir d'un serveur DHCP et configure
66 l'interface réseau de la machine sur laquelle il tourne. Il essaie
67 aussi de renouveler le « lease time » selon les RFC1541 ou
68 draft-ietf-dhc-dhcp-09.
69
70 %description -l pl
71 dhcpd jest implementacja klienta DHCP, opisan± w
72 draft-ietf-dhc-dhcp-09 (kiedy nie podaje siê opcji -r) oraz RFC1544
73 (kiedy podaje siê opcjê -r).
74
75 Pobiera on informacjê o komputerze (adres IP, maska sieci, adres
76 rozg³oszeniowy itd.) i konfiguruje interfejs sieciowy maszyny, na
77 której jest uruchomiony. Próbuje równie¿ od¶wie¿yæ czas przestoju
78 zgodnie z RFC1541 oraz draft-ietf-dhc-dhcp-09.
79
80 %description -l pt_BR
81 dhcpcd é uma implementação do cliente DHCP especificado em
82 draft-ietf-dhc-dhcp-09 (quando a opção -r não é especificada) e
83 RFC1541 (quando a opção -r é especificada). Ele captura a informação
84 do host (endereço IP, máscara de rede, endereço de broadcast, etc.) de
85 um servidor DHCP e configura a interface de rede da máquina em que
86 está rodando. Ele também tenta renovar o tempo de aluguel dos
87 endereços de acordo com RFC1541 ou draft-ietf-dhc-dhcp-09.
88
89 %description -l tr
90 Makina bilgilerini (IP adresi, að maskesi, yayýn adresi, vb.) bir DHCP
91 sunucusundan alýr ve üzerinde çalýþtýðý makinanýn að arayüzünü
92 ayarlar. Ayrýca RFC1541 veya draft-ietf-dhc-dhcp-09'a uygun olarak,
93 kira zamanýný (lease time) yenilemeye çalýþýr.
94
95 %prep
96 %setup -q -n %{name}-%{ver}
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p0
103
104 %build
105 rm -f missing
106 %{__aclocal}
107 %{__autoconf}
108 %{__automake}
109 %configure
110 %{__make} all \
111         mandir=%{_mandir} \
112         sbindir=%{_sbindir}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_var}/lib/dhcpc
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         mandir=%{_mandir} \
121         sbindir=%{_sbindir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc README AUTHORS ChangeLog NEWS
129 %attr(755,root,root) %{_sbindir}/dhcpcd
130 %dir %{_var}/lib/dhcpc
131 %{_mandir}/man8/dhcpcd.8*
This page took 0.078462 seconds and 3 git commands to generate.