]> git.pld-linux.org Git - packages/dhcp.git/blob - dhcp.spec
- rel 3; add dhcpd.conf
[packages/dhcp.git] / dhcp.spec
1 #
2 # Conditional build:
3 %bcond_with     ldap    # with support for ldap storage
4 #
5 Summary:        DHCP Server
6 Summary(es):    Servidor DHCP (Protocolo de configuración dinámica de hosts)
7 Summary(pl):    Serwer DHCP
8 Summary(pt_BR): Servidor DHCP (Protocolo de configuração dinâmica de hosts)
9 Name:           dhcp
10 Version:        3.0.1
11 Release:        3
12 Epoch:          3
13 Vendor:         ISC
14 License:        distributable
15 Group:          Networking/Daemons
16 Source0:        ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}.tar.gz
17 # Source0-md5:  44f72d16a12acc3fbe09703157aa42d2
18 Source1:        %{name}.init
19 Source2:        %{name}-relay.init
20 Source3:        %{name}-relay.sysconfig
21 Source4:        %{name}d.conf.sample
22 Source5:        %{name}.sysconfig
23 Patch0:         %{name}-if_buffer_size.patch
24 Patch1:         %{name}-ldap.patch
25 Patch2:         %{name}-ldap1.patch
26 URL:            http://www.isc.org/sw/dhcp/
27 BuildRequires:  groff
28 %{?with_ldap:BuildRequires:     openldap-devel}
29 PreReq:         rc-scripts >= 0.2.0
30 Requires(post,preun):   /sbin/chkconfig
31 Requires(post): fileutils
32 Provides:       dhcpd
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
37 individual devices on an IP network to get their own network
38 configuration information (IP address, subnetmask, broadcast address,
39 etc.) from a DHCP server. The overall purpose of DHCP is to make it
40 easier to administer a large network.
41
42 %description -l es
43 DHCP permite que hosts en una red TCP/IP soliciten y tengan sus
44 direcciones IP alocadas dinámicamente, permite también descubrir
45 información sobre la red en que están conectados. BOOTP provee una
46 funcionalidad similar, con ciertas restricciones. Este servidor
47 también las atiende. Esta versión aún está considerada como un
48 software BETA.
49
50 %description -l pl
51 Serwer DHCP (Dynamic Host Configuration Protocol).
52
53 DHCP to protokó³ pozwalaj±cy urz±dzeniom pracuj±cym w sieci IP na
54 pobieranie ich konfiguracji IP (adresu, maski podsieci, adresu
55 rozg³oszeniowego itp.) z serwera DHCP. U³atwia on administrowanie
56 du¿ymi sieciami IP.
57
58 %description -l pt_BR
59 DHCP permite que hosts numa rede TCP/IP requisitem e tenham seus
60 endereços IP alocados dinamicamente, permite também descobrir
61 informações sobre a rede em que estão conectados. BOOTP provê uma
62 funcionalidade similar, com certas restrições. Este servidor também
63 atende aquelas requisições. Esta versão é ainda considerada um
64 software BETA.
65
66 %package client
67 Summary:        DHCP Client
68 Summary(pl):    Klient DHCP
69 Group:          Networking/Daemons
70 Requires(post): fileutils
71 Obsoletes:      pump
72
73 %description client
74 Dynamic Host Configuration Protocol Client.
75
76 %description client -l pl
77 Klient DHCP (Dynamic Host Configuration Protocol).
78
79 %package relay
80 Summary:        DHCP Relay Agent
81 Summary(pl):    Agent przekazywania informacji DHCP
82 Group:          Networking/Daemons
83 PreReq:         rc-scripts >= 0.2.0
84 Requires(post,preun):   /sbin/chkconfig
85 Requires(post): fileutils
86
87 %description relay
88 Dhcp relay is a relay agent for DHCP packets. It is used on a subnet
89 with DHCP clients to "relay" their requests to a subnet that has a
90 DHCP server on it. Because DHCP packets can be broadcast, they will
91 not be routed off of the local subnet. The DHCP relay takes care of
92 this for the client.
93
94 %description relay -l pl
95 Agent przekazywania DHCP (Dynamic Host Configuration Protocol) miêdzy
96 podsieciami. Poniewa¿ komunikaty DHCP mog± byæ przekazywane w formie
97 rozg³oszeniowej, bez tego agenta nie zostan± przerutowane do innej
98 podsieci.
99
100 %package devel
101 Summary:        DHCP development includes and libs
102 Summary(pl):    Pliki nag³ówkowe i biblioteki dla oprogramowania DHCP
103 Group:          Development/Libraries
104
105 %description devel
106 Includes OMAPI and dhcptl libraries.
107
108 OMAPI is an programming layer designed for controlling remote
109 applications, and for querying them for their state. It is currently
110 used by the ISC DHCP server.
111
112 The dhcpctl set of functions provide an API that can be used to
113 communicate with and manipulate a running ISC DHCP server.
114
115 %description devel -l pl
116 Zawiera biblioteki OMAPI oraz dhcpctl.
117
118 OMAPI to warstwa programowa stworzona do kontroli zdalnych aplikacji i
119 odpytywania o ich stan. Aktualnie jest u¿ywana przez serwer ISC DHCP.
120
121 dhcpctl to zbiór funkcji tworz±cych API, które mo¿e byæ u¿ywane do
122 komunikacji z dzia³aj±cym serwerem ISC DHCP i jego kontroli.
123
124 %prep
125 %setup -q
126 install %{SOURCE4} .
127 %patch0 -p1
128 %{?with_ldap:%patch1 -p1}
129 %{?with_ldap:%patch2 -p1}
130
131 cd doc
132 echo "dhcpd complies with the following RFCs:" > rfc-compliance
133 ls rfc*.txt >> rfc-compliance
134 rm -f rfc*.txt
135 cd ..
136
137 %build
138 # Notice: this is not autoconf configure!!!!!!!
139 #         do not change it to %%configure
140 ./configure
141
142 %{__make} \
143         COPTS="%{rpmcflags} \
144         -D_PATH_DHCPD_DB=\\\"/var/lib/%{name}/dhcpd.leases\\\" \
145         -D_PATH_DHCLIENT_DB=\\\"/var/lib/%{name}/dhclient.leases\\\"" \
146         DEBUG="" VARDB="/var/lib/%{name}"
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_bindir},%{_mandir}/man{5,8}} \
151         $RPM_BUILD_ROOT{/var/lib/%{name},%{_sysconfdir}/{rc.d/init.d,sysconfig}}
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT \
155         CLIENTBINDIR=/sbin \
156         BINDIR=%{_sbindir} \
157         LIBDIR=%{_libdir} \
158         INCDIR=%{_includedir} \
159         ADMMANDIR=%{_mandir}/man8 \
160         ADMMANEXT=.8 \
161         FFMANDIR=%{_mandir}/man5 \
162         LIBMANDIR=%{_mandir}/man3 \
163         LIBMANEXT=.3 \
164         USRMANDIR=%{_mandir}/man1 \
165         USRMANEXT=.1 \
166         VARDB=/var/lib/%{name} \
167         FFMANEXT=.5
168
169 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcpd
170 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp-relay
171 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/dhcp-relay
172 install %{SOURCE4} $RPM_BUILD_ROOT/etc/dhcpd.conf
173 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/dhcpd
174
175 mv $RPM_BUILD_ROOT%{_mandir}/man3/omshell.3 \
176         $RPM_BUILD_ROOT%{_mandir}/man1/omshell.1
177
178 install client/scripts/linux $RPM_BUILD_ROOT%{_sbindir}/dhclient-script
179
180 touch $RPM_BUILD_ROOT/var/lib/%{name}/{dhcpd,dhclient}.leases
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post
186 /sbin/chkconfig --add dhcpd
187 touch /var/lib/%{name}/dhcpd.leases
188
189 if [ ! -d /var/lib/dhcp ]; then
190         install -d /var/lib/dhcp
191 fi
192
193 if [ -f /var/lock/subsys/dhcpd ]; then
194         /etc/rc.d/init.d/dhcpd restart >&2
195 else
196         echo "Run \"/etc/rc.d/init.d/dhcpd start\" to start dhcpd daemon."
197 fi
198
199 %preun
200 if [ "$1" = "0" ];then
201         if [ -f /var/lock/subsys/dhcpd ]; then
202                 /etc/rc.d/init.d/dhcpd stop >&2
203         fi
204         /sbin/chkconfig --del dhcpd
205 fi
206
207 %post client
208 if [ -d /var/lib/dhcp ]; then
209         install -d /var/lib/dhcp
210 fi
211
212 %post relay
213 /sbin/chkconfig --add dhcp-relay
214 if [ -f /var/lock/subsys/dhcrelay ]; then
215         mv -f /var/lock/subsys/dhcrelay /var/lock/subsys/dhcp-relay
216 fi
217 if [ -f /var/lock/subsys/dhcp-relay ]; then
218         /etc/rc.d/init.d/dhcp-relay restart >&2
219 else
220         echo "Run \"/etc/rc.d/init.d/dhcp-relay start\" to start dhcrelay daemon."
221 fi
222
223 %preun relay
224 if [ "$1" = "0" ];then
225         if [ -f /var/lock/subsys/dhcp-relay ]; then
226                 /etc/rc.d/init.d/dhcp-relay stop >&2
227         fi
228         /sbin/chkconfig --del dhcp-relay
229 fi
230
231 %triggerpostun -- dhcp < 3.0
232 if [ `grep ddns-update-style /etc/dhcpd.conf` = "" ]; then
233         umask 027
234         echo "ddns-update-style none;" > /etc/dhcpd.conf.tmp
235         echo "" >> /etc/dhcpd.conf.tmp
236         cat /etc/dhcpd.conf >>/etc/dhcpd.conf.tmp
237         mv -f /etc/dhcpd.conf.tmp /etc/dhcpd.conf
238 fi
239
240 %files
241 %defattr(644,root,root,755)
242 %doc doc/* README RELNOTES dhcpd.conf.sample
243 %{?with_ldap:%doc contrib/*}
244 %{_mandir}/man1/*
245 %{_mandir}/man5/dhcp*
246 %{_mandir}/man8/dhcp*
247 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/dhcpd
248 %config(noreplace) %verify(not size mtime md5) /etc/dhcpd.conf
249 %attr(755,root,root) %{_bindir}/*
250 %attr(755,root,root) %{_sbindir}/dhcpd
251 %attr(754,root,root) /etc/rc.d/init.d/dhcpd
252 %attr(750,root,root) %dir /var/lib/%{name}
253 %ghost /var/lib/%{name}/dhcpd.leases
254
255 %files client
256 %defattr(644,root,root,755)
257 %attr(755,root,root) /sbin/dhclient
258 %attr(755,root,root) /sbin/dhclient-script
259 %{_mandir}/man[58]/dhclient*
260 %ghost /var/lib/%{name}/dhclient.leases
261
262 %files relay
263 %defattr(644,root,root,755)
264 %{_mandir}/man8/dhcrelay*
265 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/dhcp-relay
266 %attr(755,root,root) %{_sbindir}/dhcrelay
267 %attr(754,root,root) /etc/rc.d/init.d/dhcp-relay
268
269 %files devel
270 %defattr(644,root,root,755)
271 %{_mandir}/man3/*
272 %{_libdir}/*.a
273 %{_includedir}/*
This page took 0.102302 seconds and 4 git commands to generate.