]> git.pld-linux.org Git - packages/dhcp.git/blob - dhcp.spec
- up to 3.1.0a1
[packages/dhcp.git] / dhcp.spec
1 #
2 # Conditional build:
3 %bcond_with     ldap    # with support for ldap storage
4 #
5 Summary:        DHCP Server
6 Summary(es):    Servidor DHCP
7 Summary(pl):    Serwer DHCP
8 Summary(pt_BR): Servidor DHCP (Protocolo de configuração dinâmica de hosts)
9 Name:           dhcp
10 Version:        3.1.0a1
11 Release:        0.1
12 Epoch:          3
13 License:        distributable
14 Group:          Networking/Daemons
15 Source0:        ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}.tar.gz
16 # Source0-md5:  a326c6f135b9fa3ad24988312c784be5
17 Source1:        %{name}.init
18 Source2:        %{name}-relay.init
19 Source3:        %{name}-relay.sysconfig
20 Source4:        %{name}d.conf.sample
21 Source5:        %{name}.sysconfig
22 Patch0:         %{name}-if_buffer_size.patch
23 Patch1:         %{name}-ldap.patch
24 Patch2:         %{name}-ldap1.patch
25 Patch3:         %{name}-client-script-redhat.patch
26 Patch4:         %{name}-3.0.3-x-option.patch
27 URL:            http://www.isc.org/sw/dhcp/
28 BuildRequires:  groff
29 %{?with_ldap:BuildRequires:     openldap-devel}
30 BuildRequires:  rpmbuild(macros) >= 1.268
31 Requires(post): fileutils
32 Requires(post,preun):   /sbin/chkconfig
33 Requires:       rc-scripts >= 0.2.0
34 Provides:       dhcpd
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
39 individual devices on an IP network to get their own network
40 configuration information (IP address, subnetmask, broadcast address,
41 etc.) from a DHCP server. The overall purpose of DHCP is to make it
42 easier to administer a large network.
43
44 %description -l es
45 DHCP permite que hosts en una red TCP/IP soliciten y tengan sus
46 direcciones IP alocadas dinámicamente, permite también descubrir
47 información sobre la red en que están conectados. BOOTP provee una
48 funcionalidad similar, con ciertas restricciones. Este servidor
49 también las atiende.
50
51 %description -l pl
52 Serwer DHCP (Dynamic Host Configuration Protocol).
53
54 DHCP to protokó³ pozwalaj±cy urz±dzeniom pracuj±cym w sieci IP na
55 pobieranie ich konfiguracji IP (adresu, maski podsieci, adresu
56 rozg³oszeniowego itp.) z serwera DHCP. U³atwia on administrowanie
57 du¿ymi sieciami IP.
58
59 %description -l pt_BR
60 DHCP permite que hosts numa rede TCP/IP requisitem e tenham seus
61 endereços IP alocados dinamicamente, permite também descobrir
62 informações sobre a rede em que estão conectados. BOOTP provê uma
63 funcionalidade similar, com certas restrições. Este servidor também
64 atende aquelas requisições. Esta versão é ainda considerada um
65 software BETA.
66
67 %package client
68 Summary:        DHCP Client
69 Summary(pl):    Klient DHCP
70 Group:          Networking/Daemons
71 Requires(post): fileutils
72 Obsoletes:      dhclient
73 Obsoletes:      pump
74
75 %description client
76 Dynamic Host Configuration Protocol Client.
77
78 %description client -l pl
79 Klient DHCP (Dynamic Host Configuration Protocol).
80
81 %package relay
82 Summary:        DHCP Relay Agent
83 Summary(pl):    Agent przekazywania informacji DHCP
84 Group:          Networking/Daemons
85 Requires(post): fileutils
86 Requires(post,preun):   /sbin/chkconfig
87 Requires:       rc-scripts >= 0.2.0
88
89 %description relay
90 Dhcp relay is a relay agent for DHCP packets. It is used on a subnet
91 with DHCP clients to "relay" their requests to a subnet that has a
92 DHCP server on it. Because DHCP packets can be broadcast, they will
93 not be routed off of the local subnet. The DHCP relay takes care of
94 this for the client.
95
96 %description relay -l pl
97 Agent przekazywania DHCP (Dynamic Host Configuration Protocol) miêdzy
98 podsieciami. Poniewa¿ komunikaty DHCP mog± byæ przekazywane w formie
99 rozg³oszeniowej, bez tego agenta nie zostan± przerutowane do innej
100 podsieci.
101
102 %package devel
103 Summary:        DHCP development includes and libs
104 Summary(pl):    Pliki nag³ówkowe i biblioteki dla oprogramowania DHCP
105 Group:          Development/Libraries
106
107 %description devel
108 Includes OMAPI and dhcptl libraries.
109
110 OMAPI is an programming layer designed for controlling remote
111 applications, and for querying them for their state. It is currently
112 used by the ISC DHCP server.
113
114 The dhcpctl set of functions provide an API that can be used to
115 communicate with and manipulate a running ISC DHCP server.
116
117 %description devel -l pl
118 Zawiera biblioteki OMAPI oraz dhcpctl.
119
120 OMAPI to warstwa programowa stworzona do kontroli zdalnych aplikacji i
121 odpytywania o ich stan. Aktualnie jest u¿ywana przez serwer ISC DHCP.
122
123 dhcpctl to zbiór funkcji tworz±cych API, które mo¿e byæ u¿ywane do
124 komunikacji z dzia³aj±cym serwerem ISC DHCP i jego kontroli.
125
126 %prep
127 %setup -q
128 install %{SOURCE4} .
129 %patch0 -p1
130 %{?with_ldap:%patch1 -p1}
131 %{?with_ldap:%patch2 -p1}
132 %patch3 -p1
133 # WTF is this?
134 #%patch4 -p1
135
136 %build
137 # Notice: this is not autoconf configure!!!!!!!
138 #         do not change it to %%configure
139 ./configure
140
141 %{__make} \
142         CC="%{__cc}" \
143         CC_OPTIONS="%{rpmcflags} \
144         -D_PATH_DHCPD_DB=\\\"/var/lib/%{name}/dhcpd.leases\\\" \
145         -DEXTENDED_NEW_OPTION_INFO \
146         -D_PATH_DHCLIENT_DB=\\\"/var/lib/%{name}/dhclient.leases\\\" " \
147         LFLAGS="%{rpmldflags}" \
148         DEBUG="" \
149         VARDB="/var/lib/%{name}"
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_bindir},%{_mandir}/man{5,8}} \
154         $RPM_BUILD_ROOT{/var/lib/%{name},%{_sysconfdir}/{rc.d/init.d,sysconfig}}
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT \
158         CLIENTBINDIR=/sbin \
159         BINDIR=%{_sbindir} \
160         LIBDIR=%{_libdir} \
161         INCDIR=%{_includedir} \
162         ADMMANDIR=%{_mandir}/man8 \
163         ADMMANEXT=.8 \
164         FFMANDIR=%{_mandir}/man5 \
165         LIBMANDIR=%{_mandir}/man3 \
166         LIBMANEXT=.3 \
167         USRMANDIR=%{_mandir}/man1 \
168         USRMANEXT=.1 \
169         VARDB=/var/lib/%{name} \
170         FFMANEXT=.5
171
172 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcpd
173 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp-relay
174 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/dhcp-relay
175 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/dhcpd.conf
176 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/dhcpd
177
178 mv $RPM_BUILD_ROOT%{_mandir}/man3/omshell.3 \
179         $RPM_BUILD_ROOT%{_mandir}/man1/omshell.1
180
181 install client/scripts/linux $RPM_BUILD_ROOT%{_sbindir}/dhclient-script
182
183 touch $RPM_BUILD_ROOT/var/lib/%{name}/{dhcpd,dhclient}.leases
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %post
189 /sbin/chkconfig --add dhcpd
190 touch /var/lib/%{name}/dhcpd.leases
191 if [ ! -d /var/lib/dhcp ]; then
192         install -d /var/lib/dhcp
193 fi
194 %service dhcpd restart "dhcpd daemon"
195
196 %preun
197 if [ "$1" = "0" ];then
198         %service dhcpd stop
199         /sbin/chkconfig --del dhcpd
200 fi
201
202 %post client
203 if [ ! -d /var/lib/dhcp ]; then
204         install -d /var/lib/dhcp
205 fi
206
207 %post relay
208 /sbin/chkconfig --add dhcp-relay
209 if [ -f /var/lock/subsys/dhcrelay ]; then
210         mv -f /var/lock/subsys/{dhcrelay,dhcp-relay}
211 fi
212 %service dhcp-relay restart "dhcrelay daemon"
213
214 %preun relay
215 if [ "$1" = "0" ];then
216         %service dhcp-relay stop
217         /sbin/chkconfig --del dhcp-relay
218 fi
219
220 %triggerpostun -- dhcp < 3.0
221 if [ "`grep ddns-update-style /etc/dhcpd.conf`" = "" ]; then
222         umask 027
223         echo "ddns-update-style none;" > /etc/dhcpd.conf.tmp
224         echo "" >> /etc/dhcpd.conf.tmp
225         cat /etc/dhcpd.conf >>/etc/dhcpd.conf.tmp
226         mv -f /etc/dhcpd.conf.tmp /etc/dhcpd.conf
227 fi
228
229 %files
230 %defattr(644,root,root,755)
231 %doc doc/* README RELNOTES dhcpd.conf.sample
232 %{?with_ldap:%doc contrib/*}
233 %{_mandir}/man1/*
234 %{_mandir}/man5/dhcp*
235 %{_mandir}/man8/dhcp*
236 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcpd
237 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcpd.conf
238 %attr(755,root,root) %{_bindir}/*
239 %attr(755,root,root) %{_sbindir}/dhcpd
240 %attr(754,root,root) /etc/rc.d/init.d/dhcpd
241 %attr(750,root,root) %dir /var/lib/%{name}
242 %ghost /var/lib/%{name}/dhcpd.leases
243
244 %files client
245 %defattr(644,root,root,755)
246 %attr(755,root,root) /sbin/dhclient
247 %attr(755,root,root) /sbin/dhclient-script
248 %{_mandir}/man[58]/dhclient*
249 %ghost /var/lib/%{name}/dhclient.leases
250
251 %files relay
252 %defattr(644,root,root,755)
253 %{_mandir}/man8/dhcrelay*
254 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp-relay
255 %attr(755,root,root) %{_sbindir}/dhcrelay
256 %attr(754,root,root) /etc/rc.d/init.d/dhcp-relay
257
258 %files devel
259 %defattr(644,root,root,755)
260 %{_mandir}/man3/*
261 %{_libdir}/*.a
262 %{_includedir}/*
This page took 0.72645 seconds and 4 git commands to generate.