]> git.pld-linux.org Git - packages/dhcp.git/blob - dhcp.spec
separeted to 2 packages
[packages/dhcp.git] / dhcp.spec
1 Summary:        DHCP Server 
2 Summary(pl):    Serwer DHCP 
3 Name:           dhcp
4 Version:        2.0
5 Release:        1
6 Group:          Networking/Daemons
7 Group(de):      Sieciowe/Serwery
8 Copyright:      ISC
9 Vendor:         PLD
10 Source0:        ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}.tar.gz
11 Source1:        dhcp.init
12 BuildRoot:      /tmp/%{name}-%{version}-root
13 Prereq:         /sbin/chkconfig
14
15 %description
16 Dynamic Host Configuration Protocol Server
17
18 %description -l pl
19 Serwer DHCP (Dynamic Host Configuration Protocol)
20
21 %package client
22 Summary:        DHCP Client
23 Summary(pl):    Klient DHCP 
24 Group:          Networking/Daemons
25 Group(de):      Sieciowe/Serwery
26
27 %description client
28 Dynamic Host Configuration Protocol Client
29
30 %description client -l pl
31 Klient DHCP (Dynamic Host Configuration Protocol)
32
33 %prep
34
35 %setup -q
36
37 %build
38
39 LDFLAGS="-s" ; export LDFLAGS
40 %configure
41
42 make COPTS="$RPM_OPT_FLAGS" DEBUG="" \
43         VARDB="/var/state/%{name}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_mandir}/man{5,8}} \
49         $RPM_BUILD_ROOT{/var/state/%{name},/etc/rc.d/init.d}
50
51 make install \
52         CLIENTBINDIR=$RPM_BUILD_ROOT/sbin \
53         BINDIR=$RPM_BUILD_ROOT%{_sbindir} \
54         ADMMANDIR=$RPM_BUILD_ROOT%{_mandir}/man8 \
55         ADMMANEXT=.8 \
56         FFMANDIR=$RPM_BUILD_ROOT%{_mandir}/man5 \
57         FFMANEXT=.5
58
59 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcpd
60
61 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
62           doc/* README RELNOTES CHANGES
63
64 touch $RPM_BUILD_ROOT/var/state/%{name}/dhcpd.leases
65
66 %post
67 /sbin/chkconfig --add dhcpd
68
69 if [ -f /var/run/dhcpd.pid ]; then
70         /etc/rc.d/init.d/dhcpd restart
71 fi
72
73 %preun
74 if [ $1 = 0 ];then
75         /etc/rc.d/init.d/dhcpd stop
76         /sbin/chkconfig --del dhcpd
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc doc/* README.gz RELNOTES.gz CHANGES.gz
84 %{_mandir}/man8/dhcrelay*
85 %{_mandir}/man5/dhcp*
86 %{_mandir}/man8/dhcp*
87 %attr(755,root,root) %{_sbindir}/dhcpd
88 %attr(755,root,root) %{_sbindir}/dhcrelay
89 %attr(755,root,root) /etc/rc.d/init.d/dhcpd
90 %attr(750,root,root) %dir /var/state/%{name}
91 %ghost /var/state/%{name}/dhcpd.leases
92
93 %files client
94 %attr(755,root,root) /sbin/dhclient
95 %{_mandir}/man8/dhclient*
96 %{_mandir}/man5/dhclient*
97
98 %changelog
99 * Fri Jul 2 1999 Bartosz Waszak <waszi@pld.org.pl>
100 - initial rpm release
This page took 0.060196 seconds and 4 git commands to generate.