]> git.pld-linux.org Git - packages/dhcp.git/blob - dhcp.spec
e590176fa6559e7abee3578fce58a4642d9e42a3
[packages/dhcp.git] / dhcp.spec
1 Summary:        DHCP Server 
2 Summary(pl):    Serwer DHCP 
3 Name:           dhcp
4 Version:        2.0
5 Release:        1
6 Serial:         1
7 Group:          Networking/Daemons
8 Group(de):      Sieciowe/Serwery
9 Copyright:      ISC
10 Vendor:         PLD
11 Source0:        ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}.tar.gz
12 Source1:        dhcp.init
13 BuildRoot:      /tmp/%{name}-%{version}-root
14 Prereq:         /sbin/chkconfig
15
16 %description
17 Dynamic Host Configuration Protocol Server
18
19 %description -l pl
20 Serwer DHCP (Dynamic Host Configuration Protocol)
21
22 %package client
23 Summary:        DHCP Client
24 Summary(pl):    Klient DHCP 
25 Group:          Networking/Daemons
26 Group(de):      Sieciowe/Serwery
27
28 %description client
29 Dynamic Host Configuration Protocol Client
30
31 %description client -l pl
32 Klient DHCP (Dynamic Host Configuration Protocol)
33
34 %prep
35
36 %setup -q
37
38 %build
39
40 LDFLAGS="-s" ; export LDFLAGS
41 %configure
42
43 make COPTS="$RPM_OPT_FLAGS" DEBUG="" \
44         VARDB="/var/state/%{name}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_mandir}/man{5,8}} \
50         $RPM_BUILD_ROOT{/var/state/%{name},/etc/rc.d/init.d}
51
52 make install \
53         CLIENTBINDIR=$RPM_BUILD_ROOT/sbin \
54         BINDIR=$RPM_BUILD_ROOT%{_sbindir} \
55         ADMMANDIR=$RPM_BUILD_ROOT%{_mandir}/man8 \
56         ADMMANEXT=.8 \
57         FFMANDIR=$RPM_BUILD_ROOT%{_mandir}/man5 \
58         FFMANEXT=.5
59
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcpd
61
62 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
63           doc/* README RELNOTES CHANGES
64
65 touch $RPM_BUILD_ROOT/var/state/%{name}/{dhcpd,dhclient}.leases
66
67 %post
68 /sbin/chkconfig --add dhcpd
69 touch /var/state/%{name}/dhcpd.leases
70
71 if [ -f /var/run/dhcpd.pid ]; then
72         /etc/rc.d/init.d/dhcpd restart
73 fi
74
75 %preun
76 if [ $1 = 0 ];then
77         /etc/rc.d/init.d/dhcpd stop
78         /sbin/chkconfig --del dhcpd
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc doc/* README.gz RELNOTES.gz CHANGES.gz
86 %{_mandir}/man8/dhcrelay*
87 %{_mandir}/man5/dhcp*
88 %{_mandir}/man8/dhcp*
89 %attr(755,root,root) %{_sbindir}/dhcpd
90 %attr(755,root,root) %{_sbindir}/dhcrelay
91 %attr(755,root,root) /etc/rc.d/init.d/dhcpd
92 %attr(750,root,root) %dir /var/state/%{name}
93 %ghost /var/state/%{name}/dhcpd.leases
94
95 %files client
96 %defattr(644,root,root,755)
97 %attr(755,root,root) /sbin/dhclient
98 %{_mandir}/man8/dhclient*
99 %{_mandir}/man5/dhclient*
100 %ghost /var/state/%{name}/dhclient.leases
101
102 %changelog
103 * Fri Jul 2 1999 Bartosz Waszak <waszi@pld.org.pl>
104 - initial rpm release
This page took 0.030813 seconds and 2 git commands to generate.