]> git.pld-linux.org Git - packages/dhcp.git/blob - dhcp.spec
b8fe14c06048d0a71bed14b2ec535e6709eebfcf
[packages/dhcp.git] / dhcp.spec
1 #
2 # Conditional build:
3 %bcond_with     ldap    # with support for ldap storage
4 #
5 Summary:        DHCP Server
6 Summary(es.UTF-8):      Servidor DHCP
7 Summary(pl.UTF-8):      Serwer DHCP
8 Summary(pt_BR.UTF-8):   Servidor DHCP (Protocolo de configuração dinâmica de hosts)
9 Name:           dhcp
10 %define _pre    a3
11 Version:        3.1.0
12 Release:        0.%{_pre}.1
13 Epoch:          4
14 License:        distributable
15 Group:          Networking/Daemons
16 Source0:        ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}%{_pre}.tar.gz
17 # Source0-md5:  d09be1a80982b78482e8fbd416924468
18 Source1:        %{name}.init
19 Source2:        %{name}-relay.init
20 Source3:        %{name}-relay.sysconfig
21 Source4:        %{name}d.conf.sample
22 Source5:        %{name}.sysconfig
23 Patch0:         %{name}-dhclient.script.patch
24 Patch1:         %{name}-if_buffer_size.patch
25 # http://home.ntelos.net/~masneyb/dhcp-3.0.5-ldap-patch
26 Patch2:         %{name}-ldap.patch
27 Patch3:         %{name}-client-script-redhat.patch
28 Patch4:         %{name}-3.0.3-x-option.patch
29 Patch5:         %{name}-typo.patch
30 Patch6:         %{name}-arg-concat.patch
31 Patch7:         %{name}-split-VARDB.patch
32 URL:            http://www.isc.org/sw/dhcp/
33 BuildRequires:  groff
34 %{?with_ldap:BuildRequires:     openldap-devel}
35 %{?with_ldap:BuildRequires:     openssl-devel}
36 BuildRequires:  rpmbuild(macros) >= 1.268
37 Requires(post): fileutils
38 Requires(post,preun):   /sbin/chkconfig
39 Requires:       rc-scripts >= 0.2.0
40 Provides:       dhcpd
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
45 individual devices on an IP network to get their own network
46 configuration information (IP address, subnetmask, broadcast address,
47 etc.) from a DHCP server. The overall purpose of DHCP is to make it
48 easier to administer a large network.
49
50 %description -l es.UTF-8
51 DHCP permite que hosts en una red TCP/IP soliciten y tengan sus
52 direcciones IP alocadas dinámicamente, permite también descubrir
53 información sobre la red en que están conectados. BOOTP provee una
54 funcionalidad similar, con ciertas restricciones. Este servidor
55 también las atiende.
56
57 %description -l pl.UTF-8
58 Serwer DHCP (Dynamic Host Configuration Protocol).
59
60 DHCP to protokół pozwalający urządzeniom pracującym w sieci IP na
61 pobieranie ich konfiguracji IP (adresu, maski podsieci, adresu
62 rozgłoszeniowego itp.) z serwera DHCP. Ułatwia on administrowanie
63 dużymi sieciami IP.
64
65 %description -l pt_BR.UTF-8
66 DHCP permite que hosts numa rede TCP/IP requisitem e tenham seus
67 endereços IP alocados dinamicamente, permite também descobrir
68 informações sobre a rede em que estão conectados. BOOTP provê uma
69 funcionalidade similar, com certas restrições. Este servidor também
70 atende aquelas requisições. Esta versão é ainda considerada um
71 software BETA.
72
73 %package client
74 Summary:        DHCP Client
75 Summary(pl.UTF-8):      Klient DHCP
76 Group:          Networking/Daemons
77 Requires(post): fileutils
78 Requires:       coreutils
79 Requires:       iproute2
80 Requires:       net-tools
81 Obsoletes:      dhclient
82 Obsoletes:      pump
83
84 %description client
85 Dynamic Host Configuration Protocol Client.
86
87 %description client -l pl.UTF-8
88 Klient DHCP (Dynamic Host Configuration Protocol).
89
90 %package relay
91 Summary:        DHCP Relay Agent
92 Summary(pl.UTF-8):      Agent przekazywania informacji DHCP
93 Group:          Networking/Daemons
94 Requires(post): fileutils
95 Requires(post,preun):   /sbin/chkconfig
96 Requires:       rc-scripts >= 0.2.0
97
98 %description relay
99 Dhcp relay is a relay agent for DHCP packets. It is used on a subnet
100 with DHCP clients to "relay" their requests to a subnet that has a
101 DHCP server on it. Because DHCP packets can be broadcast, they will
102 not be routed off of the local subnet. The DHCP relay takes care of
103 this for the client.
104
105 %description relay -l pl.UTF-8
106 Agent przekazywania DHCP (Dynamic Host Configuration Protocol) między
107 podsieciami. Ponieważ komunikaty DHCP mogą być przekazywane w formie
108 rozgłoszeniowej, bez tego agenta nie zostaną przerutowane do innej
109 podsieci.
110
111 %package devel
112 Summary:        DHCP development includes and libs
113 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki dla oprogramowania DHCP
114 Group:          Development/Libraries
115
116 %description devel
117 Includes OMAPI and dhcptl libraries.
118
119 OMAPI is an programming layer designed for controlling remote
120 applications, and for querying them for their state. It is currently
121 used by the ISC DHCP server.
122
123 The dhcpctl set of functions provide an API that can be used to
124 communicate with and manipulate a running ISC DHCP server.
125
126 %description devel -l pl.UTF-8
127 Zawiera biblioteki OMAPI oraz dhcpctl.
128
129 OMAPI to warstwa programowa stworzona do kontroli zdalnych aplikacji i
130 odpytywania o ich stan. Aktualnie jest używana przez serwer ISC DHCP.
131
132 dhcpctl to zbiór funkcji tworzących API, które może być używane do
133 komunikacji z działającym serwerem ISC DHCP i jego kontroli.
134
135 %prep
136 %setup -q -n %{name}-%{version}%{_pre}
137 install %{SOURCE4} .
138 %patch0 -p1
139 %patch1 -p1
140 %{?with_ldap:%patch2 -p1}
141 # These two patches are required for dhcdbd to function
142 %patch3 -p1
143 %patch4 -p1
144 #
145 %patch5 -p1
146 %patch6 -p1
147 %patch7 -p1
148
149 %build
150 # NOTE: this is not autoconf configure - do not change it to %%configure
151 ./configure
152
153 %{__make} \
154         CC="%{__cc}" \
155         CC_OPTIONS="%{rpmcflags} \
156                 -D_PATH_DHCPD_DB=\\\"/var/lib/%{name}/dhcpd.leases\\\" \
157                 -DEXTENDED_NEW_OPTION_INFO \
158                 -D_PATH_DHCLIENT_DB=\\\"/var/lib/dhclient/dhclient.leases\\\" \
159         "
160         LFLAGS="%{rpmldflags}" \
161         DEBUG="" \
162         VARDBS="/var/lib/%{name}"
163         VARDBC="/var/lib/dhclient"
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT{/sbin,%{_sbindir},%{_bindir},%{_mandir}/man{5,8}} \
168         $RPM_BUILD_ROOT{/var/lib/%{name},%{_sysconfdir}/{rc.d/init.d,sysconfig}}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT \
172         CLIENTBINDIR=/sbin \
173         BINDIR=%{_sbindir} \
174         LIBDIR=%{_libdir} \
175         INCDIR=%{_includedir} \
176         ADMMANDIR=%{_mandir}/man8 \
177         ADMMANEXT=.8 \
178         FFMANDIR=%{_mandir}/man5 \
179         LIBMANDIR=%{_mandir}/man3 \
180         LIBMANEXT=.3 \
181         USRMANDIR=%{_mandir}/man1 \
182         USRMANEXT=.1 \
183         VARDBS=/var/lib/%{name} \
184         VARDBC=/var/lib/dhclient \
185         FFMANEXT=.5
186
187 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcpd
188 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp-relay
189 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/dhcp-relay
190 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/dhcpd.conf
191 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/dhcpd
192
193 mv $RPM_BUILD_ROOT%{_mandir}/man3/omshell.3 \
194         $RPM_BUILD_ROOT%{_mandir}/man1/omshell.1
195
196 install client/scripts/linux $RPM_BUILD_ROOT%{_sbindir}/dhclient-script
197
198 touch $RPM_BUILD_ROOT/var/lib/%{name}/dhcpd.leases
199 touch $RPM_BUILD_ROOT/var/lib/dhclient/dhclient.leases
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post
205 /sbin/chkconfig --add dhcpd
206 touch /var/lib/%{name}/dhcpd.leases
207 %service dhcpd restart "dhcpd daemon"
208
209 %preun
210 if [ "$1" = "0" ];then
211         %service dhcpd stop
212         /sbin/chkconfig --del dhcpd
213 fi
214
215 %post client
216 if [ -f /var/lib/dhcp/dhclient.leases.rpmsave ]; then
217         mv /var/lib/dhcp/dhclient.leases.rpmsave /var/lib/dhclient/dhclient.leases
218 fi
219
220 %post relay
221 /sbin/chkconfig --add dhcp-relay
222 if [ -f /var/lock/subsys/dhcrelay ]; then
223         mv -f /var/lock/subsys/{dhcrelay,dhcp-relay}
224 fi
225 %service dhcp-relay restart "dhcrelay daemon"
226
227 %preun relay
228 if [ "$1" = "0" ];then
229         %service dhcp-relay stop
230         /sbin/chkconfig --del dhcp-relay
231 fi
232
233 %triggerpostun -- dhcp < 3.0
234 if [ "`grep ddns-update-style /etc/dhcpd.conf`" = "" ]; then
235         umask 027
236         echo "ddns-update-style none;" > /etc/dhcpd.conf.tmp
237         echo "" >> /etc/dhcpd.conf.tmp
238         cat /etc/dhcpd.conf >>/etc/dhcpd.conf.tmp
239         mv -f /etc/dhcpd.conf.tmp /etc/dhcpd.conf
240 fi
241
242 %files
243 %defattr(644,root,root,755)
244 %doc doc/* README RELNOTES dhcpd.conf.sample LICENSE
245 %{?with_ldap:%doc contrib/*}
246 %{_mandir}/man1/*
247 %{_mandir}/man5/dhcp*
248 %{_mandir}/man8/dhcp*
249 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcpd
250 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcpd.conf
251 %attr(755,root,root) %{_bindir}/*
252 %attr(755,root,root) %{_sbindir}/dhcpd
253 %attr(754,root,root) /etc/rc.d/init.d/dhcpd
254 %attr(750,root,root) %dir /var/lib/%{name}
255 %ghost /var/lib/%{name}/dhcpd.leases
256
257 %files client
258 %defattr(644,root,root,755)
259 %attr(755,root,root) /sbin/dhclient
260 %attr(755,root,root) /sbin/dhclient-script
261 %{_mandir}/man[58]/dhclient*
262 %attr(750,root,root) %dir /var/lib/dhclient
263 %ghost /var/lib/dhclient/dhclient.leases
264
265 %files relay
266 %defattr(644,root,root,755)
267 %{_mandir}/man8/dhcrelay*
268 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp-relay
269 %attr(755,root,root) %{_sbindir}/dhcrelay
270 %attr(754,root,root) /etc/rc.d/init.d/dhcp-relay
271
272 %files devel
273 %defattr(644,root,root,755)
274 %{_mandir}/man3/*
275 %{_libdir}/*.a
276 %{_includedir}/*
This page took 0.0565600000000001 seconds and 3 git commands to generate.