]> git.pld-linux.org Git - packages/device-mapper.git/blob - device-mapper.spec
128b37d9d2cd6caf5c240de05766cb4314281d9a
[packages/device-mapper.git] / device-mapper.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        Userspace support for the device-mapper
6 Summary(pl):    Wsparcie dla mapowania urz±dzeñ w przestrzeni u¿ytkownika
7 Name:           device-mapper
8 Version:        1.01.02
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://sources.redhat.com/pub/dm/%{name}.%{version}.tgz
13 # Source0-md5:  6c90d1782e8600aa8b5b0749056e29fb
14 Patch0:         %{name}-stack.patch
15 URL:            http://sources.redhat.com/dm/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
19 %{?with_selinux:Requires:       libselinux >= 1.10}
20 Conflicts:      dev < 2.9.0-8
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sbindir        /sbin
24
25 %description
26 The goal of this driver is to support volume management.
27 The driver enables the definition of new block devices composed of
28 ranges of sectors of existing devices. This can be used to define
29 disk partitions - or logical volumes. This light-weight kernel
30 component can support user-space tools for logical volume management.
31
32 %description -l pl
33 Celem tego sterownika jest obs³uga zarz±dzania wolumenami.
34 Sterownik w³±cza definiowanie nowych urz±dzeñ blokowych z³o¿onych z
35 przedzia³ów sektorów na istniej±cych urz±dzeniach. Mo¿e to byæ
36 wykorzystane do definiowania partycji na dysku lub logicznych
37 wolumenów. Ten lekki sk³adnik j±dra mo¿e wspieraæ dzia³aj±ce w
38 przestrzeni u¿ytkownika narzêdzia do zarz±dzania logicznymi
39 wolumenami.
40
41 %package devel
42 Summary:        Header files and development documentation for %{name}
43 Summary(pl):    Pliki nag³ówkowe i dokumentacja do %{name}
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files and development documentation for %{name}.
49
50 %description devel -l pl
51 Pliki nag³ówkowe i dokumentacja do %{name}.
52
53 %package static
54 Summary:        Static devmapper library
55 Summary(pl):    Statyczna biblioteka devmapper
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static devmapper library.
61
62 %description static -l pl
63 Statyczna biblioteka devmapper.
64
65 %package scripts
66 Summary:        Additional scripts
67 Summary(pl):    Dodatkowe skrypty
68 Group:          Applications/System
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       util-linux
71
72 %description scripts
73 Additional scripts.
74
75 %description scripts -l pl
76 Dodatkowe skrypty.
77
78 %prep
79 %setup -q -n %{name}.%{version}
80 %patch0 -p1
81
82 %build
83 cp -f /usr/share/automake/config.sub autoconf
84 %{__aclocal}
85 %{__autoconf}
86 %configure \
87         SELINUX=%{?with_selinux:yes}%{!?with_selinux:no} \
88         --with-optimisation="%{rpmcflags}" \
89         --with-user=%(id -u) \
90         --with-group=%(id -g) \
91         --with-interface=ioctl
92 %{__make}
93
94 ar cru libdevmapper.a lib/ioctl/*.o lib/*.o
95 ranlib libdevmapper.a
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT/{%{_lib},%{_libdir}/%{name}}
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 SONAME=$(basename $(ls -1 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*))
105 ln -sf /%{_lib}/${SONAME} $RPM_BUILD_ROOT%{_libdir}/libdevmapper.so
106 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
107 install scripts/* $RPM_BUILD_ROOT/%{_libdir}/%{name}
108
109 install libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc INTRO INSTALL README scripts/*
120 %attr(755,root,root) %{_sbindir}/*
121 %attr(755,root,root) /%{_lib}/lib*.so.*.*
122 %{_mandir}/man8/*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libdevmapper.so
127 %{_includedir}/*.h
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
132
133 %files scripts
134 %defattr(644,root,root,755)
135 %dir %{_libdir}/%{name}
136 %{_libdir}/%{name}/*
This page took 0.079653 seconds and 3 git commands to generate.