]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
9cfc6378833907afb6fb69b3c054574ad9d4138b
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w Pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.3
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://download.deluge-torrent.org/stable/%{name}-%{version}.tar.gz
9 # Source0-md5:  9e7b36bb946c5a1ddae0ffa9944a17e3
10 #Source1:       %{name}-fixed-setup.py
11 Patch0:         %{name}-pld.patch
12 URL:            http://deluge-torrent.org/
13 BuildRequires:  boost-program_options-devel
14 BuildRequires:  boost-regex-devel
15 BuildRequires:  desktop-file-utils
16 BuildRequires:  libtool
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rb_libtorrent-devel
19 BuildRequires:  rpm-pythonprov
20 Requires:       /bin/sh
21 Requires:       python-dbus
22 Requires:       python-pygtk-glade
23 Requires:       python-pyxdg
24 Requires:       rb_libtorrent
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Deluge is a new BitTorrent client, created using Python and GTK+. It
29 is intended to bring a native, full-featured client to Linux GTK+
30 desktop environments such as GNOME and XFCE. It supports features such
31 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
32 allow one to more easily share BitTorrent data even from behind a
33 router with virtually zero configuration of port-forwarding.
34
35 %description -l pl.UTF-8
36 Deluge to nowy klient BitTorrenta stworzony przy użyciu Pythona i
37 GTK+. Jego celem jest dostarczenie natywnego, w pełni funkcjonalnego
38 klienta dla środowisk GTK+ pod Linuksem, takich jak GNOME czy XFCE.
39 Obsługuje m.in. DHT (Distributed Hash Tables) i UPnP (Universal
40 Plug-n-Play), co pozwala łatwiej współdzielić dane BitTorrenta nawet
41 zza routera praktycznie bez konfiguracji przekierowywania portów.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 ## We forcibly don't store the installation directory during the build, so
49 ## we need to ensure that it is properly inserted into the code as required.
50 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
51         src/common.py
52 %ifarch %{x8664} ppc64 sparc64
53         CFLAGS="%{rpmcflags} -DAMD64" %{__python} setup.py build
54 %else
55         CFLAGS="%{rpmcflags}" %{__python} setup.py build
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
61
62 ## ...then strip the unneeded shebang lines from some of the plugins...
63 # this seems, wrong, we don't pkg the .py
64 # and if we do chmod -x on files should not fill autodeps
65 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
66
67 %find_lang %{name}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f %{name}.lang
73 %defattr(644,root,root,755)
74 %doc LICENSE
75 %attr(755,root,root) %{_bindir}/%{name}
76 %dir %{py_sitedir}/%{name}
77 %{py_sitedir}/%{name}/*.py[co]
78 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
79 %{py_sitedir}/%{name}-%{version}-py*.egg-info
80 %{_desktopdir}/%{name}.desktop
81 %{_pixmapsdir}/%{name}.png
82 %{_datadir}/%{name}
This page took 0.091126 seconds and 3 git commands to generate.