]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
35490418c77e049aba8ec6cb95165aa96dd63395
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w Pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.8
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://download.deluge-torrent.org/tarball/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  afcf4fcfa3b688cb8a5cc537eb22a32e
10 #Source1:       %{name}-fixed-setup.py
11 Patch0:         %{name}-pld.patch
12 Patch1:         %{name}-pyc.patch
13 URL:            http://deluge-torrent.org/
14 BuildRequires:  boost-program_options-devel
15 BuildRequires:  boost-regex-devel
16 BuildRequires:  desktop-file-utils
17 BuildRequires:  libtool
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rb_libtorrent-devel
20 BuildRequires:  rpm-pythonprov
21 Requires:       /bin/sh
22 Requires:       hicolor-icon-theme
23 Requires:       python-dbus
24 Requires:       python-pygtk-glade
25 Requires:       python-pyxdg
26 Requires:       rb_libtorrent
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Deluge is a new BitTorrent client, created using Python and GTK+. It
31 is intended to bring a native, full-featured client to Linux GTK+
32 desktop environments such as GNOME and XFCE. It supports features such
33 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
34 allow one to more easily share BitTorrent data even from behind a
35 router with virtually zero configuration of port-forwarding.
36
37 %description -l pl.UTF-8
38 Deluge to nowy klient BitTorrenta stworzony przy użyciu Pythona i
39 GTK+. Jego celem jest dostarczenie natywnego, w pełni funkcjonalnego
40 klienta dla środowisk GTK+ pod Linuksem, takich jak GNOME czy XFCE.
41 Obsługuje m.in. DHT (Distributed Hash Tables) i UPnP (Universal
42 Plug-n-Play), co pozwala łatwiej współdzielić dane BitTorrenta nawet
43 zza routera praktycznie bez konfiguracji przekierowywania portów.
44
45 %prep
46 %setup -q -n %{name}-torrent-%{version}
47 %patch0 -p1
48 %patch1 -p1
49
50 %build
51 ## We forcibly don't store the installation directory during the build, so
52 ## we need to ensure that it is properly inserted into the code as required.
53 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
54         src/common.py
55 %ifarch %{x8664} ppc64 sparc64
56         CFLAGS="%{rpmcflags} -DAMD64" %{__python} setup.py build
57 %else
58         CFLAGS="%{rpmcflags}" %{__python} setup.py build
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
64
65 ## ...then strip the unneeded shebang lines from some of the plugins...
66 # this seems, wrong, we don't pkg the .py
67 # and if we do chmod -x on files should not fill autodeps
68 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
69
70 %find_lang %{name}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %update_icon_cache hicolor
77
78 %postun
79 %update_icon_cache hicolor
80
81 %files -f %{name}.lang
82 %defattr(644,root,root,755)
83 %doc LICENSE
84 %attr(755,root,root) %{_bindir}/%{name}
85 %dir %{py_sitedir}/%{name}
86 %{py_sitedir}/%{name}/*.py[co]
87 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
88 %{py_sitedir}/%{name}-%{version}-py*.egg-info
89 %{_desktopdir}/%{name}.desktop
90 %{_pixmapsdir}/%{name}.png
91 %{_iconsdir}/hicolor/128x128/apps/deluge.png
92 %{_iconsdir}/hicolor/16x16/apps/deluge.png
93 %{_iconsdir}/hicolor/192x192/apps/deluge.png
94 %{_iconsdir}/hicolor/22x22/apps/deluge.png
95 %{_iconsdir}/hicolor/24x24/apps/deluge.png
96 %{_iconsdir}/hicolor/256x256/apps/deluge.png
97 %{_iconsdir}/hicolor/32x32/apps/deluge.png
98 %{_iconsdir}/hicolor/36x36/apps/deluge.png
99 %{_iconsdir}/hicolor/48x48/apps/deluge.png
100 %{_iconsdir}/hicolor/64x64/apps/deluge.png
101 %{_iconsdir}/hicolor/72x72/apps/deluge.png
102 %{_iconsdir}/hicolor/96x96/apps/deluge.png
103 %{_datadir}/%{name}
This page took 0.054415 seconds and 3 git commands to generate.