]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
2994c4a03151c0a0779083e40ade1b9c733c6a71
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w Pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.8
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://download.deluge-torrent.org/tarball/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  afcf4fcfa3b688cb8a5cc537eb22a32e
10 #Source1:       %{name}-fixed-setup.py
11 Patch0:         %{name}-pld.patch
12 Patch1:         %{name}-pyc.patch
13 URL:            http://deluge-torrent.org/
14 BuildRequires:  boost-array-devel
15 BuildRequires:  boost-filesystem-devel
16 BuildRequires:  boost-date_time-devel
17 BuildRequires:  boost-program_options-devel
18 BuildRequires:  boost-regex-devel
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  libtool
21 BuildRequires:  python-devel >= 1:2.5
22 BuildRequires:  rb_libtorrent-devel
23 BuildRequires:  rpm-pythonprov
24 Requires:       /bin/sh
25 Requires:       hicolor-icon-theme
26 Requires:       python-dbus
27 Requires:       python-gnome-extras-mozilla
28 Requires:       python-pygtk-glade
29 Requires:       python-pyxdg
30 Requires:       rb_libtorrent
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Deluge is a new BitTorrent client, created using Python and GTK+. It
35 is intended to bring a native, full-featured client to Linux GTK+
36 desktop environments such as GNOME and XFCE. It supports features such
37 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
38 allow one to more easily share BitTorrent data even from behind a
39 router with virtually zero configuration of port-forwarding.
40
41 %description -l pl.UTF-8
42 Deluge to nowy klient BitTorrenta stworzony przy użyciu Pythona i
43 GTK+. Jego celem jest dostarczenie natywnego, w pełni funkcjonalnego
44 klienta dla środowisk GTK+ pod Linuksem, takich jak GNOME czy XFCE.
45 Obsługuje m.in. DHT (Distributed Hash Tables) i UPnP (Universal
46 Plug-n-Play), co pozwala łatwiej współdzielić dane BitTorrenta nawet
47 zza routera praktycznie bez konfiguracji przekierowywania portów.
48
49 %prep
50 %setup -q -n %{name}-torrent-%{version}
51 %patch0 -p1
52 %patch1 -p1
53
54 %build
55 ## We forcibly don't store the installation directory during the build, so
56 ## we need to ensure that it is properly inserted into the code as required.
57 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
58         src/common.py
59 %ifarch %{x8664} ppc64 sparc64
60         CFLAGS="%{rpmcflags} -DAMD64" %{__python} setup.py build
61 %else
62         CFLAGS="%{rpmcflags}" %{__python} setup.py build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
68
69 ## ...then strip the unneeded shebang lines from some of the plugins...
70 # this seems, wrong, we don't pkg the .py
71 # and if we do chmod -x on files should not fill autodeps
72 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
73
74 %find_lang %{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 %update_icon_cache hicolor
81
82 %postun
83 %update_icon_cache hicolor
84
85 %files -f %{name}.lang
86 %defattr(644,root,root,755)
87 %doc LICENSE
88 %attr(755,root,root) %{_bindir}/%{name}
89 %dir %{py_sitedir}/%{name}
90 %{py_sitedir}/%{name}/*.py[co]
91 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
92 %{py_sitedir}/%{name}-%{version}-py*.egg-info
93 %{_desktopdir}/%{name}.desktop
94 %{_pixmapsdir}/%{name}.png
95 %{_iconsdir}/hicolor/128x128/apps/deluge.png
96 %{_iconsdir}/hicolor/16x16/apps/deluge.png
97 %{_iconsdir}/hicolor/192x192/apps/deluge.png
98 %{_iconsdir}/hicolor/22x22/apps/deluge.png
99 %{_iconsdir}/hicolor/24x24/apps/deluge.png
100 %{_iconsdir}/hicolor/256x256/apps/deluge.png
101 %{_iconsdir}/hicolor/32x32/apps/deluge.png
102 %{_iconsdir}/hicolor/36x36/apps/deluge.png
103 %{_iconsdir}/hicolor/48x48/apps/deluge.png
104 %{_iconsdir}/hicolor/64x64/apps/deluge.png
105 %{_iconsdir}/hicolor/72x72/apps/deluge.png
106 %{_iconsdir}/hicolor/96x96/apps/deluge.png
107 %{_datadir}/%{name}
This page took 0.849437 seconds and 2 git commands to generate.