]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- "s-/usr/lib/-%{_libdir}-"
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Name:           ddd
3 Version:        3.1.4
4 Release:        2
5 Copyright:      GPL
6 Group:          Development/Debuggers
7 Group(pl):      Programowanie/Odpluskwiacze
8 Source:         ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
9 Patch:          ddd-pty.patch
10 Icon:           ddd.xpm
11 URL:            http://www.cs.tu-bs.de/softech/ddd/
12 Buildroot:      /tmp/%{name}-%{version}-root
13
14 %description
15 The Data Display Debugger (DDD) is a common graphical user interface for
16 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
17 front-end features such as viewing source texts, DDD provides a graphical
18 data display, where data structures are displayed as graphs.  A simple mouse
19 click dereferences pointers or views structure contents, updated each time
20 the program stops.  Using DDD, you can reason about your application by
21 viewing its data, not just by viewing it execute lines of source code. 
22 Other DDD features include: debugging of programs written in C, C++, Ada,
23 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
24 hypertext source navigation and lookup; breakpoint, backtrace, and history
25 editors; preferences and settings editors; program execution in terminal
26 emulator window; debugging on remote host; on-line manual; interactive help
27 on the Motif user interface; GDB/DBX/XDB command-line interface with full
28 editing, history, search, and completion capabilities.  DDD has been
29 designed to compete with well-known commercial debuggers
30
31 %package python
32 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
33 Group:          Development/Debuggers
34 Group(pl):      Programowanie/Odpluskwiacze
35 Requires:       %{name} = %{version}
36
37 %description python
38 Data Display Debugger - python debugger.
39
40 %prep
41 %setup -q
42 %patch -p1
43
44 %build
45 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
46 ./configure %{_target} \
47         --with-motif \
48         --prefix=/usr/X11R6
49 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/{lib/python-1.5,X11R6/lib/X11/app-defaults}}
54
55 make install prefix=$RPM_BUILD_ROOT/usr/X11R6
56
57 install pydb/pydb.py $RPM_BUILD_ROOT/usr/X11R6/bin
58 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT%{_libdir}/python-1.5
59
60 install ddd/Ddd $RPM_BUILD_ROOT/usr/X11R6/lib/X11/app-defaults
61 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man1/*
62
63 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd <<EOF
64 ddd name "DDD"
65 ddd description "Data Display Debuger"
66 ddd exec "/usr/X11R6/bin/ddd"
67 ddd group "Development"
68 EOF
69
70 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd-python <<EOF
71 ddd name "DDD for python"
72 ddd description "Data Display Debuger - python"
73 ddd exec "/usr/X11R6/bin/ddd --pydb"
74 ddd group "Development"
75 EOF
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644, root, root, 755)
82 %doc ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS TODO doc/sample.dddinit
83 /etc/X11/wmconfig/ddd
84 %attr(755, root, root) /usr/X11R6/bin/*
85
86 /usr/X11R6/lib/X11/app-defaults/Ddd
87
88 /usr/X11R6/man/man1/*
89
90 %files python
91 %defattr(644, root, root, 755)
92 /etc/X11/wmconfig/ddd-python
93 %attr(755,root,root) /usr/X11R6/bin/pydb.py
94 %{_libdir}/python*/*
95
96 %changelog
97 * Sun Mar 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
98   [3.1.4-1]
99 - removed man group from man pages,
100 - added Group(pl).
101
102 * Wed Dec  2 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
103   [3.1-1]
104 - based on spec written by Alec Habig <habig@budoe.bu.edu>,
105 - only one package is now generated,
106 - added -q %setup parameter,
107 - added gziping man pages,
108 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
109 - added using %%{name} and %%{version} in Source,
110 - removeda all %post{un} scripts,
111 - added package Icon,
112 - added python subpackage,
113 - removed Packager field (this must be placed in private ~/.rpmrc),
114 - added %attr and %defattr macros in %files (allows build package from
115   non-root account).
This page took 0.096454 seconds and 4 git commands to generate.