]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- removed xpm-devel from BuildRequires.
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3
4 Summary:        X interface to the GDB, DBX and XDB debuggers
5 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
6 Name:           ddd
7 Version:        3.2.1
8 Release:        3
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
13 Source1:        ddd.desktop
14 Source2:        ddd-python.desktop
15 Patch0:         ddd-DESTDIR.patch
16 Icon:           ddd.xpm
17 URL:            http://www.gnu.org/software/ddd/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  motif-devel
20 BuildRequires:  ncurses-devel >= 5.0
21 BuildRequires:  libstdc++-devel
22 Requires:       gdb
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _prefix         /usr/X11R6
26 %define         _mandir         %{_prefix}/man
27
28 %description
29 The Data Display Debugger (DDD) is a common graphical user interface
30 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
31 ``classical'' front-end features such as viewing source texts, DDD
32 provides a graphical data display, where data structures are displayed
33 as graphs. A simple mouse click dereferences pointers or views
34 structure contents, updated each time the program stops. Using DDD,
35 you can reason about your application by viewing its data, not just by
36 viewing it execute lines of source code. Other DDD features include:
37 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
38 Modula-2, or Modula-3; machine-level debugging; hypertext source
39 navigation and lookup; breakpoint, backtrace, and history editors;
40 preferences and settings editors; program execution in terminal
41 emulator window; debugging on remote host; on-line manual; interactive
42 help on the Motif user interface; GDB/DBX/XDB command-line interface
43 with full editing, history, search, and completion capabilities. DDD
44 has been designed to compete with well-known commercial debuggers
45
46 %description -l pl
47 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
48 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
49 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
50 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
51 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
52 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
53 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
54 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
55 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
56 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
57 ustawiania preferencji; uruchamianie programów w oknie terminala;
58 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
59 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
60 wyszukiwaniem.
61
62 %package python
63 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
64 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
65 Group:          Development/Debuggers
66 Group(pl):      Programowanie/Odpluskwiacze
67 Requires:       %{name} = %{version}
68
69 %description python
70 Data Display Debugger - python debugger.
71
72 %description -l pl
73 Data Display Debugger - debugger pythona.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 LDFLAGS="-s"; export LDFLAGS
81 %configure \
82         --with-motif
83 %{__make} CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
88         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
89         $RPM_BUILD_ROOT%{_applnkdir}/Development 
90
91 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
92
93 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
94 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT%{python_sitepkgsdir}
95
96 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
97
98 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
99
100 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
101         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
108 %doc doc/sample.dddinit
109 %{_applnkdir}/Development/ddd.desktop
110 %attr(755,root,root) %{_bindir}/ddd
111 %{_libdir}/X11/app-defaults/Ddd
112 %{_mandir}/man1/*
113
114 %files python
115 %defattr(644,root,root,755)
116 %{_applnkdir}/Development/ddd-python.desktop
117 %attr(755,root,root) %{_bindir}/pydb
118 %{python_sitepkgsdir}/*
This page took 0.112793 seconds and 4 git commands to generate.