]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
b67bf540812d3b00a02730ed8156a1e172c2553e
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('pydb')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('pydb')"
5
6 Summary:        X interface to the GDB, DBX and XDB debuggers
7 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
8 Name:           ddd
9 Version:        3.3.1
10 Release:        6
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
16 Source1:        %{name}.desktop
17 Source2:        %{name}-python.desktop
18 Patch0:         %{name}-DESTDIR.patch
19 Patch1:         %{name}-ptrace.patch
20 Patch2:         %{name}-info.patch
21 Icon:           ddd.xpm
22 URL:            http://www.gnu.org/software/ddd/
23 BuildRequires:  XFree86-devel
24 BuildRequires:  motif-devel
25 BuildRequires:  ncurses-devel >= 5.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  python
28 BuildRequires:  texinfo
29 Requires:       gdb
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _prefix         /usr/X11R6
33 %define         _mandir         %{_prefix}/man
34
35 %description
36 The Data Display Debugger (DDD) is a common graphical user interface
37 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
38 ``classical'' front-end features such as viewing source texts, DDD
39 provides a graphical data display, where data structures are displayed
40 as graphs. A simple mouse click dereferences pointers or views
41 structure contents, updated each time the program stops. Using DDD,
42 you can reason about your application by viewing its data, not just by
43 viewing it execute lines of source code. Other DDD features include:
44 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
45 Modula-2, or Modula-3; machine-level debugging; hypertext source
46 navigation and lookup; breakpoint, backtrace, and history editors;
47 preferences and settings editors; program execution in terminal
48 emulator window; debugging on remote host; on-line manual; interactive
49 help on the Motif user interface; GDB/DBX/XDB command-line interface
50 with full editing, history, search, and completion capabilities. DDD
51 has been designed to compete with well-known commercial debuggers
52
53 %description -l pl
54 Data Display Debugger (DDD) jest typowym graficznym interfejsem do GDB,
55 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
56 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
57 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
58 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
59 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
60 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
61 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
62 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
63 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
64 ustawiania preferencji; uruchamianie programów w oknie terminala;
65 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
66 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
67 wyszukiwaniem.
68
69 %package python
70 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
71 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debugger pythona
72 Group:          Development/Debuggers
73 Group(de):      Entwicklung/Debugger
74 Group(pl):      Programowanie/Odpluskwiacze
75 Requires:       %{name} = %{version}
76
77 %description python
78 Data Display Debugger - python debugger.
79
80 %description -l pl
81 Data Display Debugger - debugger pythona.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 %build
90 automake -a -c
91 %configure2_13 \
92         --with-motif
93 %{__make} CXXOPT="-DNDEBUG %{rpmcflags}"
94 %python_compile
95 %python_compile_opt 
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
100         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
101         $RPM_BUILD_ROOT%{_applnkdir}/Development
102
103 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
104
105 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
106 install pydb/{pydbcmd,pydbsupt}.py[co] $RPM_BUILD_ROOT%{python_sitepkgsdir}
107
108 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
109
110 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
111
112 gzip -9nf ANNOUNCE BUGS NEWS* OPENBUGS PROBLEMS README TIPS
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
119
120 %postun
121 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
122
123 %files
124 %defattr(644,root,root,755)
125 %doc {ANNOUNCE,BUGS,NEWS*,OPENBUGS,PROBLEMS,README,TIPS}.gz
126 %doc doc/sample.dddinit
127 %{_applnkdir}/Development/ddd.desktop
128 %attr(755,root,root) %{_bindir}/ddd
129 %{_libdir}/X11/app-defaults/Ddd
130 %{_mandir}/man1/*
131 %{_datadir}/ddd*
132 %{_infodir}/ddd*
133
134 %files python
135 %defattr(644,root,root,755)
136 %{_applnkdir}/Development/ddd-python.desktop
137 %attr(755,root,root) %{_bindir}/pydb
138 %{python_sitepkgsdir}/*
This page took 0.06941 seconds and 3 git commands to generate.