]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- spec adapterized,
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('pydb')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('pydb')"
5
6 Summary:        X interface to the GDB, DBX and XDB debuggers
7 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
8 Name:           ddd
9 Version:        3.3
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
16 Source1:        %{name}.desktop
17 Source2:        %{name}-python.desktop
18 Patch0:         %{name}-DESTDIR.patch
19 Icon:           ddd.xpm
20 URL:            http://www.gnu.org/software/ddd/
21 BuildRequires:  XFree86-devel
22 BuildRequires:  motif-devel
23 BuildRequires:  ncurses-devel >= 5.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  python
26 BuildRequires:  texinfo
27 Requires:       gdb
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _prefix         /usr/X11R6
31 %define         _mandir         %{_prefix}/man
32
33 %description
34 The Data Display Debugger (DDD) is a common graphical user interface
35 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
36 ``classical'' front-end features such as viewing source texts, DDD
37 provides a graphical data display, where data structures are displayed
38 as graphs. A simple mouse click dereferences pointers or views
39 structure contents, updated each time the program stops. Using DDD,
40 you can reason about your application by viewing its data, not just by
41 viewing it execute lines of source code. Other DDD features include:
42 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
43 Modula-2, or Modula-3; machine-level debugging; hypertext source
44 navigation and lookup; breakpoint, backtrace, and history editors;
45 preferences and settings editors; program execution in terminal
46 emulator window; debugging on remote host; on-line manual; interactive
47 help on the Motif user interface; GDB/DBX/XDB command-line interface
48 with full editing, history, search, and completion capabilities. DDD
49 has been designed to compete with well-known commercial debuggers
50
51 %description -l pl
52 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
53 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
54 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
55 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
56 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
57 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
58 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
59 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
60 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
61 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
62 ustawiania preferencji; uruchamianie programów w oknie terminala;
63 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
64 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
65 wyszukiwaniem.
66
67 %package python
68 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
69 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
70 Group:          Development/Debuggers
71 Group(de):      Entwicklung/Debugger
72 Group(pl):      Programowanie/Odpluskwiacze
73 Requires:       %{name} = %{version}
74
75 %description python
76 Data Display Debugger - python debugger.
77
78 %description -l pl
79 Data Display Debugger - debugger pythona.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84
85 %build
86 automake -a -c
87 %configure \
88         --with-motif
89 %{__make} CXXOPT="-DNDEBUG %{?debug:-O -g}%{!?debug:$RPM_OPT_FLAGS}"
90 %python_compile
91 %python_compile_opt 
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
96         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
97         $RPM_BUILD_ROOT%{_applnkdir}/Development
98
99 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
100
101 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
102 install pydb/{pydbcmd,pydbsupt}.py[co] $RPM_BUILD_ROOT%{python_sitepkgsdir}
103
104 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
105
106 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
107
108 gzip -9nf ANNOUNCE BUGS NEWS* OPENBUGS PROBLEMS README TIPS
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115
116 %postun
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %files
120 %defattr(644,root,root,755)
121 %doc {ANNOUNCE,BUGS,NEWS*,OPENBUGS,PROBLEMS,README,TIPS}.gz
122 %doc doc/sample.dddinit
123 %{_applnkdir}/Development/ddd.desktop
124 %attr(755,root,root) %{_bindir}/ddd
125 %{_libdir}/X11/app-defaults/Ddd
126 %{_mandir}/man1/*
127 %{_datadir}/ddd*
128 %{_infodir}/ddd*
129
130 %files python
131 %defattr(644,root,root,755)
132 %{_applnkdir}/Development/ddd-python.desktop
133 %attr(755,root,root) %{_bindir}/pydb
134 %{python_sitepkgsdir}/*
This page took 0.034694 seconds and 3 git commands to generate.