]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
9511c30dfa9d73ac324f7d67371db454667f084c
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Name:           ddd
3 Version:        3.1.5
4 Release:        1
5 Copyright:      GPL
6 Group:          Development/Debuggers
7 Group(pl):      Programowanie/Odpluskwiacze
8 Source:         ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
9 Patch:          ddd-pty.patch
10 Icon:           ddd.xpm
11 URL:            http://www.cs.tu-bs.de/softech/ddd/
12 Buildroot:      /tmp/%{name}-%{version}-root
13
14 %define         _prefix /usr/X11R6
15 %define         _mandir /usr/X11R6/man
16
17 %description
18 The Data Display Debugger (DDD) is a common graphical user interface for
19 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
20 front-end features such as viewing source texts, DDD provides a graphical
21 data display, where data structures are displayed as graphs.  A simple mouse
22 click dereferences pointers or views structure contents, updated each time
23 the program stops.  Using DDD, you can reason about your application by
24 viewing its data, not just by viewing it execute lines of source code. 
25 Other DDD features include: debugging of programs written in C, C++, Ada,
26 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
27 hypertext source navigation and lookup; breakpoint, backtrace, and history
28 editors; preferences and settings editors; program execution in terminal
29 emulator window; debugging on remote host; on-line manual; interactive help
30 on the Motif user interface; GDB/DBX/XDB command-line interface with full
31 editing, history, search, and completion capabilities.  DDD has been
32 designed to compete with well-known commercial debuggers
33
34 %package python
35 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
36 Group:          Development/Debuggers
37 Group(pl):      Programowanie/Odpluskwiacze
38 Requires:       %{name} = %{version}
39
40 %description python
41 Data Display Debugger - python debugger.
42
43 %prep
44 %setup -q
45 #%patch -p1
46
47 %build
48 %configure --with-motif
49 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/lib/python-1.5,%{_libdir}/X11/app-defaults}
54
55 make install prefix=$RPM_BUILD_ROOT%{_prefix} \
56         mandir=$RPM_BUILD_ROOT%{_mandir} \
57         bindir=$RPM_BUILD_ROOT%{_bindir} \
58         libdir=$RPM_BUILD_ROOT%{_libdir}
59
60 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}
61 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python-1.5
62
63 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
64
65 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd <<EOF
66 ddd name "DDD"
67 ddd description "Data Display Debuger"
68 ddd exec "/usr/X11R6/bin/ddd"
69 ddd group "Development"
70 EOF
71
72 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd-python <<EOF
73 ddd name "DDD for python"
74 ddd description "Data Display Debuger - python"
75 ddd exec "/usr/X11R6/bin/ddd --pydb"
76 ddd group "Development"
77 EOF
78
79 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
80         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
87 %doc doc/sample.dddinit
88 /etc/X11/wmconfig/ddd
89 %attr(755,root,root) %{_bindir}/*
90 %{_libdir}/X11/app-defaults/Ddd
91 %{_mandir}/man1/*
92
93 %files python
94 %defattr(644,root,root,755)
95 /etc/X11/wmconfig/ddd-python
96 %attr(755,root,root) %{_bindir}/pydb.py
97 /usr/lib/python*/*
This page took 0.059071 seconds and 3 git commands to generate.