]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
93523f284318a0da040d87deea40a5446f104004
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
3 Name:           ddd
4 Version:        3.1.6
5 Release:        1
6 Copyright:      GPL
7 Group:          Development/Debuggers
8 Group(pl):      Programowanie/Odpluskwiacze
9 Source0:        ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
10 Source1:        ddd.desktop
11 Source2:        ddd-python.desktop
12 Icon:           ddd.xpm
13 URL:            http://www.cs.tu-bs.de/softech/ddd/
14 BuildRequires:  XFree86-devel
15 BuildRequires:  xpm-devel
16 BuildRequires:  lesstif-devel
17 BuildRequires:  ncurses-devel
18 BuildRequires:  libstdc++-devel
19 Requires:       gdb
20 Buildroot:      /tmp/%{name}-%{version}-root
21
22 %define         _prefix         /usr/X11R6
23 %define         _mandir         %{_prefix}/man
24
25 %description
26 The Data Display Debugger (DDD) is a common graphical user interface for
27 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
28 front-end features such as viewing source texts, DDD provides a graphical
29 data display, where data structures are displayed as graphs.  A simple mouse
30 click dereferences pointers or views structure contents, updated each time
31 the program stops.  Using DDD, you can reason about your application by
32 viewing its data, not just by viewing it execute lines of source code. 
33 Other DDD features include: debugging of programs written in C, C++, Ada,
34 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
35 hypertext source navigation and lookup; breakpoint, backtrace, and history
36 editors; preferences and settings editors; program execution in terminal
37 emulator window; debugging on remote host; on-line manual; interactive help
38 on the Motif user interface; GDB/DBX/XDB command-line interface with full
39 editing, history, search, and completion capabilities.  DDD has been
40 designed to compete with well-known commercial debuggers
41
42 %description -l pl
43 Data Display Debugger (DDD) jest typowm graficznym interfejsem do
44 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
45 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
46 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury wy¶wietlane
47 s± w postaci graficznej. Proste klikniêcie mysz± pozwala na przegl±danie
48 zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy program siê zatrzyma).
49 Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania programów napisanych w C, C++,
50 Ada, Fortran, Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie
51 maszyny; hypertekstowa nawigacja po ¼ród³ach; breakpoint, backtrace i emulator
52 okna historii; mo¿liwo¶æ ustawiania preferencji; uruchamianie programów w oknie
53 terminala; debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
54 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i wyszukiwaniem.
55
56 %package python
57 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
58 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
59 Group:          Development/Debuggers
60 Group(pl):      Programowanie/Odpluskwiacze
61 Requires:       %{name} = %{version}
62
63 %description python
64 Data Display Debugger - python debugger.
65
66 %description -l pl
67 Data Display Debugger - debugger pythona.
68
69 %prep
70 %setup -q
71
72 %build
73 LDFLAGS="-s"; export LDFLAGS
74 %configure \
75         --with-motif
76 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT/usr/lib/python1.5 \
81         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
82         $RPM_BUILD_ROOT%{_datadir}/applnk/Development 
83
84
85 make install prefix=$RPM_BUILD_ROOT%{_prefix} \
86         mandir=$RPM_BUILD_ROOT%{_mandir} \
87         bindir=$RPM_BUILD_ROOT%{_bindir} \
88         libdir=$RPM_BUILD_ROOT%{_libdir}
89
90 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
91 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python1.5
92
93 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
94
95 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/applnk/Development
96
97 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
98         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
105 %doc doc/sample.dddinit
106 %{_datadir}/applnk/Development/ddd.desktop
107 %attr(755,root,root) %{_bindir}/*
108 %{_libdir}/X11/app-defaults/Ddd
109 %{_mandir}/man1/*
110
111 %files python
112 %defattr(644,root,root,755)
113 %{_datadir}/applnk/Development/ddd-python.desktop
114 %attr(755,root,root) %{_bindir}/pydb
115 /usr/lib/python*/*
This page took 0.08825 seconds and 3 git commands to generate.