]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
7b701f3c4340057b346631c49b6c63e46d3e9276
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3
4 Summary:        X interface to the GDB, DBX and XDB debuggers
5 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
6 Name:           ddd
7 Version:        3.2.1
8 Release:        3
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
13 Source1:        ddd.desktop
14 Source2:        ddd-python.desktop
15 Patch0:         ddd-DESTDIR.patch
16 Icon:           ddd.xpm
17 URL:            http://www.gnu.org/software/ddd/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  xpm-devel
20 BuildRequires:  motif-devel
21 BuildRequires:  ncurses-devel >= 5.0
22 BuildRequires:  libstdc++-devel
23 Requires:       gdb
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _prefix         /usr/X11R6
27 %define         _mandir         %{_prefix}/man
28
29 %description
30 The Data Display Debugger (DDD) is a common graphical user interface
31 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
32 ``classical'' front-end features such as viewing source texts, DDD
33 provides a graphical data display, where data structures are displayed
34 as graphs. A simple mouse click dereferences pointers or views
35 structure contents, updated each time the program stops. Using DDD,
36 you can reason about your application by viewing its data, not just by
37 viewing it execute lines of source code. Other DDD features include:
38 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
39 Modula-2, or Modula-3; machine-level debugging; hypertext source
40 navigation and lookup; breakpoint, backtrace, and history editors;
41 preferences and settings editors; program execution in terminal
42 emulator window; debugging on remote host; on-line manual; interactive
43 help on the Motif user interface; GDB/DBX/XDB command-line interface
44 with full editing, history, search, and completion capabilities. DDD
45 has been designed to compete with well-known commercial debuggers
46
47 %description -l pl
48 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
49 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
50 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
51 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
52 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
53 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
54 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
55 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
56 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
57 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
58 ustawiania preferencji; uruchamianie programów w oknie terminala;
59 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
60 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
61 wyszukiwaniem.
62
63 %package python
64 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
65 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
66 Group:          Development/Debuggers
67 Group(pl):      Programowanie/Odpluskwiacze
68 Requires:       %{name} = %{version}
69
70 %description python
71 Data Display Debugger - python debugger.
72
73 %description -l pl
74 Data Display Debugger - debugger pythona.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 LDFLAGS="-s"; export LDFLAGS
82 %configure \
83         --with-motif
84 %{__make} CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
89         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
90         $RPM_BUILD_ROOT%{_applnkdir}/Development 
91
92 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
93
94 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
95 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT%{python_sitepkgsdir}
96
97 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
98
99 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
100
101 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
102         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
109 %doc doc/sample.dddinit
110 %{_applnkdir}/Development/ddd.desktop
111 %attr(755,root,root) %{_bindir}/ddd
112 %{_libdir}/X11/app-defaults/Ddd
113 %{_mandir}/man1/*
114
115 %files python
116 %defattr(644,root,root,755)
117 %{_applnkdir}/Development/ddd-python.desktop
118 %attr(755,root,root) %{_bindir}/pydb
119 %{python_sitepkgsdir}/*
This page took 0.14379 seconds and 3 git commands to generate.