]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
30f5903f37a4802da1b3613456fea752546f8eb8
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
3 Name:           ddd
4 Version:        3.1.6
5 Release:        1
6 Copyright:      GPL
7 Group:          Development/Debuggers
8 Group(pl):      Programowanie/Odpluskwiacze
9 Source0:        ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
10 Source1:        ddd.desktop
11 Source2:        ddd-python.desktop
12 Icon:           ddd.xpm
13 URL:            http://www.cs.tu-bs.de/softech/ddd/
14 Buildroot:      /tmp/%{name}-%{version}-root
15
16 %define         _prefix /usr/X11R6
17 %define         _mandir /usr/X11R6/man
18
19 %description
20 The Data Display Debugger (DDD) is a common graphical user interface for
21 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
22 front-end features such as viewing source texts, DDD provides a graphical
23 data display, where data structures are displayed as graphs.  A simple mouse
24 click dereferences pointers or views structure contents, updated each time
25 the program stops.  Using DDD, you can reason about your application by
26 viewing its data, not just by viewing it execute lines of source code. 
27 Other DDD features include: debugging of programs written in C, C++, Ada,
28 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
29 hypertext source navigation and lookup; breakpoint, backtrace, and history
30 editors; preferences and settings editors; program execution in terminal
31 emulator window; debugging on remote host; on-line manual; interactive help
32 on the Motif user interface; GDB/DBX/XDB command-line interface with full
33 editing, history, search, and completion capabilities.  DDD has been
34 designed to compete with well-known commercial debuggers
35
36 %description -l pl
37 Data Display Debugger (DDD) jest typowm graficznym interfejsem do
38 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
39 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
40 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury wy¶wietlane
41 s± w postaci graficznej. Proste klikniêcie mysz± pozwala na przegl±danie
42 zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy program siê zatrzyma).
43 Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania programów napisanych w C, C++,
44 Ada, Fortran, Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie
45 maszyny; hypertekstowa nawigacja po ¼ród³ach; brekpoin, backtrace i emulator
46 okna historii; mo¿liwo¶æ ustawiania preferencji; uruchamianie programów w oknie
47 terminala; debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
48 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i wyszukiwaniem.
49
50 %package python
51 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
52 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
53 Group:          Development/Debuggers
54 Group(pl):      Programowanie/Odpluskwiacze
55 Requires:       %{name} = %{version}
56
57 %description python
58 Data Display Debugger - python debugger.
59
60 %description -l pl
61 Data Display Debugger - debugger pythona.
62
63 %prep
64 %setup -q
65
66 %build
67 LDFLAGS="-s"; export LDFLAGS
68 %configure \
69         --with-motif
70 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT/{etc/X11/applnk/Development,usr/lib/python1.5,%{_libdir}/X11/app-defaults}
75
76 make install prefix=$RPM_BUILD_ROOT%{_prefix} \
77         mandir=$RPM_BUILD_ROOT%{_mandir} \
78         bindir=$RPM_BUILD_ROOT%{_bindir} \
79         libdir=$RPM_BUILD_ROOT%{_libdir}
80
81 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
82 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python1.5
83
84 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
85
86 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/X11/applnk/Development
87
88 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
89         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
96 %doc doc/sample.dddinit
97 /etc/X11/applnk/Development/ddd.desktop
98 %attr(755,root,root) %{_bindir}/*
99 %{_libdir}/X11/app-defaults/Ddd
100 %{_mandir}/man1/*
101
102 %files python
103 %defattr(644,root,root,755)
104 /etc/X11/applnk/Development/ddd-python.desktop
105 %attr(755,root,root) %{_bindir}/pydb
106 /usr/lib/python*/*
This page took 0.076062 seconds and 3 git commands to generate.