]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
2cf2caed0dad01cf2c53d16b517b999656a02c41
[packages/ddd.git] / ddd.spec
1 Summary:     X interface to the GDB, DBX and XDB debuggers
2 Name:        ddd
3 Version:     3.1.2
4 Release:     1
5 Source0:     ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
6 Copyright:   GPL
7 Group:       Development/Debuggers
8 Icon:        ddd.xpm
9 URL:         http://www.cs.tu-bs.de/softech/ddd/
10 Buildroot:   /tmp/%{name}-%{version}-root
11
12 %description
13 The Data Display Debugger (DDD) is a common graphical user interface for
14 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
15 front-end features such as viewing source texts, DDD provides a graphical
16 data display, where data structures are displayed as graphs.  A simple mouse
17 click dereferences pointers or views structure contents, updated each time
18 the program stops.  Using DDD, you can reason about your application by
19 viewing its data, not just by viewing it execute lines of source code. 
20 Other DDD features include: debugging of programs written in C, C++, Ada,
21 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
22 hypertext source navigation and lookup; breakpoint, backtrace, and history
23 editors; preferences and settings editors; program execution in terminal
24 emulator window; debugging on remote host; on-line manual; interactive help
25 on the Motif user interface; GDB/DBX/XDB command-line interface with full
26 editing, history, search, and completion capabilities.  DDD has been
27 designed to compete with well-known commercial debuggers
28
29 %package python
30 Summary:     X interface to the GDB, DBX and XDB debuggers - The python debugger
31 Group:       Development/Debuggers
32 Requires:    %{name} = %{version}
33
34 %description python
35 Data Display Debugger - python debugger.
36
37 %prep
38 %setup -q
39
40 %build
41 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
42 ./configure \
43         --with-motif \
44         --prefix=/usr/X11R6
45 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/{lib/python-1.5,X11R6/lib/X11/app-defaults}}
50
51 make install prefix=$RPM_BUILD_ROOT/usr/X11R6
52
53 install pydb/pydb.py $RPM_BUILD_ROOT/usr/X11R6/bin
54 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python-1.5
55
56 install ddd/Ddd $RPM_BUILD_ROOT/usr/X11R6/lib/X11/app-defaults
57 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man1/*
58
59 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd <<EOF
60 ddd name "DDD"
61 ddd description "Data Display Debuger"
62 ddd exec "/usr/X11R6/bin/ddd"
63 ddd group "Development"
64 EOF
65
66 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd-python <<EOF
67 ddd name "DDD for python"
68 ddd description "Data Display Debuger - python"
69 ddd exec "/usr/X11R6/bin/ddd --pydb"
70 ddd group "Development"
71 EOF
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644, root, root, 755)
78 %doc DOCS ANNOUNCE BUGS ChangeLog* NEWS* OPENBUGS PROBLEMS README TIPS TODO doc/sample.dddinit
79 /etc/X11/wmconfig/ddd
80 %attr(755, root, root) /usr/X11R6/bin/*
81 %attr(644, root,  man) /usr/X11R6/man/man1/*
82 /usr/X11R6/lib/X11/app-defaults/Ddd
83
84 %files python
85 %defattr(644, root, root, 755)
86 /etc/X11/wmconfig/ddd-python
87 %attr(755, root, root) /usr/X11R6/bin/pydb.py
88 /usr/lib/python-1.5/*
89
90 %changelog
91 * Wed Dec  2 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
92   [3.1-1]
93 - based on spec written by Alec Habig <habig@budoe.bu.edu>,
94 - only one package is now generated,
95 - added -q %setup parameter,
96 - added gziping man pages,
97 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
98 - added using %%{name} and %%{version} in Source,
99 - removeda all %post{un} scripts,
100 - added package Icon,
101 - added python subpackage,
102 - removed Packager field (this must be placed in private ~/.rpmrc),
103 - added %attr and %defattr macros in %files (allows build package from
104   non-root account).
This page took 0.04814 seconds and 3 git commands to generate.