]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
26b7b2b1c1e03ca2cb222e96a9da77cdf7452461
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
3 Name:           ddd
4 Version:        3.2.1
5 Release:        3
6 License:        GPL
7 Group:          Development/Debuggers
8 Group(pl):      Programowanie/Odpluskwiacze
9 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
10 Source1:        ddd.desktop
11 Source2:        ddd-python.desktop
12 Patch0:         ddd-DESTDIR.patch
13 Icon:           ddd.xpm
14 URL:            http://www.gnu.org/software/ddd/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  xpm-devel
17 BuildRequires:  motif-devel
18 BuildRequires:  ncurses-devel >= 5.0
19 BuildRequires:  libstdc++-devel
20 Requires:       gdb
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _prefix         /usr/X11R6
24 %define         _mandir         %{_prefix}/man
25
26 %description
27 The Data Display Debugger (DDD) is a common graphical user interface
28 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
29 ``classical'' front-end features such as viewing source texts, DDD
30 provides a graphical data display, where data structures are displayed
31 as graphs. A simple mouse click dereferences pointers or views
32 structure contents, updated each time the program stops. Using DDD,
33 you can reason about your application by viewing its data, not just by
34 viewing it execute lines of source code. Other DDD features include:
35 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
36 Modula-2, or Modula-3; machine-level debugging; hypertext source
37 navigation and lookup; breakpoint, backtrace, and history editors;
38 preferences and settings editors; program execution in terminal
39 emulator window; debugging on remote host; on-line manual; interactive
40 help on the Motif user interface; GDB/DBX/XDB command-line interface
41 with full editing, history, search, and completion capabilities. DDD
42 has been designed to compete with well-known commercial debuggers
43
44 %description -l pl
45 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
46 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
47 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
48 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
49 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
50 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
51 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
52 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
53 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
54 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
55 ustawiania preferencji; uruchamianie programów w oknie terminala;
56 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
57 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
58 wyszukiwaniem.
59
60 %package python
61 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
62 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
63 Group:          Development/Debuggers
64 Group(pl):      Programowanie/Odpluskwiacze
65 Requires:       %{name} = %{version}
66
67 %description python
68 Data Display Debugger - python debugger.
69
70 %description -l pl
71 Data Display Debugger - debugger pythona.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 LDFLAGS="-s"; export LDFLAGS
79 %configure \
80         --with-motif
81 %{__make} CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_libdir}/python1.5 \
86         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
87         $RPM_BUILD_ROOT%{_applnkdir}/Development 
88
89 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
90
91 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
92 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT%{_libdir}/python1.5
93
94 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
95
96 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
97
98 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
99         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
106 %doc doc/sample.dddinit
107 %{_applnkdir}/Development/ddd.desktop
108 %attr(755,root,root) %{_bindir}/ddd
109 %{_libdir}/X11/app-defaults/Ddd
110 %{_mandir}/man1/*
111
112 %files python
113 %defattr(644,root,root,755)
114 %{_applnkdir}/Development/ddd-python.desktop
115 %attr(755,root,root) %{_bindir}/pydb
116 %{_libdir}/python*/*
This page took 0.076145 seconds and 3 git commands to generate.