]> git.pld-linux.org Git - packages/dcc-dccd.git/blob - dcc-dccd.spec
e32f8bbfd5bf8c04f721b5f129bfb1a748578dec
[packages/dcc-dccd.git] / dcc-dccd.spec
1 Summary:        Distributed Checksum Clearinghouse, anti-spam tool
2 Summary(pl):    Narzêdzie anty-spamowe bazuj±ce na sumach kontrolnych (DCC)
3 Name:           dcc-dccd
4 Version:        1.1.14
5 Release:        1
6 License:        BSD-like
7 Group:          Networking
8 #Source0:       http://www.dcc-servers.net/dcc/source/%{name}-%{version}.tar.Z
9 Source0:        %{name}-%{version}.tar.Z
10 # Source0-md5:  5b17974c039b9f0e646e36d86a476b52
11 URL:            http://www.dcc-servers.net/
12 Requires(pre): /usr/sbin/useradd
13 Requires(postun):      /usr/sbin/userdel
14 Requires(post,preun):   /sbin/chkconfig
15 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         dccdir  /var/lib/dcc
18
19 %description
20 Distributed Checksum Clearinghouse or DCC is a cooperative,
21 distributed system intended to detect "bulk" mail or mail sent to many
22 people. It allows individuals receiving a single mail message to
23 determine that many other people have been sent essentially identical
24 copies of the message and so reject the message. It can identify some
25 unsolicited bulk mail using "spam traps" and other detectors, but that
26 is not its focus.
27
28 The DCC can be viewed as a tool for end users to enforce their right
29 to "opt-in" to streams of bulk mail by refusing all bulk mail except
30 from sources in a "white list." White lists are generally the
31 responsibility of DCC clients, since only they know which bulk mail
32 they solicited.
33
34 NB to use DCC to reject SPAM you need to configure %{dccdir}/dcc_conf
35 and either use procmail or sendmail to feed the messages to DCC.
36
37 %description -l pl
38 DCC (Distributed Checksum Clearinghouse) jest kooperatywnym,
39 rozproszonym systemem maj±cym na celu wykrywanie masowej poczty lub
40 poczty wys³anej do wielu ludzi. Pozwala jednostkom otrzymuj±cym
41 pojedynczy list okre¶liæ, jak wielu innych otrzyma³o dok³adnie
42 identyczne kopie tej wiadomo¶ci i na tej podstawie odrzuciæ j±. Mo¿e
43 zidentyfikowaæ niechcian± masow± pocztê przy u¿yciu "pu³apek
44 antyspamowych" i innych wykrywaczy, ale to nie jest podstawowym celem.
45
46 DCC mo¿na odbieraæ jako narzêdzie dla u¿ytkowników koñcowych,
47 zapewniaj±ce im prawo do przeciwstawienia siê zalewowi masowej poczty
48 przez odrzucenie wszystkich ¶mieci oprócz ¼róde³ z "bia³ej listy".
49 Za bia³e listy odpowiadaj± klienci DCC, jako ¿e tylko oni wiedz±,
50 jak± masow± pocztê zamawiali.
51
52 Aby u¿ywaæ DCC do odrzucania spamu trzeba go skonfigurowaæ poprzez
53 %{dccdir}/dcc_conf i u¿ywaæ procmaila lub sendmaila, by przekazywaæ
54 wszystkie listy do DCC.
55
56 %package cgi
57 Summary:        cgi-scripts for managing mail delivery on a DCC enabled server
58 Summary(pl):    Skrypty cgi do obs³ugi dostarczania poczty na serwerze DCC
59 Group:          Networking
60 Requires:       %{name} >= 1.1.2
61
62 %description cgi
63 Example set of cgi-scripts to allow users to point-and-click manage
64 their own DCC whitelists and thus what is delivered to them. Allows
65 overriding of site level lists. The scripts give controlled access to
66 the whitelists which are otherwise in protected directory space (owned
67 by dcc).
68
69 NB these scripts need configured after installation.
70
71 %description cgi -l pl
72 Przyk³adowy zestaw skryptów pozwalaj±cych u¿ytkownikom na klikane
73 zarz±dzenie ich bia³ymi listami DCC, a wiêc i tym, co dostaj±. Pozwala
74 przykrywaæ listy dotycz±ce serwera. Skrypty daj± dostêp do bia³ych
75 list, które normalnie s± w zabezpieczonym katalogu (którego
76 w³a¶cicielem jest DCC).
77
78 Te skrypty wymagaj± konfiguracji po zainstalowaniu.
79
80 %prep
81 %setup -q
82
83 %build
84 %configure2_13 \
85         --with-uid=99 \
86         --with-cgibin=/home/services/httpd/html/cgi-bin \
87         --with-rundir=%{_var}/run \
88         --with-db-memory=32
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{makeinstall} \
95         MANOWN=$(id -u) \
96         MANGRP=$(id -g) \
97         BINOWN=$(id -u) \
98         BINGRP=$(id -u) \
99         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
100         BINDIR=$RPM_BUILD_ROOT%{_bindir}
101
102 DCC_PROTO_HOMEDIR=$RPM_BUILD%{_var}/lib/dcc
103 DCC_CGIBINDIR=$RPM_BUILD_ROOT%{dccdir}/cgi-bin; export DCC_CGIBINDIR
104 DCC_SUID=$BINOWN DCC_OWN=$BINOWN DCC_GRP=$BINGRP; export DCC_SUID DCC_OWN DCC_GRP
105
106 install -d $RPM_BUILD_ROOT%{_datadir}/sendmail-cf/feature $DCC_CGIBINDIR
107 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{init.d,cron.daily},%{_bindir}} \
108         $RPM_BUILD_ROOT{/var/run/dcc,%{dccdir}/{log,userdirs/{local,esmtp,cyrus,procmail}}}
109
110 %makeinstall
111 cp misc/dcc.m4 misc/dccdnsbl.m4 $RPM_BUILD_ROOT/usr/share/sendmail-cf/feature
112 mv $RPM_BUILD_ROOT/usr/sbin/cron-dccd $RPM_BUILD_ROOT/etc/cron.daily/dccd
113
114 # There already is a logger program which takes the required arguments on Linux
115
116 rm -f $RPM_BUILD_ROOT/usr/sbin/logger
117
118 # We are putting these in the docs directory
119 rm -f $RPM_BUILD_ROOT/usr/sbin/hackmc
120 rm -f $RPM_BUILD_ROOT/usr/sbin/na-spam
121 rm -f $RPM_BUILD_ROOT/usr/sbin/ng-spam
122
123 mv $RPM_BUILD_ROOT/usr/sbin/rcDCC $RPM_BUILD_ROOT/etc/rc.d/init.d/dccd
124 chmod 755 $RPM_BUILD_ROOT/etc/init.d/dccd
125
126 # Set some initial logging, but no rejections
127 perl -p -i -e "s/BRAND=\$/BRAND=RPMDEFAULT/ ; s/DCCM_LOG_AT=\$/\$&10/ ; " \
128         $RPM_BUILD_ROOT%{dccdir}/dcc_conf
129
130 umask 077
131 cat > $RPM_BUILD_ROOT%{dccdir}/flod <<EOF
132 # hostname,port     rem-id [passwd-id] [out-opts] [in-opts]
133
134 # this will not work
135 # nonesuch.example.com,-        32767 100
136 EOF
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %pre
142 /usr/sbin/useradd -d /var/dcc -r dcc >/dev/null 2>&1 || :
143
144 %postun
145 if [ $1 = 0 ]; then
146         /usr/sbin/userdel -r dcc > /dev/null 2>&1 || :
147 fi
148
149 %post
150 /sbin/chkconfig --add dccd || :
151 /sbin/chkconfig --level 016 dccd off || :
152 umask 022
153 /usr/bin/cdcc info > %{dccdir}/map.txt || :
154
155 %post cgi
156 echo The scripts need configured and added into your web configuration.
157 echo see %{dccdir}/cgi-bin/README
158
159 %preun
160 if [ $1 = 0 ]; then
161         /sbin/chkconfig --del dccd || :
162         /etc/rc.d/init.d/dccd stop || :
163 fi
164
165 %files
166 %defattr(644,root,root,755)
167 %dir %{dccdir}
168 %dir %{dccdir}/log
169 %dir %{dccdir}/userdirs/local
170 %dir %{dccdir}/userdirs/cyrus
171 %dir %{dccdir}/userdirs/procmail
172 %dir %{dccdir}/userdirs/esmtp
173 %dir /var/run/dcc
174 %doc CHANGES FAQ.html FAQ.txt INSTALL.html INSTALL.txt LICENSE cdcc.html dbclean.html dblist.html dccd.html dcc.html dccm.html dccproc.html dccsight.html homedir/flod homedir/ids homedir/map.txt homedir/README misc/dcc.m4 misc/dccdnsbl.m4 misc/hackmc misc/na-spam misc/ng-spam
175 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_conf
176 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whiteclnt
177 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitecommon
178 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitelist
179 %config(noreplace) %verify(not size mtime md5) %{dccdir}/ids
180 %config(noreplace) %verify(not size mtime md5) %{dccdir}/flod
181 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db
182 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db.hash
183 %config(noreplace) %verify(not size mtime md5) %{dccdir}/map
184 %{dccdir}/map.txt
185 %attr(754,root,root) /etc/rc.d/init.d/dccd
186 %attr(750,root,root) /etc/cron.daily/dccd
187 %attr(755,root,root) %{_bindir}/cdcc
188 %attr(755,root,root) %{_bindir}/dccproc
189 %attr(755,root,root) %{_sbindir}/dbclean
190 %attr(755,root,root) %{_sbindir}/dblist
191 %attr(755,root,root) %{_sbindir}/dccd
192 %attr(755,root,root) %{_sbindir}/dccm
193 %attr(755,root,root) %{_sbindir}/dccsight
194 %attr(755,root,root) %{_sbindir}/refeed
195 %attr(755,root,root) %{_sbindir}/start-dccd
196 %attr(755,root,root) %{_sbindir}/start-dccm
197 %attr(755,root,root) %{_sbindir}/stop-dccd
198 %attr(755,root,root) %{_sbindir}/wlist
199 %{_datadir}/sendmail-cf/feature/dcc.m4
200 %{_datadir}/sendmail-cf/feature/dccdnsbl.m4
201
202 %{_mandir}/man8/*
203
204 %files cgi
205 %defattr(644,root,root,755)
206 %dir %{dccdir}/cgi-bin
207 %{dccdir}/cgi-bin/chgpasswd
208 %{dccdir}/cgi-bin/common
209 %{dccdir}/cgi-bin/edit-whiteclnt
210 %{dccdir}/cgi-bin/http2https
211 %{dccdir}/cgi-bin/list-log
212 %{dccdir}/cgi-bin/list-msg
213 %{dccdir}/cgi-bin/README
214 %{dccdir}/cgi-bin/webuser-notify
This page took 0.082518 seconds and 3 git commands to generate.