]> git.pld-linux.org Git - packages/dcc-dccd.git/blob - dcc-dccd.spec
d2855cc245359c261eb82ea9de891f1b9e226b0c
[packages/dcc-dccd.git] / dcc-dccd.spec
1 Summary:        Distributed Checksum Clearinghouse, anti-spam tool
2 Summary(pl):    Narzêdzie anty-spamowe bazuj±ce na sumach kontrolnych (DCC)
3 Name:           dcc-dccd
4 Version:        1.1.14
5 Release:        1
6 License:        BSD-like
7 Group:          Networking
8 Source0:        http://www.dcc-servers.net/dcc/source/%{name}-%{version}.tar.Z
9 URL:            http://www.dcc-servers.net/
10 Requires(pre):  /usr/sbin/useradd
11 Requires(post,preun):   /sbin/chkconfig
12 Requires(postun):       /usr/sbin/userdel
13 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         dccdir  /var/lib/dcc
16
17 %description
18 Distributed Checksum Clearinghouse or DCC is a cooperative,
19 distributed system intended to detect "bulk" mail or mail sent to many
20 people. It allows individuals receiving a single mail message to
21 determine that many other people have been sent essentially identical
22 copies of the message and so reject the message. It can identify some
23 unsolicited bulk mail using "spam traps" and other detectors, but that
24 is not its focus.
25
26 The DCC can be viewed as a tool for end users to enforce their right
27 to "opt-in" to streams of bulk mail by refusing all bulk mail except
28 from sources in a "white list." White lists are generally the
29 responsibility of DCC clients, since only they know which bulk mail
30 they solicited.
31
32 NB to use DCC to reject SPAM you need to configure %{dccdir}/dcc_conf
33 and either use procmail or sendmail to feed the messages to DCC.
34
35 %description -l pl
36 DCC (Distributed Checksum Clearinghouse) jest kooperatywnym,
37 rozproszonym systemem maj±cym na celu wykrywanie masowej poczty lub
38 poczty wys³anej do wielu ludzi. Pozwala jednostkom otrzymuj±cym
39 pojedynczy list okre¶liæ, jak wielu innych otrzyma³o dok³adnie
40 identyczne kopie tej wiadomo¶ci i na tej podstawie odrzuciæ j±. Mo¿e
41 zidentyfikowaæ niechcian± masow± pocztê przy u¿yciu "pu³apek
42 antyspamowych" i innych wykrywaczy, ale to nie jest podstawowym celem.
43
44 DCC mo¿na odbieraæ jako narzêdzie dla u¿ytkowników koñcowych,
45 zapewniaj±ce im prawo do przeciwstawienia siê zalewowi masowej poczty
46 przez odrzucenie wszystkich ¶mieci oprócz ¼róde³ z "bia³ej listy".
47 Za bia³e listy odpowiadaj± klienci DCC, jako ¿e tylko oni wiedz±,
48 jak± masow± pocztê zamawiali.
49
50 Aby u¿ywaæ DCC do odrzucania spamu trzeba go skonfigurowaæ poprzez
51 %{dccdir}/dcc_conf i u¿ywaæ procmaila lub sendmaila, by przekazywaæ
52 wszystkie listy do DCC.
53
54 %package cgi
55 Summary:        cgi-scripts for managing mail delivery on a DCC enabled server
56 Summary(pl):    Skrypty cgi do obs³ugi dostarczania poczty na serwerze DCC
57 Group:          Networking
58 Requires:       %{name} >= 1.1.2
59
60 %description cgi
61 Example set of cgi-scripts to allow users to point-and-click manage
62 their own DCC whitelists and thus what is delivered to them. Allows
63 overriding of site level lists. The scripts give controlled access to
64 the whitelists which are otherwise in protected directory space (owned
65 by dcc).
66
67 NB these scripts need configured after installation.
68
69 %description cgi -l pl
70 Przyk³adowy zestaw skryptów pozwalaj±cych u¿ytkownikom na klikane
71 zarz±dzenie ich bia³ymi listami DCC, a wiêc i tym, co dostaj±. Pozwala
72 przykrywaæ listy dotycz±ce serwera. Skrypty daj± dostêp do bia³ych
73 list, które normalnie s± w zabezpieczonym katalogu (którego
74 w³a¶cicielem jest DCC).
75
76 Te skrypty wymagaj± konfiguracji po zainstalowaniu.
77
78 %prep
79 %setup -q
80
81 %build
82 %configure2_13 \
83         --with-uid=99 \
84         --with-cgibin=/home/services/httpd/html/cgi-bin \
85         --with-rundir=%{_var}/run \
86         --with-db-memory=32
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{makeinstall} \
93         MANOWN=$(id -u) \
94         MANGRP=$(id -g) \
95         BINOWN=$(id -u) \
96         BINGRP=$(id -u) \
97         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
98         BINDIR=$RPM_BUILD_ROOT%{_bindir}
99
100 DCC_PROTO_HOMEDIR=$RPM_BUILD%{_var}/lib/dcc
101 DCC_CGIBINDIR=$RPM_BUILD_ROOT%{dccdir}/cgi-bin; export DCC_CGIBINDIR
102 DCC_SUID=$BINOWN DCC_OWN=$BINOWN DCC_GRP=$BINGRP; export DCC_SUID DCC_OWN DCC_GRP
103
104 install -d $RPM_BUILD_ROOT%{_datadir}/sendmail-cf/feature $DCC_CGIBINDIR
105 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{init.d,cron.daily},%{_bindir}} \
106         $RPM_BUILD_ROOT{/var/run/dcc,%{dccdir}/{log,userdirs/{local,esmtp,cyrus,procmail}}}
107
108 %makeinstall
109 cp misc/dcc.m4 misc/dccdnsbl.m4 $RPM_BUILD_ROOT/usr/share/sendmail-cf/feature
110 mv $RPM_BUILD_ROOT/usr/sbin/cron-dccd $RPM_BUILD_ROOT/etc/cron.daily/dccd
111
112 # There already is a logger program which takes the required arguments on Linux
113
114 rm -f $RPM_BUILD_ROOT/usr/sbin/logger
115
116 # We are putting these in the docs directory
117 rm -f $RPM_BUILD_ROOT/usr/sbin/hackmc
118 rm -f $RPM_BUILD_ROOT/usr/sbin/na-spam
119 rm -f $RPM_BUILD_ROOT/usr/sbin/ng-spam
120
121 mv $RPM_BUILD_ROOT/usr/sbin/rcDCC $RPM_BUILD_ROOT/etc/rc.d/init.d/dccd
122 chmod 755 $RPM_BUILD_ROOT/etc/init.d/dccd
123
124 # Set some initial logging, but no rejections
125 perl -p -i -e "s/BRAND=\$/BRAND=RPMDEFAULT/ ; s/DCCM_LOG_AT=\$/\$&10/ ; " \
126         $RPM_BUILD_ROOT%{dccdir}/dcc_conf
127
128 umask 077
129 cat > $RPM_BUILD_ROOT%{dccdir}/flod <<EOF
130 # hostname,port     rem-id [passwd-id] [out-opts] [in-opts]
131
132 # this will not work
133 # nonesuch.example.com,-        32767 100
134 EOF
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %pre
140 /usr/sbin/useradd -d /var/dcc -r dcc >/dev/null 2>&1 || :
141
142 %postun
143 if [ $1 = 0 ]; then
144         /usr/sbin/userdel -r dcc > /dev/null 2>&1 || :
145 fi
146
147 %post
148 /sbin/chkconfig --add dccd || :
149 /sbin/chkconfig --level 016 dccd off || :
150 umask 022
151 /usr/bin/cdcc info > %{dccdir}/map.txt || :
152
153 %post cgi
154 echo The scripts need configured and added into your web configuration.
155 echo see %{dccdir}/cgi-bin/README
156
157 %preun
158 if [ $1 = 0 ]; then
159         /sbin/chkconfig --del dccd || :
160         /etc/rc.d/init.d/dccd stop || :
161 fi
162
163 %files
164 %defattr(644,root,root,755)
165 %dir %{dccdir}
166 %dir %{dccdir}/log
167 %dir %{dccdir}/userdirs/local
168 %dir %{dccdir}/userdirs/cyrus
169 %dir %{dccdir}/userdirs/procmail
170 %dir %{dccdir}/userdirs/esmtp
171 %dir /var/run/dcc
172 %doc CHANGES FAQ.html FAQ.txt INSTALL.html INSTALL.txt LICENSE cdcc.html dbclean.html dblist.html dccd.html dcc.html dccm.html dccproc.html dccsight.html homedir/flod homedir/ids homedir/map.txt homedir/README misc/dcc.m4 misc/dccdnsbl.m4 misc/hackmc misc/na-spam misc/ng-spam
173 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_conf
174 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whiteclnt
175 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitecommon
176 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitelist
177 %config(noreplace) %verify(not size mtime md5) %{dccdir}/ids
178 %config(noreplace) %verify(not size mtime md5) %{dccdir}/flod
179 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db
180 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db.hash
181 %config(noreplace) %verify(not size mtime md5) %{dccdir}/map
182 %{dccdir}/map.txt
183 %attr(754,root,root) /etc/rc.d/init.d/dccd
184 %attr(750,root,root) /etc/cron.daily/dccd
185 %attr(755,root,root) %{_bindir}/cdcc
186 %attr(755,root,root) %{_bindir}/dccproc
187 %attr(755,root,root) %{_sbindir}/dbclean
188 %attr(755,root,root) %{_sbindir}/dblist
189 %attr(755,root,root) %{_sbindir}/dccd
190 %attr(755,root,root) %{_sbindir}/dccm
191 %attr(755,root,root) %{_sbindir}/dccsight
192 %attr(755,root,root) %{_sbindir}/refeed
193 %attr(755,root,root) %{_sbindir}/start-dccd
194 %attr(755,root,root) %{_sbindir}/start-dccm
195 %attr(755,root,root) %{_sbindir}/stop-dccd
196 %attr(755,root,root) %{_sbindir}/wlist
197 %{_datadir}/sendmail-cf/feature/dcc.m4
198 %{_datadir}/sendmail-cf/feature/dccdnsbl.m4
199
200 %{_mandir}/man8/*
201
202 %files cgi
203 %defattr(644,root,root,755)
204 %dir %{dccdir}/cgi-bin
205 %{dccdir}/cgi-bin/chgpasswd
206 %{dccdir}/cgi-bin/common
207 %{dccdir}/cgi-bin/edit-whiteclnt
208 %{dccdir}/cgi-bin/http2https
209 %{dccdir}/cgi-bin/list-log
210 %{dccdir}/cgi-bin/list-msg
211 %{dccdir}/cgi-bin/README
212 %{dccdir}/cgi-bin/webuser-notify
This page took 0.116659 seconds and 3 git commands to generate.