]> git.pld-linux.org Git - packages/dar.git/blob - dar.spec
- up to 2.1.0 - new API (v.2) for external Graphic user Interface
[packages/dar.git] / dar.spec
1 #
2 # Conditional build:
3 %bcond_without  static  # build without dar_static
4 #
5 Summary:        dar makes backup of a directory tree and files
6 Summary(pl):    dar - narzêdzie do tworzenia kopii zapasowych drzew katalogów i plików
7 Name:           dar
8 Version:        2.1.0
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 # Source0-md5:  4cf38abcf6c7e39722b7c8654630192a
14 Patch0:         %{name}-opt.patch
15 URL:            http://dar.linux.free.fr/
16 BuildRequires:  attr-devel
17 BuildRequires:  autoconf >= 2.54
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 %ifarch alpha
21 # ICE in 3.3.x up to 3.3.2 - require patched version
22 BuildRequires:  gcc-c++ >= 5:3.3.2-0.3
23 %endif
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d
26 BuildRequires:  zlib-devel
27 %if %{with static}
28 BuildRequires:  attr-static
29 BuildRequires:  bzip2-static
30 BuildRequires:  glibc-static
31 BuildRequires:  libstdc++-static
32 BuildRequires:  zlib-static
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 dar is a shell command, that makes backup of a directory tree and
38 files.
39
40 FILTERS: dar is able to backup from total file system to a single
41 file. Additionally a mechanism of filters permits, based on the
42 filename, to exclude or include some files while backing up or
43 restoring a directory tree. In the other side, a secondary filter
44 mechanism permits to exclude some branches of a directory tree, or to
45 only include some branches.
46
47 DIFFERENTIAL BACKUP: When making a backup with dar, you have the
48 possibility to make a full backup or a differential backup. A full
49 backup, as expected makes backup of all files as specified on the
50 command line (with or without filters). Instead, a differential
51 backup, (over filter mechanism), saves only files that have changed
52 since a given reference backup. Additionally, files that existed in
53 the reference backup and which do no more exist at the time of the
54 differential backup are recorded in the backup. At recovery time,
55 (unless you deactivate it), restoring a differential backup will
56 update changed files and new files, but also remove files that have
57 been recorded as deleted. Note that the reference backup can be a full
58 backup or another differential backup. This way you can make a first
59 full backup, then many differential backup, each taking as reference
60 the last backup made.
61
62 SLICES: Dar stands for Disk ARchive. From the beginning it was
63 designed to be able to split an archive over several removable media
64 whatever their number is and whatever their size is. Thus dar is able
65 to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
66 etc... Dar is not concerned by un/mounting a removable medium, instead
67 it is independent of hardware. Given the size, it will split the
68 archive in several files (called SLICES), eventually pausing before
69 creating the next one, allowing this way, the user to un/mount a
70 medium, burn the file on CD-R, send it by email (if your mail system
71 does not allow huge file in emails, dar can help you here also). By
72 default, (no size specified), dar will make one slice whatever its
73 size is. Additionally, the size of the first slice can be specified
74 separately, if for example you want first to fulfil a partially filled
75 disk before starting using empty ones. Last, at restoration time, dar
76 will just pause and prompt the user asking a slice only if it is
77 missing.
78
79 COMPRESSION: last, dar can use compression. By default no compression
80 is used. Actually only gzip algorithm is implemented, but some room
81 has been done for bzip2 and any other compression algorithm. Note
82 that, compression is made before slices, which means that using
83 compression with slices, will not make slices smaller, but will
84 probably make less slices in the backup.
85
86 DIRECT ACCESS: even using compression dar has not to read the whole
87 backup to extract one file. This way if you just want to restore one
88 file from a huge backup, the process will be much faster than using
89 tar. Dar first reads the catalogue (i.e. the contents of the backup),
90 then it goes directly to the location of the saved file(s) you want to
91 restore and proceed to restoration. In particular using slices dar
92 will ask only for the slice(s) containing the file(s) to restore.
93
94 HARD LINK CONSIDERATION: hard links are now properly saved. They are
95 properly restored if possible. If for example restoring across a
96 mounted filesystem, hard linking will fail, but dar will then
97 duplicate the inode and file content, issuing a warning.
98
99 EXTENDED ATTRIBUTES: support for extended attributes have to be
100 activated at compilation time (see INSTALL). Dar is able to save and
101 restore EA, all or just those of a given namespace (system or user).
102 If no EA have been saved and restoration occurs over a file that has
103 EA, they will be preserved. But if they have been saved empty for a
104 given file, any existing EA for that file will be removed at
105 restoration time, unless -u and/or -U is given on command-line.
106
107 ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
108 to detect data corruption in the archive. Only the file where data
109 corruption occurred will not be possible to restore, but dar will
110 restore the other even when compression is used.
111
112 USING PIPES dar is now able to produce an archive to its standard
113 output or named pipe. it is also able to read an archive through a
114 pair of pipes, to take a remote archive as reference, or even to
115 restore data from a remote archive. This way it is now possible to
116 store an archive remotely and in total security (if using encrypted
117 means)
118
119 ISOLATION the catalogue (i.e.: the contents of an archive), can be
120 extracted (this operation is called isolation) to a small file, that
121 can in turn be used as reference for differential archive. There is no
122 more need to provide an archive to be able to create a differential
123 backup over it, just its catalogue is necessary.
124
125 RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
126 "dar_xform" is able to change the size of slices of a given archive.
127 The resulting archive is totally identical to archives directly
128 created by dar. Source archive can be taken from a set of slice, from
129 standard input or even a named pipe.
130
131 %description -l pl
132 dar jest poleceniem pow³oki, które tworzy kopie zapasowe drzew
133 katalogów i plików. Mo¿liwo¶ci:
134 - Filtry: dar mo¿e tworzyæ kopiê zapasow± ca³ego systemu plików do
135   pojedynczego pliku; mechanizm filtrów pozwala wy³±czaæ lub do³±czaæ
136   pliki przy tworzeniu kopii lub odtwarzaniu z niej.
137 - Backup ró¿nicowy: dar mo¿e tworzyæ kopie pe³ne lub ró¿nicowe
138   (zawieraj±ce tylko te pliki, które zmieni³y siê od innego backupu)
139 - Czê¶ci (slices): dar oznacza "Disk ARchive". Od pocz±tku ma
140   mo¿liwo¶æ dzielenia archiwów na ró¿ne no¶niki wymienialne,
141   niezale¿nie od ich liczby i rozmiaru (mo¿na tworzyæ kopie na CD-R,
142   DVD-R, CD-RW, Zip, Jazz...).
143 - Kompresja: domy¶lnie dar nie kompresuje danych; ma zaimplementowany
144   algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
145   wykonywana przed podzia³em na czê¶ci.
146 - Bezpo¶redni dostêp: nawet w przypadku u¿ycia kompresji, dar nie musi
147   czytaæ ca³ej kopii aby odtworzyæ jeden plik. Najpierw odczytuje
148   katalog, nastêpnie skacze od razu do w³a¶ciwego miejsca.
149 - Obs³uga twardych dowi±zañ: dar zachowuje i odtwarza je w miarê
150   mo¿liwo¶ci; w przypadku niemo¿liwo¶ci wykonania dowi±zania, powiela
151   plik i wypisuje ostrze¿enie.
152 - Obs³uga rozszerzonych atrybutów (zale¿nie od opcji kompilacji): dar
153   potrafi zachowywaæ i odtwarzaæ rozszerzone atrubuty - wszystkie lub
154   tylko dotycz±ce danej przestrzeni nazw (systemowej lub u¿ytkownika).
155 - Testowanie archiwów: dziêki u¿yciu CRC dar wykrywa uszkodzone dane;
156   tylko uszkodzone pliki nie zostan± odtworzone, reszta tak - nawet w
157   przypadku u¿ycia kompresji.
158 - U¿ycie rurek - dar mo¿e wyprodukowaæ archiwum na standardowe wyj¶cie
159   lub do nazwanej rurki. Mo¿e tak¿e czytaæ archiwum z pary rurek, a
160   nawet odtwarzaæ ze zdalnego archiwum.
161 - Rozdzielenie: katalog (zawarto¶æ archiwum) mo¿e byæ wyci±gniêty do
162   ma³ego pliku, który mo¿e byæ u¿ywany jako odniesienie dla
163   ró¿nicowego backupu.
164 - Przekszta³canie czê¶ci istniej±cego archiwum: zewnêtrzny program o
165   nazwie dar_xform jest w stanie zmieniaæ rozmiary czê¶ci podanego
166   archiwum. Mo¿e czytaæ z zestawu kata³ków, standardowego wej¶cia lub
167   nazwanej rurki.
168
169 %package static
170 Summary:        Static version of dar backup tool
171 Summary(pl):    Statyczna wersja archiwizatora dar
172 Group:          Applications
173
174 %description static
175 Static version of dar backup tool.
176
177 %description static -l pl
178 Statyczna wersja archiwizatora dar.
179
180 %package devel
181 Summary:        Header files to develop dar software
182 Summary(pl):    Pliki nag³ówkowe biblioteki dar
183 Group:          Development/Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description devel
187 Header files to develop software which operates on dar.
188
189 %description devel -l pl
190 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania korzystaj±cego z
191 dara.
192
193 %package libs-static
194 Summary:        Static version of dar library
195 Summary(pl):    Statyczna wersja biblioteki dar
196 Group:          Development/Libraries
197 Requires:       %{name}-devel = %{version}-%{release}
198
199 %description libs-static
200 Static version of dar library.
201
202 %description libs-static -l pl
203 Statyczna wersja biblioteki dar.
204
205 %prep
206 %setup -q
207 %patch -p1
208
209 %build
210 %{__libtoolize}
211 %{__aclocal}
212 %{__autoconf}
213 %{__autoheader}
214 %{__automake}
215 %configure \
216         --enable-ea-support \
217 %{?without_static:--disable-dar-static} \
218         --disable-upx
219 %{__make}
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 %{?with_static:install -d $RPM_BUILD_ROOT/bin}
224
225 %{__make} install \
226         DESTDIR=$RPM_BUILD_ROOT
227
228 %{?with_static:mv -f $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
229
230 %clean
231 rm -rf $RPM_BUILD_ROOT
232
233 %post   -p /sbin/ldconfig
234 %postun -p /sbin/ldconfig
235
236 %files
237 %defattr(644,root,root,755)
238 %doc BUGS README TODO doc
239 %attr(755,root,root) %{_bindir}/*
240 %attr(755,root,root) %{_libdir}/libdar.so.*.*.*
241 %{_datadir}/%{name}
242 %{_mandir}/man1/*
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libdar.so
247 %{_libdir}/libdar.la
248 %{_includedir}/dar
249
250 %if %{with static}
251 %files static
252 %defattr(644,root,root,755)
253 %attr(755,root,root) /bin/*
254 %endif
255
256 %files libs-static
257 %defattr(644,root,root,755)
258 %{_libdir}/libdar.a
This page took 0.093392 seconds and 4 git commands to generate.