]> git.pld-linux.org Git - packages/dar.git/blob - dar.spec
- add bcond_without ea
[packages/dar.git] / dar.spec
1 #
2 # Conditional build:
3 %bcond_without  ea              # build without support for linux extented attributes
4 %bcond_without  static  # build without dar_static
5 #
6 Summary:        dar makes backup of a directory tree and files
7 Summary(pl):    dar - narzêdzie do tworzenia kopii zapasowych drzew katalogów i plików
8 Name:           dar
9 Version:        2.1.4
10 Release:        1
11 License:        GPL v2
12 Group:          Applications
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  032306021f6a66ef060260acd39da3dd
15 Patch0:         %{name}-opt.patch
16 URL:            http://dar.linux.free.fr/
17 %{?with_ea:BuildRequires:       attr-devel >= 2.4.16-3}
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  bzip2-devel
21 %ifarch alpha
22 # ICE in 3.3.x up to 3.3.2 - require patched version
23 BuildRequires:  gcc-c++ >= 5:3.3.2-0.3
24 %endif
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.4d
27 BuildRequires:  zlib-devel
28 %if %{with static}
29 %{?with_ea:BuildRequires:       attr-static}
30 BuildRequires:  bzip2-static
31 BuildRequires:  glibc-static
32 BuildRequires:  libstdc++-static
33 BuildRequires:  zlib-static
34 %endif
35 Requires:       %{name}-libs = %{version}-%{release}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 dar is a shell command, that makes backup of a directory tree and
40 files.
41
42 FILTERS: dar is able to backup from total file system to a single
43 file. Additionally a mechanism of filters permits, based on the
44 filename, to exclude or include some files while backing up or
45 restoring a directory tree. In the other side, a secondary filter
46 mechanism permits to exclude some branches of a directory tree, or to
47 only include some branches.
48
49 DIFFERENTIAL BACKUP: When making a backup with dar, you have the
50 possibility to make a full backup or a differential backup. A full
51 backup, as expected makes backup of all files as specified on the
52 command line (with or without filters). Instead, a differential
53 backup, (over filter mechanism), saves only files that have changed
54 since a given reference backup. Additionally, files that existed in
55 the reference backup and which do no more exist at the time of the
56 differential backup are recorded in the backup. At recovery time,
57 (unless you deactivate it), restoring a differential backup will
58 update changed files and new files, but also remove files that have
59 been recorded as deleted. Note that the reference backup can be a full
60 backup or another differential backup. This way you can make a first
61 full backup, then many differential backup, each taking as reference
62 the last backup made.
63
64 SLICES: Dar stands for Disk ARchive. From the beginning it was
65 designed to be able to split an archive over several removable media
66 whatever their number is and whatever their size is. Thus dar is able
67 to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
68 etc... Dar is not concerned by un/mounting a removable medium, instead
69 it is independent of hardware. Given the size, it will split the
70 archive in several files (called SLICES), eventually pausing before
71 creating the next one, allowing this way, the user to un/mount a
72 medium, burn the file on CD-R, send it by email (if your mail system
73 does not allow huge file in emails, dar can help you here also). By
74 default, (no size specified), dar will make one slice whatever its
75 size is. Additionally, the size of the first slice can be specified
76 separately, if for example you want first to fulfil a partially filled
77 disk before starting using empty ones. Last, at restoration time, dar
78 will just pause and prompt the user asking a slice only if it is
79 missing.
80
81 COMPRESSION: last, dar can use compression. By default no compression
82 is used. Actually only gzip algorithm is implemented, but some room
83 has been done for bzip2 and any other compression algorithm. Note
84 that, compression is made before slices, which means that using
85 compression with slices, will not make slices smaller, but will
86 probably make less slices in the backup.
87
88 DIRECT ACCESS: even using compression dar has not to read the whole
89 backup to extract one file. This way if you just want to restore one
90 file from a huge backup, the process will be much faster than using
91 tar. Dar first reads the catalogue (i.e. the contents of the backup),
92 then it goes directly to the location of the saved file(s) you want to
93 restore and proceed to restoration. In particular using slices dar
94 will ask only for the slice(s) containing the file(s) to restore.
95
96 HARD LINK CONSIDERATION: hard links are now properly saved. They are
97 properly restored if possible. If for example restoring across a
98 mounted filesystem, hard linking will fail, but dar will then
99 duplicate the inode and file content, issuing a warning.
100
101 EXTENDED ATTRIBUTES: support for extended attributes have to be
102 activated at compilation time (see INSTALL). Dar is able to save and
103 restore EA, all or just those of a given namespace (system or user).
104 If no EA have been saved and restoration occurs over a file that has
105 EA, they will be preserved. But if they have been saved empty for a
106 given file, any existing EA for that file will be removed at
107 restoration time, unless -u and/or -U is given on command-line.
108
109 ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
110 to detect data corruption in the archive. Only the file where data
111 corruption occurred will not be possible to restore, but dar will
112 restore the other even when compression is used.
113
114 USING PIPES dar is now able to produce an archive to its standard
115 output or named pipe. it is also able to read an archive through a
116 pair of pipes, to take a remote archive as reference, or even to
117 restore data from a remote archive. This way it is now possible to
118 store an archive remotely and in total security (if using encrypted
119 means)
120
121 ISOLATION the catalogue (i.e.: the contents of an archive), can be
122 extracted (this operation is called isolation) to a small file, that
123 can in turn be used as reference for differential archive. There is no
124 more need to provide an archive to be able to create a differential
125 backup over it, just its catalogue is necessary.
126
127 RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
128 "dar_xform" is able to change the size of slices of a given archive.
129 The resulting archive is totally identical to archives directly
130 created by dar. Source archive can be taken from a set of slice, from
131 standard input or even a named pipe.
132
133 %description -l pl
134 dar jest poleceniem pow³oki, które tworzy kopie zapasowe drzew
135 katalogów i plików. Mo¿liwo¶ci:
136 - Filtry: dar mo¿e tworzyæ kopiê zapasow± ca³ego systemu plików do
137   pojedynczego pliku; mechanizm filtrów pozwala wy³±czaæ lub do³±czaæ
138   pliki przy tworzeniu kopii lub odtwarzaniu z niej.
139 - Backup ró¿nicowy: dar mo¿e tworzyæ kopie pe³ne lub ró¿nicowe
140   (zawieraj±ce tylko te pliki, które zmieni³y siê od innego backupu)
141 - Czê¶ci (slices): dar oznacza "Disk ARchive". Od pocz±tku ma
142   mo¿liwo¶æ dzielenia archiwów na ró¿ne no¶niki wymienialne,
143   niezale¿nie od ich liczby i rozmiaru (mo¿na tworzyæ kopie na CD-R,
144   DVD-R, CD-RW, Zip, Jazz...).
145 - Kompresja: domy¶lnie dar nie kompresuje danych; ma zaimplementowany
146   algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
147   wykonywana przed podzia³em na czê¶ci.
148 - Bezpo¶redni dostêp: nawet w przypadku u¿ycia kompresji, dar nie musi
149   czytaæ ca³ej kopii aby odtworzyæ jeden plik. Najpierw odczytuje
150   katalog, nastêpnie skacze od razu do w³a¶ciwego miejsca.
151 - Obs³uga twardych dowi±zañ: dar zachowuje i odtwarza je w miarê
152   mo¿liwo¶ci; w przypadku niemo¿liwo¶ci wykonania dowi±zania, powiela
153   plik i wypisuje ostrze¿enie.
154 - Obs³uga rozszerzonych atrybutów (zale¿nie od opcji kompilacji): dar
155   potrafi zachowywaæ i odtwarzaæ rozszerzone atrubuty - wszystkie lub
156   tylko dotycz±ce danej przestrzeni nazw (systemowej lub u¿ytkownika).
157 - Testowanie archiwów: dziêki u¿yciu CRC dar wykrywa uszkodzone dane;
158   tylko uszkodzone pliki nie zostan± odtworzone, reszta tak - nawet w
159   przypadku u¿ycia kompresji.
160 - U¿ycie rurek - dar mo¿e wyprodukowaæ archiwum na standardowe wyj¶cie
161   lub do nazwanej rurki. Mo¿e tak¿e czytaæ archiwum z pary rurek, a
162   nawet odtwarzaæ ze zdalnego archiwum.
163 - Rozdzielenie: katalog (zawarto¶æ archiwum) mo¿e byæ wyci±gniêty do
164   ma³ego pliku, który mo¿e byæ u¿ywany jako odniesienie dla
165   ró¿nicowego backupu.
166 - Przekszta³canie czê¶ci istniej±cego archiwum: zewnêtrzny program o
167   nazwie dar_xform jest w stanie zmieniaæ rozmiary czê¶ci podanego
168   archiwum. Mo¿e czytaæ z zestawu kata³ków, standardowego wej¶cia lub
169   nazwanej rurki.
170
171 %package static
172 Summary:        Static version of dar backup tool
173 Summary(pl):    Statyczna wersja archiwizatora dar
174 Group:          Applications
175
176 %description static
177 Static version of dar backup tool.
178
179 %description static -l pl
180 Statyczna wersja archiwizatora dar.
181
182 %package libs
183 Summary:        Shared version of dar library
184 Summary(pl):    Wspó³dzielona wersja biblioteki dar
185 Group:          Libraries
186
187 %description libs
188 Shared version of dar library.
189
190 %description libs -l pl
191 Wspó³dzielona wersja biblioteki dar.
192
193 %package devel
194 Summary:        Header files to develop dar software
195 Summary(pl):    Pliki nag³ówkowe biblioteki dar
196 Group:          Development/Libraries
197 Requires:       %{name}-libs = %{version}-%{release}
198
199 %description devel
200 Header files to develop software which operates on dar.
201
202 %description devel -l pl
203 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania korzystaj±cego z
204 dara.
205
206 %package libs-static
207 Summary:        Static version of dar library
208 Summary(pl):    Statyczna wersja biblioteki dar
209 Group:          Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211
212 %description libs-static
213 Static version of dar library.
214
215 %description libs-static -l pl
216 Statyczna wersja biblioteki dar.
217
218 %prep
219 %setup -q
220 %patch -p1
221
222 %build
223 %{__libtoolize}
224 %{__aclocal}
225 %{__autoconf}
226 %{__autoheader}
227 %{__automake}
228 %configure \
229         %{?with_ea:--enable-ea-support} \
230         %{!?with_static:--disable-dar-static} \
231         --disable-upx
232 %{__make}
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236 %{?with_static:install -d $RPM_BUILD_ROOT/bin}
237
238 %{__make} install \
239         DESTDIR=$RPM_BUILD_ROOT
240
241 %{?with_static:mv -f $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
242
243 find $RPM_BUILD_DIR/%{name}-%{version}/doc -name "Makefile*" | xargs rm -fv
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 %post   libs -p /sbin/ldconfig
249 %postun libs -p /sbin/ldconfig
250
251 %files
252 %defattr(644,root,root,755)
253 %doc BUGS README TODO doc
254 %attr(755,root,root) %{_bindir}/*
255 %{_datadir}/%{name}
256 %{_mandir}/man1/*
257
258 %files libs
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_libdir}/libdar.so.*.*.*
261
262 %files devel
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_libdir}/libdar.so
265 %{_libdir}/libdar.la
266 %{_includedir}/dar
267
268 %if %{with static}
269 %files static
270 %defattr(644,root,root,755)
271 %attr(755,root,root) /bin/*
272 %endif
273
274 %files libs-static
275 %defattr(644,root,root,755)
276 %{_libdir}/libdar.a
This page took 0.05489 seconds and 4 git commands to generate.