]> git.pld-linux.org Git - packages/dante.git/blob - dante.spec
- cosmetics
[packages/dante.git] / dante.spec
1 %define         pre     pre1
2 Summary:        A free Socks v4/v5 client implementation
3 Summary(pl):    Darmowa implementacja klienta Socks v4/5
4 Name:           dante
5 Version:        1.1.15
6 Release:        0.%{pre}.1
7 License:        BSD-like
8 Group:          Networking/Daemons
9 Source0:        ftp://ftp.inet.no/pub/socks/%{name}-%{version}-%{pre}.tar.gz
10 # Source0-md5:  1dc7cbd260c7a171cacc49d314845806
11 Source1:        sockd.init
12 URL:            http://www.inet.no/dante/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libwrap-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Dante is a free implementation of the proxy protocols socks version 4,
20 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
21 between networks. It is being developed by Inferno Nettverk A/S, a
22 Norwegian consulting company. Commercial support is available.
23
24 This package contains the dynamic libraries required to "socksify"
25 existing applications to become socks clients.
26
27 %description -l pl
28 Dante jest darmow± implementacj± protoko³ów proxy: socks w wersji 4,
29 socks w wersji 5 (rfc1928) oraz msproxy. Mo¿e byæ u¿ywany jako zapora
30 pomiêdzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
31 A/S - Norwesk± firmê konsultingow±. Komercyjne wsparcie jest dostêpne.
32
33 Ten pakiet zawiera dynamiczne biblioteki wymagane do "usocksowiania"
34 istniej±cych aplikacji tak by dzia³a³y one jako klienci socks.
35
36 %package server
37 Summary:        A free Socks v4/v5 server implementation
38 Summary(pl):    Darmowa implementacja serwera Socks v4/5
39 Group:          Networking/Daemons
40 Requires:       %{name} = %{version}-%{release}
41 PreReq:         rc-scripts
42 Requires(post,preun):   /sbin/chkconfig
43
44 %description server
45 This package contains the socks proxy daemon and its documentation.
46 The sockd is the server part of the Dante socks proxy package and
47 allows socks clients to connect through it to the network.
48
49 %description server -l pl
50 Ten pakiet zawiera serwer proxy socks oraz jego dokumentacjê. Serwer
51 sockd jest czê¶ci± pakietu proxy Dante. Za po¶rednictwem serwera
52 klienci mog± ³±czyæ siê z serwerami w sieci.
53
54 %package devel
55 Summary:        Development libraries for socks
56 Summary(pl):    Biblioteki developerskie dla socks
57 Group:          Networking/Daemons
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 Additional libraries required to compile programs that use socks.
62
63 %description devel -l pl
64 Dodatkowe biblioteki wymagane do rozwoju programów korzystaj±cych z
65 socks.
66
67 %package static
68 Summary:        Static libraries for socks
69 Summary(pl):    Statyczne biblioteki socks
70 Group:          Networking/Daemons
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libraries for socks.
75
76 %description static -l pl
77 Statyczne biblioteki socks.
78
79 %prep
80 %setup -q -n %{name}-%{version}-%{pre}
81
82 %build
83 cp -f /usr/share/automake/config.sub .
84 %{__autoconf}
85 %configure \
86         --disable-preload
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install example/sock{s,d}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
97
98 install %{SOURCE1} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/sockd
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %post server
107 /sbin/chkconfig --add sockd
108 if [ -f /var/lock/subsys/sockd ]; then
109         /etc/rc.d/init.d/sockd restart 1>&2
110 else
111         echo "Run \"/etc/rc.d/init.d/sockd start\" to start dante sockd daemon."
112 fi
113
114 %postun server
115 if [ "$1" = "0" ]; then
116         if [ -f /var/lock/subsys/sockd ]; then
117                 /etc/rc.d/init.d/sockd stop 1>&2
118         fi
119         /sbin/chkconfig --del sockd
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc BUGS CREDITS LICENSE NEWS README SUPPORT TODO
125 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/socks.conf
126 %attr(755,root,root) %{_libdir}/lib*.so.*.*
127 %attr(755,root,root) %{_bindir}/socksify
128 %{_mandir}/man5/socks.conf.5*
129
130 %files server
131 %defattr(644,root,root,755)
132 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sockd.conf
133 %attr(754,root,root) /etc/rc.d/init.d/sockd
134 %attr(755,root,root) %{_sbindir}/sockd
135 %{_mandir}/man8/sockd.8*
136 %{_mandir}/man5/sockd.conf.5*
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/lib*.so
141 %{_libdir}/lib*.la
142 %{_includedir}/*
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/lib*.a
This page took 0.308722 seconds and 4 git commands to generate.