]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- updated to 2.1.22, updated gcc4 patch, removed obsolete configdir patch
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # TODO:
3 # - add ldap plugin from openldap sources
4 #
5 # Conditional build:
6 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
7 %bcond_without  ldap            # disable LDAP support for saslauthd
8 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
9 %bcond_without  mysql           # don't build MySQL pluggin
10 %bcond_without  pgsql           # do not build PostgreSQL pluggin
11 %bcond_without  sqlite          # do not enable sqlite plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # enable opie plugin
14 %bcond_with     srp             # build srp pluggin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 %bcond_with     x509            # build x509 plugin (no sources in package???)
17 #
18 %if %{without mysql} && %{without pgsql}
19 %undefine with_cryptedpw
20 %endif
21
22 Summary:        The SASL library API for the Cyrus mail system
23 Summary(pl):    Biblioteka Cyrus SASL
24 Summary(pt_BR): Implementação da API SASL
25 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
26 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
27 Name:           cyrus-sasl
28 Version:        2.1.22
29 Release:        1
30 License:        distributable
31 Group:          Libraries
32 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
33 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 URL:            http://asg.web.cmu.edu/sasl/
46 BuildRequires:  autoconf >= 2.54
47 BuildRequires:  automake
48 %{?with_authlib:BuildRequires:  courier-authlib-devel}
49 BuildRequires:  db-devel
50 BuildRequires:  ed
51 BuildRequires:  groff
52 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
53 BuildRequires:  libtool >= 1.4
54 %{?with_mysql:BuildRequires:    mysql-devel}
55 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
56 BuildRequires:  openssl-devel >= 0.9.7d
57 %{?with_opie:BuildRequires:     opie-devel}
58 BuildRequires:  pam-devel
59 %{?with_pgsql:BuildRequires:    postgresql-devel}
60 %{?with_sqlite:BuildRequires:   sqlite-devel}
61 Requires:       pam >= 0.79.0
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _sysconfdir     /etc/sasl
65
66 %define         specflags       -fno-strict-aliasing
67
68 %description
69 This is an implementation of the SASL API, useful for adding
70 authentication, authorization, and security to network protocols. The
71 SASL protocol itself is documented in rfc2222; the API standard is a
72 work in progress.
73
74 Note: remember to install appropriate plugins, or you won't have any
75 authentication mechanisms available.
76
77 %description -l pl
78 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
79 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
80 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
81 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
82 RFC 2222; standaryzacja API jest w toku.
83
84 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
85 doinstalowaæ odpowiednie wtyczki.
86
87 %description -l pt_BR
88 Esta é uma implementação da API SASL, útil para acrescentar
89 autenticação, autorização e seguança (criptografia) para protocolos de
90 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
91 ainda está em desenvolvimento.
92
93 %description -l ru
94 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
95 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
96 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
97
98 %description -l uk
99 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
100 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
101 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
102
103 %package devel
104 Summary:        Header files and documentation for cyrus-sasl
105 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
106 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
107 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
108 Summary(uk):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
109 Group:          Development/Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description devel
113 This includes the header files and documentation needed to develop
114 applications which use SASL.
115
116 %description devel -l pl
117 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
118
119 %description devel -l pt_BR
120 Este pacote inclui os arquivos de cabeçalho e documentação necessários
121 para desenvolver aplicativos que usem SASL.
122
123 %description devel -l ru
124 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
125 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
126
127 %description devel -l uk
128 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
129 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
130
131 %package static
132 Summary:        Static cyrus-sasl libraries
133 Summary(pl):    Statyczne biblioteki cyrus-sasl
134 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
135 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138
139 %description static
140 Static cyrus-sasl libraries.
141
142 %description static -l pl
143 Statyczne biblioteki cyrus-sasl.
144
145 %description static -l ru
146 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
147 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
148
149 %description static -l uk
150 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
151 Cyrus SASL.
152
153 %package cram-md5
154 Summary:        Cram-MD5 Cyrus SASL plugin
155 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
156 Summary(pt_BR): Mecanismo SASL CRAM-MD5
157 Group:          Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description cram-md5
161 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
162 mandatory-to-implement authentication mechanism for a number of
163 protocols; it uses MD5 with a challenge/response system to
164 authenticate the user.
165
166 %description cram-md5 -l pl
167 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
168 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
169 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
170 systemem challenge/response.
171
172 %description cram-md5 -l pt_BR
173 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
174 mecanismo de autenticação obrigatório de ser implementado para vários
175 protocolos: ele usa MD5 com um sistema de desafio/resposta para
176 autenticar o usuário.
177
178 %package digest-md5
179 Summary:        Digest-MD5 Cyrus SASL plugin
180 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
181 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
182 Group:          Libraries
183 Requires:       %{name} = %{version}-%{release}
184
185 %description digest-md5
186 This plugin implements the latest draft of the SASL DIGEST-MD5
187 mechanism. Although not yet finalized, this is likely to become the
188 new mandatory-to-implement authentication system in all new protocols.
189 It's based on the digest md5 authentication system designed for HTTP.
190
191 %description digest-md5 -l pl
192 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
193 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
194 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
195 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
196 Digest-MD5 zaprojektowanym dla HTTP.
197
198 %description digest-md5 -l pt_BR
199 Este plugin implementa a última versão da especificação do mecanismo
200 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
201 provavelmente será o novo sistema de autenticação obrigatório para
202 protocolos novos. Ele é baseado na autenticação md5 digest
203 desenvolvida para HTTP.
204
205 %package plain
206 Summary:        Plain Cyrus SASL plugin
207 Summary(pl):    Wtyczka plain do Cyrus SASL
208 Summary(pt_BR): Mecanismo SASL PLAIN
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211
212 %description plain
213 This plugin implements the SASL PLAIN mechanism. Although insecure,
214 PLAIN is useful for transitioning to new security mechanisms, as this
215 is the only mechanism which gives the server a copy of the user's
216 password.
217
218 %description plain -l pl
219 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
220 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
221 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
222 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
223
224 %description plain -l pt_BR
225 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
226 mecanismo é útil durante transições para novos mecanismos de
227 segurança, pois é o único esquema que fornece uma cópia da senha do
228 usuário para o servidor.
229
230 %package anonymous
231 Summary:        Anonymous Cyrus SASL plugin
232 Summary(pl):    Wtyczka anonymous do Cyrus SASL
233 Summary(pt_BR): Mecanismo SASL ANONYMOUS
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236
237 %description anonymous
238 This plugin implements the SASL ANONYMOUS mechanism, used for
239 anonymous authentication.
240
241 %description anonymous -l pl
242 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
243 anonimowego uwierzytelniania.
244
245 %description anonymous -l pt_BR
246 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
247 autenticação anônima.
248
249 %package gssapi
250 Summary:        GSSAPI Cyrus SASL plugin
251 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
252 Summary(pt_BR): Mecanismo SASL GSSAPI
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255
256 %description gssapi
257 This plugin implements the SASL GSSAPI mechanism, used for
258 GSSAPI/Kerberos5 authentication.
259
260 %description gssapi -l pl
261 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
262 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
263
264 %description gssapi -l pt_BR
265 Este plugin implementa o mecanismo SASL GSSAPI, usado para
266 autenticação Kerberos/GSSAPI.
267
268 %package login
269 Summary:        Unsupported Login Cyrus SASL plugin
270 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273
274 %description login
275 Unsupported LOGIN Cyrus SASL plugin.
276
277 %description login -l pl
278 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
279 SASL.
280
281 %package srp
282 Summary:        SRP Cyrus SASL plugin
283 Summary(pl):    Wtyczka SRP do Cyrus SASL
284 Summary(pt_BR): Mecanismo SASL SRP
285 Group:          Libraries
286 Requires:       %{name} = %{version}-%{release}
287
288 %description srp
289 This plugin implements the SASL SRP mechanism, based on the Secure
290 Remote Password protocol. This mechanism performs mutual
291 authentication and can provide a security layer with replay detection,
292 integrity protection and/or condifentiality protection.
293
294 %description srp -l pl
295 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
296 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
297 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
298 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
299
300 %description srp -l pt_BR
301 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
302 (Secure Remote Password). Este mecanismo oferece autenticação mútua
303 (do cliente e do servidor) e pode prover uma camada de segurança com
304 detecção de ataques de replay, garantia de integridade e/ou
305 confidencialidade.
306
307 %package otp
308 Summary:        OTP Cyrus SASL plugin
309 Summary(pl):    Wtyczka OTP do Cyrus SASL
310 Summary(pt_BR): Mecanismo SASL OTP
311 Group:          Libraries
312 Requires:       %{name} = %{version}-%{release}
313
314 %description otp
315 This plugin implements the SASL OTP (One Time Password) mechanism.
316
317 %description otp -l pl
318 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
319 SASL.
320
321 %package opie
322 Summary:        OPIE Cyrus SASL plugin
323 Summary(pl):    Wtyczka OPIE do Cyrus SASL
324 Summary(pt_BR): Mecanismo SASL OPIE
325 Group:          Libraries
326 Requires:       %{name} = %{version}-%{release}
327
328 %description opie
329 This plugin implements the SASL OPIE (One Time Password) mechanism.
330
331 %description opie -l pl
332 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
333 SASL.
334
335 %package x509
336 Summary:        x509 Cyrus SASL plugin
337 Summary(pl):    Wtyczka x509 do Cyrus SASL
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340
341 %description x509
342 x509 Cyrus SASL plugin.
343
344 %description x509 -l pl
345 Wtyczka x509 do Cyrus SASL.
346
347 %package saslauthd
348 Summary:        Cyrus SASL authd
349 Summary(pl):    Demon authd do Cyrus SASL
350 Group:          Daemons
351 Requires(post,preun):   /sbin/chkconfig
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       rc-scripts
354
355 %description saslauthd
356 Cyrus SASL authd.
357
358 %description saslauthd -l pl
359 Demon authd do Cyrus SASL.
360
361 %package pwcheck
362 Summary:        Cyrus SASL pwcheck helper
363 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
364 Group:          Libraries
365 Requires:       %{name} = %{version}-%{release}
366
367 %description pwcheck
368 Cyrus SASL pwcheck helper.
369
370 %description pwcheck -l pl
371 Program pomocniczy pwcheck do Cyrus SASL.
372
373 %package sasldb
374 Summary:        Cyrus SASL sasldb plugin
375 Summary(pl):    Wtyczka sasldb do Cyrus SASL
376 Group:          Libraries
377 Requires:       %{name} = %{version}-%{release}
378
379 %description sasldb
380 Cyrus SASL sasldb plugin.
381
382 %description sasldb -l pl
383 Wtyczka sasldb do Cyrus SASL.
384
385 %package mysql
386 Summary:        Cyrus SASL MySQL plugin
387 Summary(pl):    Wtyczka MySQL do Cyrus SASL
388 Group:          Libraries
389 Requires:       %{name} = %{version}-%{release}
390
391 %description mysql
392 Cyrus SASL MySQL plugin.
393
394 %description mysql -l pl
395 Wtyczka MySQL do Cyrus SASL.
396
397 %package pgsql
398 Summary:        Cyrus SASL PostgreSQL plugin
399 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
400 Group:          Libraries
401 Requires:       %{name} = %{version}-%{release}
402
403 %description pgsql
404 Cyrus SASL PostgreSQL plugin.
405
406 %description pgsql -l pl
407 Wtyczka PostgreSQL do Cyrus SASL.
408
409 %package sqlite
410 Summary:        Cyrus SQLite PostgreSQL plugin
411 Summary(pl):    Wtyczka SQLite do Cyrus SASL
412 Group:          Libraries
413 Requires:       %{name} = %{version}-%{release}
414
415 %description sqlite
416 Cyrus SASL SQLite plugin.
417
418 %description sqlite -l pl
419 Wtyczka SQLite do Cyrus SASL.
420
421 %prep
422 %setup -q
423 %patch0 -p1
424 %patch1 -p1
425 %patch2 -p1
426 %patch3 -p1
427 %patch4 -p1
428 %if %{with cryptedpw}
429 %patch5 -p1
430 %patch6 -p1
431 %endif
432
433 cd doc
434 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
435 ls rfc*.txt >> rfc-compliance
436 rm -f rfc*.txt
437 cd ..
438
439 rm -rf autom4te.cache saslauthd/autom4te.cache
440 # acinclude.m4 contains only old libtool.m4
441 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
442
443 %build
444 %{__libtoolize}
445 %{__aclocal} -I cmulocal -I config
446 %{__autoheader}
447 %{__automake}
448 %{__autoconf}
449
450 cd saslauthd
451 %{__libtoolize}
452 %{__aclocal} -I ../cmulocal -I ../config -I config
453 %{__autoheader}
454 %{__automake}
455 %{__autoconf}
456 cd ..
457
458 %configure \
459         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
460         --disable-krb4 \
461         %{!?with_gssapi: --disable-gssapi} \
462         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
463         --enable-login \
464         --enable-sample \
465         --enable-sql \
466         %{?with_srp: --enable-srp} \
467         --enable-static \
468         --with-plugindir=%{_libdir}/sasl2 \
469         --with-configdir=%{_sysconfdir} \
470         --with-dblib=berkeley \
471         --with-dbpath=/var/lib/sasl2/sasl.db \
472         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
473         %{?with_ldap: --with-ldap=%{_prefix}} \
474         %{?with_mysql: --with-mysql=%{_prefix}} \
475         %{?with_pgsql: --with-pgsql=%{_prefix}} \
476         %{?with_sqlite: --with-sqlite=%{_prefix}} \
477         %{?with_opie: --with-opie=%{_prefix}} \
478         --with-pam \
479         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
480         --with-saslauthd=/var/lib/sasl2
481 %{__make}
482
483 %{__make} -C saslauthd testsaslauthd
484 %{__make} -C saslauthd saslcache
485
486 cd doc
487 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
488 for i in $RFCLIST; do
489         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
490         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
491 done
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
496                 $RPM_BUILD_ROOT%{_mandir}/man8
497
498 %{__make} install \
499         sasldir=%{_libdir}/sasl2 \
500         DESTDIR=$RPM_BUILD_ROOT
501
502 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
503 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
504
505 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
506 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
507
508 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
509
510 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
511
512 # create empty config
513 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
514 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
515 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
516 install %{SOURCE3} ./cyrus.pam
517
518 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
519
520 # sample programs for testing sasl
521 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
522 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %post   -p /sbin/ldconfig
528 %postun -p /sbin/ldconfig
529
530 %post saslauthd
531 /sbin/chkconfig --add saslauthd
532 if [ -f /var/lock/subsys/saslauthd ]; then
533         /etc/rc.d/init.d/saslauthd restart 1>&2
534 else
535         echo "Run \"/etc/rc.d/init.d/saslauthd start\" to start saslauthd."
536 fi
537
538 %preun saslauthd
539 if [ "$1" = "0" ]; then
540         if [ -f /var/lock/subsys/saslauthd ]; then
541                 /etc/rc.d/init.d/saslauthd stop 1>&2
542         fi
543         /sbin/chkconfig --del saslauthd
544 fi
545
546 %files
547 %defattr(644,root,root,755)
548 %doc AUTHORS COPYING ChangeLog NEWS README
549 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
550 %dir %{_sysconfdir}
551 %dir %{_libdir}/sasl2
552 %dir /var/lib/sasl2
553 %attr(755,root,root) %{_libdir}/lib*.so.*.*
554 # sample programs to subpackage instead?
555 %attr(755,root,root) %{_bindir}/sasl-sample-client
556 %attr(755,root,root) %{_bindir}/sasl-sample-server
557 %attr(755,root,root) %{_sbindir}/pluginviewer
558 %attr(755,root,root) %{_sbindir}/sasldblistusers2
559 %attr(755,root,root) %{_sbindir}/saslpasswd2
560
561 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
562 %{_mandir}/man8/pluginviewer.8*
563 %{_mandir}/man8/sasldblistusers2.8*
564 %{_mandir}/man8/saslpasswd2.8*
565
566 %files devel
567 %defattr(644,root,root,755)
568 %{_includedir}/sasl
569 %attr(755,root,root) %{_libdir}/lib*.so
570 %{_libdir}/lib*.la
571 %{_mandir}/man3/*
572
573 %files static
574 %defattr(644,root,root,755)
575 %{_libdir}/lib*.a
576
577 %files anonymous
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
580
581 %if %{with gssapi}
582 %files gssapi
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
585 %endif
586
587 %files cram-md5
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
590
591 %files digest-md5
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
594
595 %files login
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
598
599 %files otp
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
602
603 %if %{with opie}
604 %files opie
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
607 %endif
608
609 %files plain
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
612
613 %files sasldb
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
616
617 %if %{with mysql}
618 %files mysql
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
621 %endif
622
623 %if %{with pgsql}
624 %files pgsql
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
627 %endif
628
629 %if %{with sqlite}
630 %files sqlite
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
633 %endif
634
635 %if %{with srp}
636 %files srp
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
639 %endif
640
641 %if %{with x509}
642 %files x509
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
645 %endif
646
647 %if %{with pwcheck}
648 %files pwcheck
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_sbindir}/pwcheck
651 %endif
652
653 %files saslauthd
654 %defattr(644,root,root,755)
655 %doc cyrus.pam
656 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
657 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
658 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
659 %attr(755,root,root) %{_sbindir}/saslauthd
660 %attr(755,root,root) %{_sbindir}/testsaslauthd
661 %attr(755,root,root) %{_sbindir}/saslcache
662 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
663 %{_mandir}/man8/saslauthd.8*
This page took 0.072384 seconds and 4 git commands to generate.