]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- nagios config lib64 safe
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.22
28 Release:        8.4
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-automake_1_10.patch
46 Patch8:         %{name}-nagios-plugin.patch
47 URL:            http://asg.web.cmu.edu/sasl/
48 BuildRequires:  autoconf >= 2.54
49 BuildRequires:  automake
50 %{?with_authlib:BuildRequires:  courier-authlib-devel}
51 BuildRequires:  db-devel
52 BuildRequires:  ed
53 BuildRequires:  groff
54 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
55 BuildRequires:  libtool >= 1.4
56 %{?with_mysql:BuildRequires:    mysql-devel}
57 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
58 BuildRequires:  openssl-devel >= 0.9.7d
59 %{?with_opie:BuildRequires:     opie-devel}
60 BuildRequires:  pam-devel
61 %{?with_pgsql:BuildRequires:    postgresql-devel}
62 BuildRequires:  rpmbuild(macros) >= 1.268
63 %{?with_sqlite:BuildRequires:   sqlite-devel}
64 Requires:       pam >= 0.79.0
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sysconfdir     /etc/sasl
68
69 %define         specflags       -fno-strict-aliasing
70
71 %description
72 This is an implementation of the SASL API, useful for adding
73 authentication, authorization, and security to network protocols. The
74 SASL protocol itself is documented in rfc2222; the API standard is a
75 work in progress.
76
77 Note: remember to install appropriate plugins, or you won't have any
78 authentication mechanisms available.
79
80 %description -l pl.UTF-8
81 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
82 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
83 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
84 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
85 RFC 2222; standaryzacja API jest w toku.
86
87 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
88 doinstalować odpowiednie wtyczki.
89
90 %description -l pt_BR.UTF-8
91 Esta é uma implementação da API SASL, útil para acrescentar
92 autenticação, autorização e seguança (criptografia) para protocolos de
93 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
94 ainda está em desenvolvimento.
95
96 %description -l ru.UTF-8
97 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
98 Authentication and Security Layer, метод для добавления поддержки
99 аутентикации к протоколам, основанным на соединениях.
100
101 %description -l uk.UTF-8
102 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
103 Authentication and Security Layer, метод для додання підтримки
104 аутентикації до протоколів, базованих на з'єднаннях.
105
106 %package devel
107 Summary:        Header files and documentation for cyrus-sasl
108 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
109 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
110 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
111 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
112 Group:          Development/Libraries
113 Requires:       %{name} = %{version}-%{release}
114
115 %description devel
116 This includes the header files and documentation needed to develop
117 applications which use SASL.
118
119 %description devel -l pl.UTF-8
120 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
121
122 %description devel -l pt_BR.UTF-8
123 Este pacote inclui os arquivos de cabeçalho e documentação necessários
124 para desenvolver aplicativos que usem SASL.
125
126 %description devel -l ru.UTF-8
127 Хедеры и библиотеки, необходимые для разработки приложений,
128 использующих Cyrus SASL.
129
130 %description devel -l uk.UTF-8
131 Хедери та бібліотеки, необхідні для розробки програм, що
132 використовують Cyrus SASL.
133
134 %package static
135 Summary:        Static cyrus-sasl libraries
136 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
137 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
138 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
139 Group:          Development/Libraries
140 Requires:       %{name}-devel = %{version}-%{release}
141
142 %description static
143 Static cyrus-sasl libraries.
144
145 %description static -l pl.UTF-8
146 Statyczne biblioteki cyrus-sasl.
147
148 %description static -l ru.UTF-8
149 Статические библиотеки, необходимые для разработки приложений,
150 использующих Cyrus SASL.
151
152 %description static -l uk.UTF-8
153 Статичні бібліотеки, необхідні для розробки програм, що використовують
154 Cyrus SASL.
155
156 %package cram-md5
157 Summary:        Cram-MD5 Cyrus SASL plugin
158 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
159 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
160 Group:          Libraries
161 Requires:       %{name} = %{version}-%{release}
162
163 %description cram-md5
164 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
165 mandatory-to-implement authentication mechanism for a number of
166 protocols; it uses MD5 with a challenge/response system to
167 authenticate the user.
168
169 %description cram-md5 -l pl.UTF-8
170 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
171 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
172 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
173 systemem challenge/response.
174
175 %description cram-md5 -l pt_BR.UTF-8
176 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
177 mecanismo de autenticação obrigatório de ser implementado para vários
178 protocolos: ele usa MD5 com um sistema de desafio/resposta para
179 autenticar o usuário.
180
181 %package digest-md5
182 Summary:        Digest-MD5 Cyrus SASL plugin
183 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
184 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
185 Group:          Libraries
186 Requires:       %{name} = %{version}-%{release}
187
188 %description digest-md5
189 This plugin implements the latest draft of the SASL DIGEST-MD5
190 mechanism. Although not yet finalized, this is likely to become the
191 new mandatory-to-implement authentication system in all new protocols.
192 It's based on the digest md5 authentication system designed for HTTP.
193
194 %description digest-md5 -l pl.UTF-8
195 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
196 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
197 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
198 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
199 Digest-MD5 zaprojektowanym dla HTTP.
200
201 %description digest-md5 -l pt_BR.UTF-8
202 Este plugin implementa a última versão da especificação do mecanismo
203 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
204 provavelmente será o novo sistema de autenticação obrigatório para
205 protocolos novos. Ele é baseado na autenticação md5 digest
206 desenvolvida para HTTP.
207
208 %package plain
209 Summary:        Plain Cyrus SASL plugin
210 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
211 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214
215 %description plain
216 This plugin implements the SASL PLAIN mechanism. Although insecure,
217 PLAIN is useful for transitioning to new security mechanisms, as this
218 is the only mechanism which gives the server a copy of the user's
219 password.
220
221 %description plain -l pl.UTF-8
222 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
223 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
224 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
225 który udostępnia serwerowi kopię hasła użytkownika.
226
227 %description plain -l pt_BR.UTF-8
228 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
229 mecanismo é útil durante transições para novos mecanismos de
230 segurança, pois é o único esquema que fornece uma cópia da senha do
231 usuário para o servidor.
232
233 %package anonymous
234 Summary:        Anonymous Cyrus SASL plugin
235 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
236 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239
240 %description anonymous
241 This plugin implements the SASL ANONYMOUS mechanism, used for
242 anonymous authentication.
243
244 %description anonymous -l pl.UTF-8
245 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
246 anonimowego uwierzytelniania.
247
248 %description anonymous -l pt_BR.UTF-8
249 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
250 autenticação anônima.
251
252 %package gssapi
253 Summary:        GSSAPI Cyrus SASL plugin
254 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
255 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258
259 %description gssapi
260 This plugin implements the SASL GSSAPI mechanism, used for
261 GSSAPI/Kerberos5 authentication.
262
263 %description gssapi -l pl.UTF-8
264 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
265 uwierzytelniania z użyciem GSSAPI/Kerberos5.
266
267 %description gssapi -l pt_BR.UTF-8
268 Este plugin implementa o mecanismo SASL GSSAPI, usado para
269 autenticação Kerberos/GSSAPI.
270
271 %package login
272 Summary:        Unsupported Login Cyrus SASL plugin
273 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
274 Group:          Libraries
275 Requires:       %{name} = %{version}-%{release}
276
277 %description login
278 Unsupported LOGIN Cyrus SASL plugin.
279
280 %description login -l pl.UTF-8
281 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
282 SASL.
283
284 %package srp
285 Summary:        SRP Cyrus SASL plugin
286 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
287 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
288 Group:          Libraries
289 Requires:       %{name} = %{version}-%{release}
290
291 %description srp
292 This plugin implements the SASL SRP mechanism, based on the Secure
293 Remote Password protocol. This mechanism performs mutual
294 authentication and can provide a security layer with replay detection,
295 integrity protection and/or condifentiality protection.
296
297 %description srp -l pl.UTF-8
298 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
299 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
300 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
301 powtarzania, zabezpieczeniem integralności i/lub poufności.
302
303 %description srp -l pt_BR.UTF-8
304 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
305 (Secure Remote Password). Este mecanismo oferece autenticação mútua
306 (do cliente e do servidor) e pode prover uma camada de segurança com
307 detecção de ataques de replay, garantia de integridade e/ou
308 confidencialidade.
309
310 %package otp
311 Summary:        OTP Cyrus SASL plugin
312 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
313 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
314 Group:          Libraries
315 Requires:       %{name} = %{version}-%{release}
316
317 %description otp
318 This plugin implements the SASL OTP (One Time Password) mechanism.
319
320 %description otp -l pl.UTF-8
321 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
322 SASL.
323
324 %package opie
325 Summary:        OPIE Cyrus SASL plugin
326 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
327 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
328 Group:          Libraries
329 Requires:       %{name} = %{version}-%{release}
330
331 %description opie
332 This plugin implements the SASL OPIE (One Time Password) mechanism.
333
334 %description opie -l pl.UTF-8
335 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
336 SASL.
337
338 %package x509
339 Summary:        x509 Cyrus SASL plugin
340 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
341 Group:          Libraries
342 Requires:       %{name} = %{version}-%{release}
343
344 %description x509
345 x509 Cyrus SASL plugin.
346
347 %description x509 -l pl.UTF-8
348 Wtyczka x509 do Cyrus SASL.
349
350 %package saslauthd
351 Summary:        Cyrus SASL authd
352 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
353 Group:          Daemons
354 Requires(post,preun):   /sbin/chkconfig
355 Requires:       %{name} = %{version}-%{release}
356 Requires:       /sbin/chkconfig
357 Requires:       rc-scripts
358
359 %description saslauthd
360 Cyrus SASL authd.
361
362 %description saslauthd -l pl.UTF-8
363 Demon authd do Cyrus SASL.
364
365 %package pwcheck
366 Summary:        Cyrus SASL pwcheck helper
367 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
368 Group:          Libraries
369 Requires:       %{name} = %{version}-%{release}
370
371 %description pwcheck
372 Cyrus SASL pwcheck helper.
373
374 %description pwcheck -l pl.UTF-8
375 Program pomocniczy pwcheck do Cyrus SASL.
376
377 %package sasldb
378 Summary:        Cyrus SASL sasldb plugin
379 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
380 Group:          Libraries
381 Requires:       %{name} = %{version}-%{release}
382
383 %description sasldb
384 Cyrus SASL sasldb plugin.
385
386 %description sasldb -l pl.UTF-8
387 Wtyczka sasldb do Cyrus SASL.
388
389 %package mysql
390 Summary:        Cyrus SASL MySQL plugin
391 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
392 Group:          Libraries
393 Requires:       %{name} = %{version}-%{release}
394
395 %description mysql
396 Cyrus SASL MySQL plugin.
397
398 %description mysql -l pl.UTF-8
399 Wtyczka MySQL do Cyrus SASL.
400
401 %package pgsql
402 Summary:        Cyrus SASL PostgreSQL plugin
403 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
404 Group:          Libraries
405 Requires:       %{name} = %{version}-%{release}
406
407 %description pgsql
408 Cyrus SASL PostgreSQL plugin.
409
410 %description pgsql -l pl.UTF-8
411 Wtyczka PostgreSQL do Cyrus SASL.
412
413 %package sqlite
414 Summary:        Cyrus SQLite PostgreSQL plugin
415 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description sqlite
420 Cyrus SASL SQLite plugin.
421
422 %description sqlite -l pl.UTF-8
423 Wtyczka SQLite do Cyrus SASL.
424
425 %package -n nagios-plugin-check_saslauthd
426 Summary:        Nagios plugin to check health of saslauthd
427 Group:          Networking
428 Requires:       nagios-core
429
430 %description -n nagios-plugin-check_saslauthd
431 Nagios plugin to check health of saslauthd
432
433 %prep
434 %setup -q
435 %patch0 -p1
436 %patch1 -p1
437 %patch2 -p1
438 %patch3 -p1
439 %patch4 -p1
440 %if %{with cryptedpw}
441 %patch5 -p1
442 %patch6 -p1
443 %endif
444 %patch7 -p1
445 %patch8 -p1
446
447 cd doc
448 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
449 ls rfc*.txt >> rfc-compliance
450 rm -f rfc*.txt
451 cd ..
452
453 rm -rf autom4te.cache saslauthd/autom4te.cache
454 # acinclude.m4 contains only old libtool.m4
455 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
456
457 %build
458 %{__libtoolize}
459 %{__aclocal} -I cmulocal -I config
460 %{__autoheader}
461 %{__automake}
462 %{__autoconf}
463
464 cd saslauthd
465 %{__libtoolize}
466 %{__aclocal} -I ../cmulocal -I ../config -I config
467 %{__autoheader}
468 %{__automake}
469 %{__autoconf}
470 cd ..
471
472 %configure \
473         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
474         --disable-krb4 \
475         %{!?with_gssapi: --disable-gssapi} \
476         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
477         --enable-login \
478         --enable-sample \
479         --enable-httpform \
480         --enable-sql \
481         %{?with_srp: --enable-srp} \
482         --enable-static \
483         --with-plugindir=%{_libdir}/sasl2 \
484         --with-configdir=%{_sysconfdir} \
485         --with-dblib=berkeley \
486         --with-dbpath=/var/lib/sasl2/sasl.db \
487         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
488         %{?with_ldap: --with-ldap=%{_prefix}} \
489         %{?with_mysql: --with-mysql=%{_prefix}} \
490         %{?with_pgsql: --with-pgsql=%{_prefix}} \
491         %{?with_sqlite: --with-sqlite=%{_prefix}} \
492         %{?with_opie: --with-opie=%{_prefix}} \
493         --with-pam \
494         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
495         --with-saslauthd=/var/lib/sasl2
496 %{__make}
497
498 %{__make} -C saslauthd testsaslauthd
499 %{__make} -C saslauthd saslcache
500
501 cd doc
502 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
503 for i in $RFCLIST; do
504         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
505         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
506 done
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
511                 $RPM_BUILD_ROOT%{_mandir}/man8
512
513 %{__make} install \
514         sasldir=%{_libdir}/sasl2 \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
518 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
519
520 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
521 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
522
523 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
524
525 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
526
527 # create empty config
528 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
529 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
530 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
531 install %{SOURCE3} cyrus.pam
532
533 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
534
535 # sample programs for testing sasl
536 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
537 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
538
539 # package for ghost
540 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
541
542 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
543 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
544
545 %clean
546 rm -rf $RPM_BUILD_ROOT
547
548 %post   -p /sbin/ldconfig
549 %postun -p /sbin/ldconfig
550
551 %post saslauthd
552 /sbin/chkconfig --add saslauthd
553 %service saslauthd restart
554
555 %preun saslauthd
556 if [ "$1" = "0" ]; then
557         %service saslauthd stop
558         /sbin/chkconfig --del saslauthd
559 fi
560
561 %files
562 %defattr(644,root,root,755)
563 %doc AUTHORS COPYING ChangeLog NEWS README
564 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
565 %dir %{_sysconfdir}
566 %dir %{_libdir}/sasl2
567 %dir /var/lib/sasl2
568 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
570 # sample programs to subpackage instead?
571 %attr(755,root,root) %{_bindir}/sasl-sample-client
572 %attr(755,root,root) %{_bindir}/sasl-sample-server
573 %attr(755,root,root) %{_sbindir}/pluginviewer
574 %attr(755,root,root) %{_sbindir}/sasldblistusers2
575 %attr(755,root,root) %{_sbindir}/saslpasswd2
576
577 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
578 %{_mandir}/man8/pluginviewer.8*
579 %{_mandir}/man8/sasldblistusers2.8*
580 %{_mandir}/man8/saslpasswd2.8*
581
582 %files devel
583 %defattr(644,root,root,755)
584 %{_includedir}/sasl
585 %attr(755,root,root) %{_libdir}/lib*.so
586 %{_libdir}/lib*.la
587 %{_mandir}/man3/*
588
589 %files static
590 %defattr(644,root,root,755)
591 %{_libdir}/lib*.a
592
593 %files anonymous
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
596
597 %if %{with gssapi}
598 %files gssapi
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
601 %endif
602
603 %files cram-md5
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
606
607 %files digest-md5
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
610
611 %files login
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
614
615 %files otp
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
618
619 %if %{with opie}
620 %files opie
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
623 %endif
624
625 %files plain
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
628
629 %files sasldb
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
632
633 %if %{with mysql}
634 %files mysql
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
637 %endif
638
639 %if %{with pgsql}
640 %files pgsql
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
643 %endif
644
645 %if %{with sqlite}
646 %files sqlite
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
649 %endif
650
651 %if %{with srp}
652 %files srp
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
655 %endif
656
657 %if %{with x509}
658 %files x509
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
661 %endif
662
663 %if %{with pwcheck}
664 %files pwcheck
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_sbindir}/pwcheck
667 %endif
668
669 %files saslauthd
670 %defattr(644,root,root,755)
671 %doc cyrus.pam
672 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
673 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
674 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
675 %attr(755,root,root) %{_sbindir}/saslauthd
676 %attr(755,root,root) %{_sbindir}/testsaslauthd
677 %attr(755,root,root) %{_sbindir}/saslcache
678 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
679 %ghost /var/lib/sasl2/cache.flock
680 %ghost /var/lib/sasl2/cache.mmap
681 %ghost /var/lib/sasl2/mux
682 %ghost /var/lib/sasl2/mux.accept
683 %ghost /var/lib/sasl2/saslauthd.pid
684 %{_mandir}/man8/saslauthd.8*
685
686 %files -n nagios-plugin-check_saslauthd
687 %defattr(644,root,root,755)
688 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
689 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.110555 seconds and 4 git commands to generate.