]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
0bb0d86bca2791c689e923cb0278a0fcd67c4982
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.2
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        http://www.cs.cornell.edu/projects/%{name}/%{name}-%{version}.tar.gz
11 Source1:        http://www.cs.cornell.edu/projects/%{name}-%{version}-docs.tar.gz
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-options.patch
14 URL:            http://www.cs.cornell.edu/projects/cyclone/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Cyclone is a language for C programmers who want to write secure, robust
19 programs. It's a dialect of C designed to be safe: free of crashes,
20 buffer overflows, format string attacks, and so on.
21
22 %description -l pl
23 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne i
24 szybkie programy. Jest on dialektem C zaprojektowanym by byæ bezpiecznym:
25 wolnym od SEGV, przepe³nieñ buforów, format string attacks, itd.
26
27 %prep
28 %setup -q -n %{name} -a1
29 %patch0 -p1
30 %patch1 -p1
31
32 %build
33 ./configure \
34         -sh /bin/sh \
35         -bindir %{_bindir} \
36         -libdir %{_libdir}/%{name} \
37         -incdir %{_includedir}/%{name} 
38
39 %{__make}
40 %{__make} cyclone_src
41 %{__make} update
42 # hack, there is no doc/ in source distribution
43 mkdir doc
44 echo 'clean:' > doc/Makefile
45 %{__make} clean_nogc
46 # here we got C sources generated from patched cyclone,
47 # we can build for real.
48 %{__make} CFLAGS="%{rpmcflags}" CYC_FLAGS="%{rpmcflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 make install DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc online-manual/*
61 %attr(755, root, root) %{_bindir}/*
62 %{_libdir}/%{name}
63 %{_includedir}/%{name}
This page took 0.043901 seconds and 3 git commands to generate.