]> git.pld-linux.org Git - packages/cvs-nserver.git/blob - cvs-nserver.spec
- added %preun
[packages/cvs-nserver.git] / cvs-nserver.spec
1 Summary:        Concurrent Versions System
2 Summary(de):    Concurrent-Versioning-System
3 Summary(fr):    Un système pour maintenir à jour des fichiers
4 Summary(pl):    Concurrent Versioning System
5 Summary(tr):    Sürüm denetim sistemi
6 Name:           cvs-nserver
7 Version:        1.11.1.2
8 Release:        1
9 License:        GPL
10 Group:          Development/Version Control
11 Group(pl):      Programowanie/Zarz±dzanie wersjami
12 Source0:        http://alexm.here.ru/cvs-nserver/download/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-cvspasswd.patch
14 # outdated, but maybe will be needed for checkpasswd (outside programs):
15 #Patch0:                cvs-nserver-PAM_fix.patch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 CVS is a version control system, which allows you to keep old versions
20 of files (usually source code), keep a log of who, when, and why
21 changes occurred, etc., like RCS or SCCS. Unlike the simpler systems,
22 CVS does not just operate on one file at a time or one directory at a
23 time, but operates on hierarchical collections of directories
24 consisting of version controlled files. CVS helps to manage releases
25 and to control the concurrent editing of source files among multiple
26 authors. CVS allows triggers to enable/log/control various operations
27 and works well over a wide area network.
28
29 %description -l de
30 CVS ist ein Frontend für das RCS(1)-Revisionskontrollsystem, das den
31 Begriff der Revisionskontrolle von einer Sammlung von Dateien in einem
32 einzelnen Verzeichnis auf eine ganze Hierarchie ausweitet, bestehend
33 aus revisionskontrollierten Dateien. Diese Verzeichnisse und Dateien
34 lassen sich zu einer Software-Release kombinieren. CVS bietet die
35 Funktionen, die zur Verwaltung von Software-Releases und zur
36 Überwachung der gleichzeitigen Bearbeitung von Quelldateien durch
37 mehrere Software- Entwickler notwendig sind.
38
39 %description -l fr
40 "CVS" signifie "Concurrent Version System". C'est un système de
41 comparaison de versions de fichiers, qui peut garder une trace des
42 changements apportés à des fichiers (le plus souvent, les fichiers des
43 sources d'un programme). CVS conserve seulement les différences, et
44 non l'intégralité d'un fichier récent et d'un fichier plus ancien. A
45 chaque modification d'un fichier, CVS garde (entre autres) le nom de
46 la personne ayant fait la modification, la raison justifiant cette
47 modification, et la date à laquelle celle-ci a eu lieu. CVS est très
48 utile pour gérer la mise en commun des modifications apportées par
49 plusieurs personnes travaillant en parallèle sur les mêmes fichiers.
50 Au lieu de garder plusieurs versions des fichiers dans un seul
51 répertoire, CVS crée une série de répertoires, chacun contenant une
52 nouvelle version des fichiers. Ces répertoires et ces fichiers peuvent
53 ensuite être regroupés pour former la version la plus à jour du
54 logiciel. Installez ce package si vous avez besoin d'utiliser un
55 système de contrôle de version.
56
57 %description -l pl
58 CVS jest nak³adk± na rcs (Revision Control System, czyli w wolnym
59 t³umaczeniu system kontroli wersji zasobów), który rozszerza
60 mo¿liwo¶ci rcs'a z narzêdzia do kontroli zbioru plików w pojedynczym
61 katalogu o mo¿liwo¶æ kontroli zbioru hierarchicznie u³o¿onych katalogów
62 z plikami. Z pomoc± CVS w ³atwy sposób mo¿na zarz±dzaæ kodem ¼ród³owym
63 opracowywanym przez nawet bardzo du¿e zespó³y programistów
64 umo¿liwiaj±c ¶ledzenie i kontrolê wszystkich zmian w trakcie pracy nad
65 projektami i wypuszczaniem pe³nych wersji oprogramowania (release).
66
67 %description -l tr
68 CVS (Concurrent Versioning System), tek bir dizindeki dosya
69 topluluðunun sürüm denetimini, denetimi yapýlmýþ dizinlerin hiyerarþik
70 topluluðuna geniþleten rcs(1) sürüm denetim sisteminin ön yüzüdür. Bu
71 dizin ve dosyalar, bir yazýlým yayýný oluþturma amacýyla biraraya
72 getirilebilir. CVS, bu yazýlým yayýnlarýnýn yönetilmesini ve kaynak
73 dosyalarý bakýmýnýn birden çok yazýlým geliþtiricisi tarafýndan
74 eþzamanlý olarak yapýlmasýný kontrol etmek için gereken iþlevleri
75 saðlar.
76
77 %package client
78 Summary:        Concurrent Versions System - client
79 Summary(pl):    Concurrent Versioning System - klient
80 Group:          Development/Version Control
81
82 %description client
83 client
84
85 %description -l pl client
86 klient
87
88 %prep
89 %setup -q 
90 %patch0 -p1
91
92 %build
93 autoconf
94 %configure \
95         --enable-encryption \
96         --enable-client \
97         --enable-server \
98         --enable-setuid
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %{__make} DESTDIR=$RPM_BUILD_ROOT install
104
105 %pre
106 if [ -n "`getgid cvs`" ]; then
107         if [ "`getgid cvs`" != "52" ]; then
108                 echo "Warning: group cvs haven't gid=52. Correct this before installing cvs-nserver" 1>&2
109                 exit 1
110         fi
111 else
112         /usr/sbin/groupadd -g 52 -r -f cvs
113 fi
114 if [ -n "`getgid cvsadmin`" ]; then
115         if [ "`getgid cvsadmin`" != "53" ]; then
116                 echo "Warning: group cvsadmin haven't gid=53. Correct this before installing cvs-nserver" 1>&2
117                 exit 1
118         fi
119 else
120         /usr/sbin/groupadd -g 53 -r -f cvsadmin
121 fi
122 if [ -n "`id -u cvs 2>/dev/null`" ]; then
123         if [ "`id -u cvs`" != "52" ]; then
124                 echo "Warning: user cvs haven't uid=52. Correct this before installing cvs-nserver" 1>&2
125                 exit 1
126         fi
127 else
128         /usr/sbin/useradd -u 52 -r -d /home/cvsroot -s /bin/false -c "CVS user" -g cvs cvs 1>&2
129 fi
130 if [ -n "`id -u cvsadmin 2>/dev/null`" ]; then
131         if [ "`id -u cvsadmin`" != "53" ]; then
132                 echo "Warning: user cvsadmin haven't uid=53. Correct this before installing cvs-nserver" 1>&2
133                 exit 1
134         fi
135 else
136         /usr/sbin/useradd -u 53 -r -d /home/cvsroot -s /bin/false -c "CVS user" -g cvs cvsadmin 1>&2
137 fi
138
139 %preun
140 /usr/sbin/userdel cvs
141 /usr/sbin/userdel cvsadmin
142 /usr/sbin/groupdel cvs
143 /usr/sbin/groupdel cvsadmin
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/cvschkpw
151 %attr(755,root,root) %{_bindir}/cvs-pserver
152 %attr(755,root,root) %{_bindir}/cvs-nserver
153 %attr(755,root,root) %{_bindir}/rcs2log
154 %attr(4750,cvsadmin,cvs) %{_bindir}/cvspasswd
155 %{_infodir}/cvs.*
156 %{_mandir}/man8/cvs-pserver.8*
157 %{_mandir}/man8/cvs-nserver.8*
158 %{_mandir}/man8/cvs-server.8*
159 %dir /usr/share/cvs-nserver/*
160
161 %files client
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/cvs
164 %attr(755,root,root) %{_bindir}/cvsbug
165 %{_infodir}/cvsclient*
166 %{_mandir}/man1/cvs.1*
167 %{_mandir}/man5/cvs.5*
168 %{_mandir}/man8/cvsbug.8*
This page took 0.068425 seconds and 4 git commands to generate.