]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
2100afdd728eff2ad14bdc90a7ebf5b61c561cbe
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without MIT Kerberos 5 support
8 #
9 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
10 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
11 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
12 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
13 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
14 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
15 Name:           curl
16 Version:        7.19.2
17 Release:        1
18 License:        MIT-like
19 Group:          Applications/Networking
20 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
21 # Source0-md5:  3a461b145a4a31fe7d5a44684e7fbdbc
22 Patch0:         %{name}-no_strip.patch
23 Patch1:         %{name}-ac.patch
24 Patch2:         %{name}-pc.patch
25 URL:            http://curl.haxx.se/
26 BuildRequires:  autoconf >= 2.57
27 BuildRequires:  automake
28 %{?with_ares:BuildRequires:     c-ares-devel}
29 %{?with_kerberos5:BuildRequires:        krb5-devel}
30 BuildRequires:  libidn-devel >= 0.4.1
31 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
32 BuildRequires:  libtool
33 BuildRequires:  openldap-devel
34 %if %{with ssl}
35 %if %{with gnutls}
36 BuildRequires:  gnutls-devel
37 %else
38 BuildRequires:  openssl-devel >= 0.9.7d
39 %endif
40 %endif
41 BuildRequires:  zlib-devel
42 Requires:       %{name}-libs = %{version}-%{release}
43 Requires:       libidn >= 0.4.1
44 %{?with_ssh:Requires:   libssh2 >= 0.16}
45 Requires:       openssl-tools >= 0.9.7d
46 Obsoletes:      libcurl2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 cURL is a tool for getting files with URL syntax, supporting FTP,
51 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
52 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
53 cookies, user+password authentication and a busload of other useful
54 tricks. The main use for curl is when you want to get or send files
55 automatically to or from a site using one of the supported protocols.
56
57 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58 Dict servers, using any of the supported protocols. cURL is designed
59 to work without user interaction or any kind of interactivity. cURL
60 offers many useful capabilities, like proxy support, user
61 authentication, FTP upload, HTTP post, and file transfer resume.
62
63 %description -l pl.UTF-8
64 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
65 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
66 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
67 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
68 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
69 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
70 pliki z/na serwer używając jednego z dostępnych protokołów.
71 %{?with_ssl:Ten pakiet obsługuje także SSL.}
72
73 %description -l pt_BR.UTF-8
74 Curl é um cliente para baixar/enviar arquivos de/para servidores
75 usando um dos protocolos suportados. É projetado para funcionar sem a
76 interação do usuário.
77
78 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
79 continuar transferências interrompidas, e mais...
80
81 %description -l ru.UTF-8
82 curl - это клиент с множеством поддерживаемых протоколов для получения
83 файлов с серверов, спроектированный для работы как в неинтерактивном
84 режиме, так и с возможностью диалога с пользователем.
85
86 curl поддерживает много полезных возможностей, среди которых поддержка
87 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
88 POST, восстановление прерванной пересылки и многое другое.
89
90 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
91 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
92 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
93
94 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
95 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
96 в╕дновлення перервано╖ пересилки та багато ╕ншого.
97
98 %package libs
99 Summary:        curl library
100 Summary(pl.UTF-8):      Biblioteka curl
101 Group:          Libraries
102 Requires:       ca-certificates >= 20080809-4
103
104 %description libs
105 curl library.
106
107 %description libs -l pl.UTF-8
108 Biblioteka curl.
109
110 %package devel
111 Summary:        Header files and development documentation for curl library
112 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
113 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
114 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
115 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
116 Group:          Development/Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118 %{?with_ares:Requires:  c-ares-devel}
119 %{?with_kerberos5:Requires:     krb5-devel}
120 Requires:       libidn-devel >= 0.4.1
121 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
122 %if %{with ssl}
123 %if %{with gnutls}
124 Requires:       gnutls-devel
125 %else
126 Requires:       openssl-devel >= 0.9.7c
127 %endif
128 %endif
129 Requires:       zlib-devel
130 Obsoletes:      libcurl2-devel
131
132 %description devel
133 Header files and development documentation for curl library.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe i dokumentacja do biblioteki curl.
137
138 %description devel -l pt_BR.UTF-8
139 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
140
141 %description devel -l ru.UTF-8
142 Этот пакет содержит файлы, необходимые для разработки программ с
143 использованием библиотеки curl.
144
145 %description devel -l uk.UTF-8
146 Цей пакет містить файли, необхідні для розробки програм з
147 використанням бібліотеки curl.
148
149 %package static
150 Summary:        Static version of curl library
151 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
152 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
153 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
154 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}-%{release}
157
158 %description static
159 Static version of curl library.
160
161 %description static -l pl.UTF-8
162 Statyczna wersja biblioteki curl.
163
164 %description static -l pt_BR.UTF-8
165 Bibliotecas estáticas para desenvolvimento com o curl.
166
167 %description static -l ru.UTF-8
168 Этот пакет содержит статическую библиотеку для разработки программ с
169 использованием библиотеки curl.
170
171 %description static -l uk.UTF-8
172 Цей пакет містить статичну бібліотеку для розробки програм з
173 використанням бібліотеки curl.
174
175 %prep
176 %setup -q
177 %patch0 -p1
178 %patch1 -p1
179 %patch2 -p1
180
181 %build
182 %{__libtoolize}
183 %{__aclocal} -I m4
184 %{__autoconf}
185 %{__autoheader}
186 %{__automake}
187 %configure \
188         ac_cv_header_gss_h=no \
189 %if %{with ssl}
190         --with-ca-bundle=/etc/certs/ca-certificates.crt \
191 %if %{with gnutls}
192         --with-gnutls=%{_prefix} --without-ssl \
193 %else
194         --with-ssl=%{_prefix} \
195 %endif
196 %endif
197         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
198         %{?with_ares:--enable-ares=%{_prefix}} \
199         --enable-ldaps \
200         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
201
202 %{__make}
203
204 %install
205 rm -rf $RPM_BUILD_ROOT
206
207 %{__make} install \
208         DESTDIR=$RPM_BUILD_ROOT
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %post   libs -p /sbin/ldconfig
214 %postun libs -p /sbin/ldconfig
215
216 %files
217 %defattr(644,root,root,755)
218 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
219 %attr(755,root,root) %{_bindir}/curl
220 %{_mandir}/man1/curl.1*
221
222 %files libs
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
225 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
226
227 %files devel
228 %defattr(644,root,root,755)
229 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
230 %attr(755,root,root) %{_bindir}/curl-config
231 %attr(755,root,root) %{_libdir}/libcurl.so
232 %{_libdir}/libcurl.la
233 %{_includedir}/curl
234 %{_pkgconfigdir}/libcurl.pc
235 %{_mandir}/man1/curl-config.1*
236 %{_mandir}/man3/curl_*.3*
237 %{_mandir}/man3/libcurl*.3*
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libcurl.a
This page took 0.031698 seconds and 2 git commands to generate.