]> git.pld-linux.org Git - packages/ctags.git/blob - ctags.spec
1d49f9f92893a02ad3a6e6d55c4714e3d2ec67f3
[packages/ctags.git] / ctags.spec
1 Summary:     Exuberant ctags -- C cross-reference tool
2 Summary(de): Exuberant ctags - C-Cross-Reference-Tool 
3 Summary(fr): ctags exubérant
4 Summary(pl): ctags - generator list odwo³añ
5 Summary(tr): C dili için çapraz-baþvuru (cross-reference) aracý
6 Name:        ctags
7 Version:     3.0.3
8 Release:     1
9 Copyright:   GPL
10 Group:       Development/Languages
11 Source:      ftp://ftp.revnet.com/pub/ctags/archives/%{name}-%{version}.tar.gz
12 URL:         http://darren.hiebert.com/ctags
13 Buildroot:   /tmp/%{name}-%{version}-root
14
15 %description
16 A better ctags which generates tags for all possible tag types: macro
17 definitions, enumerated values (values inside enum{...}), function and
18 method definitions, enum/struct/union tags, external function prototypes
19 (optional), typedefs, and variable declarations. It is far less easily
20 fooled by code containing #if preprocessor conditional constructs, using a
21 conditional path selection algorithm to resolve complicated choices, and a
22 fall-back algorithm when this one fails. Can also be used to print out a
23 list of selected objects found in source files.
24
25 %description -l de
26 Ein verbessertes ctags, das tags für alle möglichen tag-Typen generiert:
27 Makrodefinitionen, aufgezählte Werte (Werte in enum{...}), Funktions- und
28 Methodendefinitionen, enum/struct/union-tags, externe Funktionsprototypen
29 (wahlweise), typedefs und variable Deklarationen. Es läßt sich weit weniger
30 gut durch Code täuschen, der #if-Präprozessor-Bedingungen enthält, dank
31 eines konditionalen Pfadauswahlalgorithmus, der komplizierte Entscheidungen
32 trifft, und eines Ausweiche-Algorithmus, der ins Spiel kommt, wenn der erste
33 dem Problem nicht gewachsen ist.  Kann auch benutzt werden, um eine Liste
34 ausgewählter Objekte, die in Quelldateien gefunden wurden, auszudrucken.
35
36 %description -l fr
37 un ctags amélioré générant des tags pour tous les types de tags possibles :
38 définitions de macros, valeurs énumérées (valeurs dans enum{...}),
39 définitions de fonctions et de méthodes, enum/struct/union tags, prototypes
40 de fonctions externes (optionnel), typedefs, et déclarations de variables.
41 Peut aussi être utilisé pour afficher une liste des objets choisis trouvés
42 dans les fichiers source.
43
44 %description -l pl
45 Generator tabeli odwo³añ dla: makr, zmiennych, funkcji i procedur, definicji
46 typów, metod (C++) itp. U¿ywany do generacji listy wyspecyfikowanych
47 obiektów znalezionych w plikach ¼ród³owych. Tablica owych odwo³añ mo¿e byæ
48 wykorzystywana przez wiekszosæ standardowych edytorów tekstu (vim, joe,
49 emacs), do przemieszczania siê w ¼ród³ach miêdzy deklaracj± i u¿yciem danego
50 symbolu.
51
52 %description -l tr
53 Olabilecek her türlü etiket çeþitleri - makro tanýmlamalarý, sayýlý
54 (enumerated) deðerler, fonksiyon ve yöntem (method) tanýmlamalarý, tip ve
55 deðiþken tanýmlarý - için etiketler üretir. Kaynak kodlarýnda bulunan,
56 seçilmiþ nesnelerin listesinin çýktýsýný yazýcýdan almak için de
57 kullanýlabilir.
58
59 %prep
60 %setup -q
61
62 %build
63 CFLAGS=$RPM_OPT_FLAGS LDFLAGS="-s" \
64 ./configure \
65         --prefix=/usr
66 make
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 make prefix=$RPM_BUILD_ROOT/usr install
71
72 rm -f $RPM_BUILD_ROOT/usr/man/man1/etags.1
73 echo ".so ctags.1" > $RPM_BUILD_ROOT/usr/man/man1/etags.1
74
75 gzip -9nf $RPM_BUILD_ROOT/usr/man/man1/*
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %attr(644, root, root, 755) %doc FAQ NEWS QUOTES README
82 %attr(755, root, root) /usr/bin/*
83 %attr(644, root,  man) /usr/man/man1/*
84
85 %changelog
86 * Fri Dec 11 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
87   [3.0-1]
88 - added gzipping man pages,
89 - added using LDFLAGS="-s" to ./configure enviroment.
90 - etags(1) man page is now maked as nroff include to ctags(1) instead
91   making sym link to ctags.1 (this allow compress man pages).
92
93 * Wed Aug 26 1998 Wojciech "Sas" Ciêciwa <cieciwa@zarz.agh.edu.pl>
94   [2.3.1-1]
95 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
96 - added URL,
97 - changed base Source URL to ftp://ftp.revnet.com/pub/ctags/,
98 - added pl translation.
99  
100 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
101 - translations modified for de, fr, tr
102
103 * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
104 - upgraded to 2.0.3
105
106 * Mon Nov 03 1997 Michael K. Johnson <johnsonm@redhat.com>
107 - removed etags.  Emacs provides its own; and needs to support
108   more than just C.
109
110 * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
111 - updated from 1.5 to 1.6
112
113 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
114 - built against glibc
This page took 0.051173 seconds and 3 git commands to generate.