]> git.pld-linux.org Git - packages/csync2.git/blob - csync2.spec
18b620787cffab5eafc90ed3b1dbdf7ef4761a85
[packages/csync2.git] / csync2.spec
1 Summary:        Cluster sync tool
2 Summary(pl.UTF-8):      Narzędzie do synchronizacji klastra
3 Name:           csync2
4 Version:        1.34
5 Release:        2
6 License:        GPL v2+
7 Group:          Daemons
8 Source0:        http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
9 # Source0-md5:  efc8a3548996b79cef2ad76af5e93cd8
10 Source1:        %{name}.init
11 Source2:        %{name}.inet
12 Source3:        %{name}.sysconfig
13 Patch0:         %{name}-man_fix.patch
14 URL:            http://oss.linbit.com/csync2/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gnutls-devel
18 BuildRequires:  librsync-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  sqlite-devel
21 Requires:       setup > 2.4.10-4
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc/%{name}
25
26 %description
27 Csync2 is a cluster synchronization tool. It can be used to keep files
28 on multiple hosts in a cluster in sync. Csync2 can handle complex
29 setups with much more than just 2 hosts, handle file deletions and can
30 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
31 and server farms.
32
33 %description -l pl.UTF-8
34 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
35 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
36 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
37 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
38 klastrów HA, HPC, COW oraz farm serwerów.
39
40 %package -n csync2-inetd
41 Summary:        Files necessary to run csync2 in inetd service mode
42 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie usługi inetd
43 Group:          Networking/Daemons
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       rc-inetd
46 Provides:       csyncd
47 Provides:       csyncd-inetd
48 Obsoletes:      csyncd
49 Obsoletes:      csync2-standalone
50 Obsoletes:      csyncd-standalone
51
52 %description -n csync2-inetd
53 Csync2 is a cluster synchronization tool. It can be used to keep files
54 on multiple hosts in a cluster in sync. Csync2 can handle complex
55 setups with much more than just 2 hosts, handle file deletions and can
56 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
57 and server farms.
58
59 %description -n csync2-inetd -l pl.UTF-8
60 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
61 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
62 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
63 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
64 klastrów HA, HPC, COW oraz farm serwerów.
65
66 %package -n csync2-standalone
67 Summary:        Files necessary to run csync2 in standalone daemon mode
68 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie samodzielnego serwera
69 Group:          Networking/Daemons
70 Requires(post,preun):   /sbin/chkconfig
71 Requires:       %{name} = %{version}-%{release}
72 Provides:       csyncd
73 Provides:       csyncd-standalone
74 Obsoletes:      csyncd
75 Obsoletes:      csync2-inetd
76 Obsoletes:      csyncd-inetd
77
78 %description -n csync2-standalone
79 Csync2 is a cluster synchronization tool. It can be used to keep files
80 on multiple hosts in a cluster in sync. Csync2 can handle complex
81 setups with much more than just 2 hosts, handle file deletions and can
82 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
83 and server farms.
84
85 %description -n csync2-standalone -l pl.UTF-8
86 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
87 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
88 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
89 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
90 klastrów HA, HPC, COW oraz farm serwerów.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95
96 %build
97 %configure
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_var}/lib/csync2,/etc/{sysconfig/rc-inetd,rc.d/init.d}}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
108 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
109 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post -n csync2-inetd
115 %service -q rc-inetd reload
116
117 %postun -n csync2-inetd
118 if [ "$1" = "0" ]; then
119         %service -q rc-inetd reload
120 fi
121
122 %post -n csync2-standalone
123 /sbin/chkconfig --add csync2
124 %service csync2 restart "csync2 server"
125
126 %preun -n csync2-standalone
127 if [ "$1" = "0" ]; then
128         %service csync2 stop
129         /sbin/chkconfig --del csync2
130 fi
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog README TODO csync2.xinetd csync2_locheck.sh paper.pdf
135 %dir %{_sysconfdir}
136 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/csync2.cfg
137 %attr(755,root,root) %{_sbindir}/csync2
138 %attr(755,root,root) %{_sbindir}/csync2-compare
139 %dir %{_var}/lib/csync2
140 %{_mandir}/man1/*.1*
141
142 %files -n csync2-inetd
143 %defattr(644,root,root,755)
144 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/%{name}
145
146 %files -n csync2-standalone
147 %defattr(644,root,root,755)
148 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
149 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.07875 seconds and 3 git commands to generate.