]> git.pld-linux.org Git - packages/cryptsetup.git/blob - cryptsetup.spec
- rel 7; change to C
[packages/cryptsetup.git] / cryptsetup.spec
1 #
2 # Conditonal build:
3 %bcond_without  initrd  # don't build initrd version
4 #
5 %define realname        cryptsetup
6 Summary:        LUKS for dm-crypt implemented in cryptsetup
7 Summary(pl.UTF-8):      LUKS dla dm-crypta zaimplementowany w cryptsetup
8 Name:           cryptsetup-luks
9 Version:        1.0.6
10 Release:        7
11 License:        GPL v2
12 Group:          Base
13 Source0:        http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
14 # Source0-md5:  00d452eb7a76e39f5749545d48934a10
15 Patch1:         %{name}-nostatic.patch
16 Patch2:         %{name}-udev.patch
17 URL:            http://luks.endorphin.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  device-mapper-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  libgcrypt-devel >= 1.1.42
23 BuildRequires:  libselinux-devel
24 BuildRequires:  libsepol-devel
25 BuildRequires:  libtool
26 BuildRequires:  libuuid-devel
27 BuildRequires:  popt-devel
28 %if %{with initrd}
29 BuildRequires:  device-mapper-static >= 1.02.07
30 BuildRequires:  libgcrypt-static >= 1.1.42
31 BuildRequires:  libgpg-error-static
32 BuildRequires:  libselinux-static
33 BuildRequires:  libsepol-static
34 BuildRequires:  libuuid-static
35 BuildRequires:  popt-static
36 %endif
37 Conflicts:      udev-core < 1:115
38 Provides:       cryptsetup = %{version}
39 Obsoletes:      cryptsetup
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sbindir        /sbin
43 %define         _noautoreqdep   libcryptsetup.so.0
44
45 %description
46 LUKS is the upcoming standard for Linux hard disk encryption. By
47 providing a standard on-disk-format, it does not only facilitate
48 compatibility among distributions, but also provide secure management
49 of multiple user passwords. In contrast to existing solution, LUKS
50 stores all setup necessary setup information in the partition header,
51 enabling the user to transport or migrate his data seamlessly.
52
53 This package contains implementation of LUKS for dm-crypt implemented
54 in cryptsetup.
55
56 %description -l pl.UTF-8
57 LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
58 Dostarczając standardowy format danych na dysku nie tylko ułatwia
59 utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
60 bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
61 do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
62 informacje o konfiguracji w nagłówku partycji, pozwalając
63 użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
64
65 Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
66 cryptsetup.
67
68 %package devel
69 Summary:        Header files for cryptsetup library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cryptsetup
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       device-mapper-devel
74 Requires:       libgcrypt-devel >= 1.1.42
75 Obsoletes:      cryptsetup-devel
76
77 %description devel
78 Header files for cryptsetup library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki cryptsetup.
82
83 %package static
84 Summary:        Static cryptsetup library
85 Summary(pl.UTF-8):      Statyczna biblioteka cryptsetup
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Obsoletes:      cryptsetup-static
89
90 %description static
91 Static version of cryptsetup library.
92
93 %description static -l pl.UTF-8
94 Statyczna wersja biblioteki cryptsetup.
95
96 %package initrd
97 Summary:        LUKS for dm-crypt implemented in cryptsetup - initrd version
98 Group:          Base
99 Requires:       udev-initrd >= 1:115
100
101 %description initrd
102 This package contains implementation of LUKS for dm-crypt implemented
103 in cryptsetup - staticaly linked for initrd.
104
105 %prep
106 %setup -q -n %{realname}-%{version}
107 %patch1 -p1
108 %patch2 -p1
109
110 %build
111 %{__gettextize}
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117
118 %if %{with initrd}
119 %configure \
120         --disable-shared-library \
121         --enable-static \
122         --enable-static-cryptsetup \
123         --disable-nls
124 %{__make}
125 mv src/cryptsetup cryptsetup-initrd
126 %{__make} clean
127 %endif
128
129 %configure \
130         --enable-static
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 install -d $RPM_BUILD_ROOT/%{_lib}
140 mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
141 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
142         $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
143
144 %if %{with initrd}
145 install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
146 %endif
147
148 %find_lang %{realname}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files -f %{realname}.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog TODO
159 %attr(755,root,root) %{_sbindir}/cryptsetup
160 %attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
161 %attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
162 %{_mandir}/man8/cryptsetup.8*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libcryptsetup.so
167 %{_libdir}/libcryptsetup.la
168 %{_includedir}/libcryptsetup.h
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libcryptsetup.a
173
174 %if %{with initrd}
175 %files initrd
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_sbindir}/cryptsetup-initrd
178 %endif
This page took 0.06024 seconds and 4 git commands to generate.