]> git.pld-linux.org Git - packages/cryptsetup-luks.git/blob - cryptsetup-luks.spec
- up to 1.0.5
[packages/cryptsetup-luks.git] / cryptsetup-luks.spec
1 #
2 # Conditonal build:
3 %bcond_with     static  # link cryptsetup statically
4 #
5 %define _realname       cryptsetup
6 Summary:        LUKS for dm-crypt implemented in cryptsetup
7 Summary(pl.UTF-8):      LUKS dla dm-crypta zaimplementowany w cryptsetup
8 Name:           cryptsetup-luks
9 Version:        1.0.5
10 Release:        1
11 License:        GPL
12 Group:          Base
13 Source0:        http://luks.endorphin.org/source/%{_realname}-%{version}.tar.bz2
14 # Source0-md5:  0aa2f94c39123f1a0352983e5366179c
15 Patch1:         %{name}-nostatic.patch
16 URL:            http://luks.endorphin.org/about
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  device-mapper-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  libgcrypt-devel >= 1.1.42
22 BuildRequires:  libselinux-devel
23 BuildRequires:  libsepol-devel
24 BuildRequires:  libuuid-devel
25 BuildRequires:  popt-devel
26 BuildRequires:  libtool
27 %if %{with static}
28 BuildRequires:  device-mapper-static >= 1.02.07
29 BuildRequires:  libgcrypt-static >= 1.1.42
30 BuildRequires:  libgpg-error-static
31 BuildRequires:  libselinux-static
32 BuildRequires:  libsepol-static
33 BuildRequires:  libuuid-static
34 BuildRequires:  popt-static
35 %endif
36 Obsoletes:      cryptsetup
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _sbindir        /sbin
40 %define         _noautoreqdep   libcryptsetup.so.0
41
42 %description
43 LUKS is the upcoming standard for Linux hard disk encryption. By
44 providing a standard on-disk-format, it does not only facilitate
45 compatibility among distributions, but also provide secure management
46 of multiple user passwords. In contrast to existing solution, LUKS
47 stores all setup necessary setup information in the partition header,
48 enabling the user to transport or migrate his data seamlessly.
49
50 This package contains implementation of LUKS for dm-crypt implemented
51 in cryptsetup.
52
53 %description -l pl.UTF-8
54 LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
55 Dostarczając standardowy format danych na dysku nie tylko ułatwia
56 utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
57 bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
58 do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
59 informacje o konfiguracji w nagłówku partycji, pozwalając
60 użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
61
62 Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
63 cryptsetup.
64
65 %package devel
66 Summary:        Header files for cryptsetup library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cryptsetup
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       device-mapper-devel
71 Requires:       libgcrypt-devel >= 1.1.42
72 Obsoletes:      cryptsetup-devel
73
74 %description devel
75 Header files for cryptsetup library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki cryptsetup.
79
80 %package static
81 Summary:        Static cryptsetup library
82 Summary(pl.UTF-8):      Statyczna biblioteka cryptsetup
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Obsoletes:      cryptsetup-static
86
87 %description static
88 Static version of cryptsetup library.
89
90 %description static -l pl.UTF-8
91 Statyczna wersja biblioteki cryptsetup.
92
93 %prep
94 %setup -q -n %{_realname}-%{version}
95 %patch1 -p1
96
97 %build
98 %{__gettextize}
99 %{__autoheader}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --enable-static \
105         %{?with_static:--enable-static-cryptsetup}
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT/%{_lib}
115 mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
116 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libcryptsetup.so.*.*.*) \
117         $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
118
119 %find_lang %{_realname}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files -f %{_realname}.lang
128 %defattr(644,root,root,755)
129 %doc ChangeLog
130 %attr(755,root,root) %{_sbindir}/cryptsetup
131 %attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
132 %{_mandir}/man8/*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libcryptsetup.so
137 %{_libdir}/libcryptsetup.la
138 %{_includedir}/*.h
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libcryptsetup.a
This page took 0.051051 seconds and 4 git commands to generate.