]> git.pld-linux.org Git - packages/crossx8664-binutils.git/blob - crossx8664-binutils.spec
- workaround flex warnings.
[packages/crossx8664-binutils.git] / crossx8664-binutils.spec
1 Summary:        Cross AMD64 GNU binary utility development utilities - binutils
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - AMD64 binutils
3 Summary(fr):    Utilitaires de développement binaire de GNU - AMD64 binutils
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla AMD64 - binutils
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - AMD64 binutils
6 Summary(tr):    GNU geliþtirme araçlarý - AMD64 binutils
7 Name:           crossamd64-binutils
8 Version:        2.16.90.0.1
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  b231856d84a6181572b0b3371cfc6843
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gettext-devel
20 ExcludeArch:    amd64
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         target          amd64-pld-linux
24 %define         arch            %{_prefix}/%{target}
25 %define         specflags       -Wno-error
26
27 %description
28 Binutils is a collection of binary utilities, including:
29 - ar - create, modify and extract from archives,
30 - nm - lists symbols from object files,
31 - objcopy - copy and translate object files,
32 - objdump - display information from object files,
33 - ranlib - generate an index for the contents of an archive,
34 - size - list the section sizes of an object or archive file,
35 - strings - list printable strings from files,
36 - strip - discard symbols,
37 - c++filt - a filter for demangling encoded C++ symbols,
38 - addr2line - convert addresses to file and line,
39 - nlmconv - convert object code into an NLM.
40
41 This package contains the cross version for AMD64.
42
43 %description -l pl
44 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
45 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
46 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
47 programów i bibliotek.
48
49 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla AMD64.
50
51 %prep
52 %setup -q -n binutils-%{version}
53
54 %build
55 cp -f /usr/share/automake/config.sub .
56
57 # ldscripts won't be generated properly if SHELL is not bash...
58 CFLAGS="%{rpmcflags}" \
59 LDFLAGS="%{rpmldflags}" \
60 CONFIG_SHELL="/bin/bash" \
61 ./configure \
62         --disable-shared \
63         --prefix=%{_prefix} \
64         --libdir=%{_libdir} \
65         --mandir=%{_mandir} \
66         --infodir=%{_infodir} \
67         --enable-64-bit-bfd \
68         --target=%{target}
69
70 %{__make} all \
71         tooldir=%{_prefix} \
72         EXEEXT=""
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_prefix}
77
78 %{__make} install \
79         prefix=$RPM_BUILD_ROOT%{_prefix} \
80         mandir=$RPM_BUILD_ROOT%{_mandir} \
81         infodir=$RPM_BUILD_ROOT%{_infodir} \
82         libdir=$RPM_BUILD_ROOT%{_libdir}
83
84 # remove these man pages unless we cross-build for win*/netware platforms.
85 # however, this should be done in Makefiles.
86 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README
94 %attr(755,root,root) %{_bindir}/%{target}-*
95 %dir %{arch}
96 %dir %{arch}/bin
97 %attr(755,root,root) %{arch}/bin/*
98 %dir %{arch}/lib
99 %dir %{arch}/lib/*
100 %{arch}/lib/ldscripts/*
101 %{_mandir}/man?/%{target}-*
This page took 0.086366 seconds and 3 git commands to generate.