]> git.pld-linux.org Git - packages/crossppc-binutils.git/blob - crossppc-binutils.spec
- sed -e "s/sparc/ppc/g" -e "s/SPARC/PPC/g" from crosssparc-binutils
[packages/crossppc-binutils.git] / crossppc-binutils.spec
1 Summary:        Cross PPC GNU binary utility development utilities - binutils
2 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - PPC binutils
3 Summary(fr):    Utilitaires de développement binaire de GNU - PPC binutils
4 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla PPC - binutils
5 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - PPC binutils
6 Summary(tr):    GNU geliþtirme araçlarý - PPC binutils
7 Name:           crossppc-binutils
8 Version:        2.15.90.0.3
9 Release:        1
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  1c1af0064ebd3d7bd99905874656a21e
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  bash
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  perl-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         target          ppc-pld-linux
22 %define         arch            %{_prefix}/%{target}
23
24 %description
25 Binutils is a collection of binary utilities, including:
26 - ar - create, modify and extract from archives,
27 - nm - lists symbols from object files,
28 - objcopy - copy and translate object files,
29 - objdump - display information from object files,
30 - ranlib - generate an index for the contents of an archive,
31 - size - list the section sizes of an object or archive file,
32 - strings - list printable strings from files,
33 - strip - discard symbols,
34 - c++filt - a filter for demangling encoded C++ symbols,
35 - addr2line - convert addresses to file and line,
36 - nlmconv - convert object code into an NLM.
37
38 This package contains the cross version for PPC.
39
40 %description -l pl
41 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
42 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
43 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
44 programów i bibliotek.
45
46 Ten pakiet zawiera wersjê skro¶n± generuj±c± kod dla PPC.
47
48 %prep
49 %setup -q -n binutils-%{version}
50
51 %build
52 # ldscripts won't be generated properly if SHELL is not bash...
53 CFLAGS="%{rpmcflags}" \
54 LDFLAGS="%{rpmldflags}" \
55 CONFIG_SHELL="/bin/bash" \
56 ./configure \
57         --disable-shared \
58         --prefix=%{_prefix} \
59         --infodir=%{_infodir} \
60         --mandir=%{_mandir} \
61         --target=%{target}
62
63 %{__make} all \
64         tooldir=%{_prefix} \
65         EXEEXT=""
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_prefix}
70
71 %{__make} install \
72         prefix=$RPM_BUILD_ROOT%{_prefix} \
73         mandir=$RPM_BUILD_ROOT%{_mandir} \
74         infodir=$RPM_BUILD_ROOT%{_infodir}
75
76 # remove these man pages unless we cross-build for win*/netware platforms.
77 # however, this should be done in Makefiles.
78 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %attr(755,root,root) %{_bindir}/%{target}-*
87 %dir %{arch}/bin
88 %attr(755,root,root) %{arch}/bin/*
89 %dir %{arch}/lib
90 %dir %{arch}/lib/*
91 %{arch}/lib/ldscripts/*
92 %{_mandir}/man?/%{target}-*
This page took 0.066159 seconds and 4 git commands to generate.