]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blob - crossmingw32-pangomm.spec
df6fe2b755d0b730bc7f131541c5c09c439f6b90
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
1 Summary:        A C++ interface for pango library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
3 Name:           crossmingw32-pangomm
4 Version:        2.28.4
5 Release:        4
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.28/pangomm-%{version}.tar.xz
9 # Source0-md5:  f4fe0905ee56e1ff0205005e61d2a66f
10 URL:            http://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  crossmingw32-cairomm >= 1.6.3
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-glibmm >= 2.22.0
16 BuildRequires:  crossmingw32-pango >= 1.24.0
17 BuildRequires:  libtool >= 2:2.0
18 BuildRequires:  mm-common >= 0.9.5
19 BuildRequires:  pkgconfig >= 1:0.15
20 BuildRequires:  rpmbuild(macros) >= 1.446
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-cairomm >= 1.6.3
24 Requires:       crossmingw32-glibmm >= 2.22.0
25 Requires:       crossmingw32-pango >= 1.24.0
26 Provides:       crossmingw32-gtkmm-pango
27 Obsoletes:      crossmingw32-gtkmm-pango
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42 %define         __pkgconfig_provides    %{nil}
43 %define         __pkgconfig_requires    %{nil}
44
45 %ifnarch %{ix86}
46 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
47 %define         optflags        -O2
48 %endif
49 # -z options are invalid for mingw linker, most of -f options are Linux-specific
50 %define         filterout_ld    -Wl,-z,.*
51 %define         filterout_c             -f[-a-z0-9=]*
52
53 %description
54 A C++ interface for pango library - cross MinGW32 version.
55
56 %description -l pl.UTF-8
57 Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
58
59 %package static
60 Summary:        Static pangomm library (cross MinGW32 version)
61 Summary(pl.UTF-8):      Statyczna biblioteka pangomm (wersja skrośna MinGW32)
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Provides:       crossmingw32-gtkmm-pango-static
65 Obsoletes:      crossmingw32-gtkmm-pango-static
66
67 %description static
68 Static pangomm library (cross MinGW32 version).
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka pangomm (wersja skrośna MinGW32).
72
73 %package dll
74 Summary:        DLL pangomm library for Windows
75 Summary(pl.UTF-8):      Biblioteka DLL pangomm dla Windows
76 Group:          Applications/Emulators
77 Requires:       crossmingw32-cairomm-dll >= 1.6.3
78 Requires:       crossmingw32-glibmm-dll >= 2.22.0
79 Requires:       crossmingw32-pango-dll >= 1.24.0
80 Requires:       wine
81 Provides:       crossmingw32-gtkmm-pango-dll
82 Obsoletes:      crossmingw32-gtkmm-pango-dll
83
84 %description dll
85 DLL pangomm library for Windows.
86
87 %description dll -l pl.UTF-8
88 Biblioteka DLL pangomm dla Windows.
89
90 %prep
91 %setup -q -n pangomm-%{version}
92
93 %build
94 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
95 %{__libtoolize}
96 %{__aclocal} -I build
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --target=%{target} \
102         --host=%{target} \
103         --disable-documentation \
104         --disable-silent-rules \
105         --enable-static
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT%{_dlldir}
116 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
117
118 %if 0%{!?debug:1}
119 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
120 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
121 %endif
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README
129 %{_libdir}/libpangomm-1.4.dll.a
130 %{_libdir}/libpangomm-1.4.la
131 %{_libdir}/pangomm-1.4
132 %{_includedir}/pangomm-1.4
133 %{_pkgconfigdir}/pangomm-1.4.pc
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libpangomm-1.4.a
138
139 %files dll
140 %defattr(644,root,root,755)
141 %{_dlldir}/libpangomm-1.4-*.dll
This page took 0.081962 seconds and 3 git commands to generate.