]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
f39b41352d7fd1304f3902e19d313d94b3a4f7bb
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - MinGW32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.2.11
6 Release:        2
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.xz
10 # Source0-md5:  815d0c6d61601f51bbcaeef6826606b0
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  libtool >= 2:2.0
16 BuildRequires:  m4
17 BuildRequires:  mm-common >= 0.7.2
18 BuildRequires:  perl-base
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-runtime
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker, most of -f options are Linux-specific
43 %define         filterout_ld    -Wl,-z,.*
44 %define         filterout_c     -f[-a-z0-9=]*
45 %define         filterout_cxx   -f[-a-z0-9=]*
46
47 %description
48 This library implements a full callback system for use in widget
49 libraries, abstract interfaces, and general programming. Originally
50 part of the Gtk-- widget set, libsigc++ is now a seperate library to
51 provide for more general use. It is the most complete library of its
52 kind with the ablity to connect an abstract callback to a class
53 method, function, or function object. It contains adaptor classes for
54 connection of dissimilar callbacks and has an ease of use unmatched by
55 other C++ callback libraries.
56
57 This package contains cross MinGW32 version.
58
59 %description -l pl.UTF-8
60 Ta biblioteka jest implementacją pełnego systemu callbacków do
61 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
62 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
63 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
64 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
65 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
66 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
67 callbacków.
68
69 Ten pakiet zawiera wersję skrośną MinGW32.
70
71 %package static
72 Summary:        Static libsigc++ library (cross MinGW32 version)
73 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description static
78 Static libsigc++ library (cross MinGW32 version).
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
82
83 %package dll
84 Summary:        DLL libsigc++ library for Windows
85 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
86 Group:          Applications/Emulators
87 Requires:       wine
88
89 %description dll
90 DLL libsigc++ library for Windows.
91
92 %description dll -l pl.UTF-8
93 Biblioteka DLL libsigc++ dla Windows.
94
95 %prep
96 %setup -q -n %{realname}-%{version}
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I build
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --target=%{target} \
105         --host=%{target} \
106         --enable-static
107
108 %{__make} all
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install -d $RPM_BUILD_ROOT%{_dlldir}
117 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
118
119 %if 0%{!?debug:1}
120 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122 %endif
123
124 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README TODO
132 %{_libdir}/libsigc-2.0.dll.a
133 %{_libdir}/libsigc-2.0.la
134 %{_libdir}/sigc++-2.0
135 %{_includedir}/sigc++-2.0
136 %{_pkgconfigdir}/sigc++-2.0.pc
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libsigc-2.0.a
141
142 %files dll
143 %defattr(644,root,root,755)
144 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.036298 seconds and 3 git commands to generate.