]> git.pld-linux.org Git - packages/crossmingw32-libpng.git/blob - crossmingw32-libpng.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libpng.git] / crossmingw32-libpng.spec
1 %define         realname        libpng
2 Summary:        PNG library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka PNG - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.5.15
6 Release:        2
7 License:        distributable
8 Group:          Development/Libraries
9 Source0:        http://downloads.sourceforge.net/libpng/%{realname}-%{version}.tar.xz
10 # Source0-md5:  e3122e7b5b5c36c034a4624c65f8a9d8
11 Patch0:         %{realname}-pngminus.patch
12 Patch1:         http://downloads.sourceforge.net/libpng-apng/%{realname}-1.5.15-apng.patch.gz
13 # Patch1-md5:   3ae9ea7e4bd201f0b25e25cd6049b094
14 URL:            http://www.libpng.org/pub/png/libpng.html
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-zlib
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz >= 1:4.999.7
20 Requires:       crossmingw32-zlib
21 Provides:       crossmingw32-libpng(APNG) = 0.10
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         no_install_post_strip   1
25
26 %define         target                  i386-mingw32
27 %define         target_platform         i386-pc-mingw32
28
29 %define         _sysprefix              /usr
30 %define         _prefix                 %{_sysprefix}/%{target}
31 %define         _libdir                 %{_prefix}/lib
32 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
33 %define         _dlldir                 /usr/share/wine/windows/system
34 %define         __cc                    %{target}-gcc
35 %define         __cxx                   %{target}-g++
36 %define         __pkgconfig_provides    %{nil}
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker, most of -f options are Linux-specific
43 %define         filterout_ld    -Wl,-z,.*
44 %define         filterout_c     -f[-a-z0-9=]*
45
46 %description
47 The PNG library is a collection of routines used to create and
48 manipulate PNG format graphics files. The PNG format was designed as a
49 replacement for GIF, with many improvements and extensions.
50
51 This package contains the cross version for Win32.
52
53 %description -l pl.UTF-8
54 Biblioteki PNG są kolekcją form używanych do tworzenia i manipulowania
55 plikami w formacie graficznym PNG. Format ten został stworzony jako
56 zamiennik dla formatu GIF, z wieloma rozszerzeniami i nowościami.
57
58 Ten pakiet zawiera wersję skrośną dla Win32.
59
60 %package static
61 Summary:        Static libpng library (cross MinGW32 version)
62 Summary(pl.UTF-8):      Statyczna biblioteka libpng (wersja skrośna MinGW32)
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Provides:       crossmingw32-libpng-static(APNG) = 0.10
66
67 %description static
68 Static libpng library (cross MinGW32 version).
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libpng (wersja skrośna MinGW32).
72
73 %package dll
74 Summary:        libpng - DLL library for Windows
75 Summary(pl.UTF-8):      libpng - biblioteka DLL dla Windows
76 Group:          Applications/Emulators
77 Requires:       crossmingw32-zlib-dll
78 Requires:       wine
79 Provides:       crossmingw32-libpng-dll(APNG) = 0.10
80
81 %description dll
82 libpng - DLL library for Windows.
83
84 %description dll -l pl.UTF-8
85 libpng - biblioteka DLL dla Windows.
86
87 %prep
88 %setup -q -n %{realname}-%{version}
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 %configure \
94         --target=%{target} \
95         --host=%{target} \
96         --with-pkgconfigdir=%{_pkgconfigdir}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT%{_dlldir}
107 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
108
109 ln -sf libpng15.dll.a $RPM_BUILD_ROOT%{_libdir}/libpng.dll.a
110
111 %if 0%{!?debug:1}
112 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
113 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
114 %endif
115
116 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/man
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %{_libdir}/libpng15.dll.a
124 %{_libdir}/libpng.dll.a
125 %{_libdir}/libpng15.la
126 %{_libdir}/libpng.la
127 %{_includedir}/libpng15
128 %{_includedir}/png*.h
129 %{_pkgconfigdir}/libpng15.pc
130 %{_pkgconfigdir}/libpng.pc
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libpng15.a
135 %{_libdir}/libpng.a
136
137 %files dll
138 %defattr(644,root,root,755)
139 %{_dlldir}/libpng15-*.dll
This page took 0.056839 seconds and 4 git commands to generate.