]> git.pld-linux.org Git - packages/crossmingw32-glib2.git/blob - crossmingw32-glib2.spec
2ec72ac95b51c70ab2850b2dddd6116c784900f6
[packages/crossmingw32-glib2.git] / crossmingw32-glib2.spec
1 Summary:        Useful routines for 'C' programming - Ming32 cross version
2 Summary(cs.UTF-8):      Šikovná knihovna s funkcemi pro pomocné programy
3 Summary(da.UTF-8):      Nyttige biblioteksfunktioner
4 Summary(de.UTF-8):      Eine nützliche Library von Dienstprogramm-Funktionen
5 Summary(es.UTF-8):      Conjunto de funciones gráficas utilitarias
6 Summary(fi.UTF-8):      Kirjasto, jossa on työkalufunktioita
7 Summary(fr.UTF-8):      Bibliothèque de fonctions utilitaires
8 Summary(ja.UTF-8):      便利なユーティリティ関数のライブラリ
9 Summary(pl.UTF-8):      Biblioteka zawierająca wiele użytecznych funkcji C - wersja skrośna dla Ming32
10 Summary(pt_BR.UTF-8):   Conjunto de funções gráficas utilitárias
11 Summary(tr.UTF-8):      Yararlı ufak yordamlar kitaplığı
12 Summary(zh_CN.UTF-8):   实用工具函数库
13 %define         _realname   glib
14 Name:           crossmingw32-%{_realname}2
15 Version:        2.12.9
16 Release:        1
17 License:        LGPL
18 Group:          Libraries
19 #Source0:       ftp://ftp.gtk.org/pub/glib/2.12/win32/glib-dev-%{version}.zip
20 Source0:        ftp://ftp.gtk.org/pub/glib/2.12/%{_realname}-%{version}.tar.bz2
21 # Source0-md5:  b3f6a2a318610af6398b3445f1a2d6c6
22 Patch0:         %{name}-stacktest.patch
23 URL:            http://www.gtk.org/
24 BuildRequires:  crossmingw32-gcc
25 BuildRequires:  crossmingw32-gettext
26 BuildRequires:  crossmingw32-libiconv
27 BuildRequires:  unzip
28 Requires:       crossmingw32-binutils
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         host                    %{target}
35 %define         target_platform         %{target}
36 %define         arch                    %{_prefix}/%{target}
37 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
38 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
39
40 %define         _sysprefix              /usr
41 %define         _prefix                 %{_sysprefix}/%{target}
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45
46 %description
47 GLib, is a library which includes support routines for C such as
48 lists, trees, hashes, memory allocation, and many other things. GLIB
49 includes also generally useful data structures used by GIMP and many
50 other.
51
52 This package contains the cross version for Win32.
53
54 %description -l cs.UTF-8
55 Šikovná knihovna s funkcemi pro pomocné programy. Vývojové knihovny a
56 hlavičky jsou v balíčku glib-devel.
57
58 %description -l da.UTF-8
59 Nyttigt bibliotek med forskellige funktioner. Udviklings- biblioteker
60 og headerfiler er i glib-devel pakken.
61
62 %description -l de.UTF-8
63 Eine nützliche Library von Dienstprogramm-Funktionen.
64 Entwicklungs-Libraries und Header befinden sich in glib-devel.
65
66 %description -l es.UTF-8
67 Conjunto de funciones utilitarias. Bibliotecas de desarrollo y
68 archivos de inclusión están en glib-devel.
69
70 %description -l fi.UTF-8
71 Kirjasto, jossa on työkalufunktioita. Kehitysversiot ja
72 header-tiedostot ovat glib-devel-paketissa.
73
74 %description -l ja.UTF-8
75 GLibはユーティリティ関数を集めた便利なライブラリです。このC言語用ライブラリは、
76 いくつかの問題を解決するよう設計されており、多くのプログラムから要求される使いやすい
77 関数を提供します。
78
79 GLibはGDK,
80 GTK+他多くのアプリケーションで利用される。このライブラリに依存するアプリケーション
81 等のためにこのglibパッケージをインストールしてください。
82
83 %description -l pl.UTF-8
84 Glib jest zestawem bibliotek zawierających funkcje do obsługi list i
85 drzew, funkcje mieszające, funkcje do alokacji pamięci i dużo innych
86 podstawowych funkcji i różnych struktur danych używanych przez program
87 GIMP i wiele innych.
88
89 Ten pakiet zawiera wersję skrośną dla Win32.
90
91 %description -l pt_BR.UTF-8
92 Conjunto de funções utilitárias. Bibliotecas de desenvolvimento e
93 arquivos de inclusão estão em glib-devel.
94
95 %description -l tr.UTF-8
96 Yararlı yordamlar kitaplığı. Geliştirme kitaplıkları ve başlık
97 dosyaları glib-devel paketinde yer almaktadır.
98
99 %prep
100 %setup -q -n %{_realname}-%{version}
101 %patch0 -p1
102
103 %build
104 export PKG_CONFIG_PATH=%{_prefix}/lib/pkgconfig
105 %{__libtoolize}
106 %{__aclocal}
107 %{__automake}
108 %{__autoconf}
109 %configure \
110         --target=%{target} \
111         --host=%{target} \
112         --disable-gtk-doc \
113         --enable-shared
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # use system glib2-devel instead
124 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*.m4
125
126 %find_lang glib20 --with-gnome
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f glib20.lang
132 %defattr(644,root,root,755)
133 %dir %{_includedir}/glib-2.0
134 %{_includedir}/glib-2.0
135 %{_libdir}/*.la
136 %{_libdir}/*.a
137 %{_bindir}/*.dll
138 %dir %{_libdir}/glib-2.0/include
139 %{_libdir}/glib-2.0/include/glibconfig.h
140 %{_pkgconfigdir}/*.pc
141 %dir %{_datadir}/glib-2.0/gettext
142 %attr(755,root,root) %{_datadir}/glib-2.0/gettext/mkinstalldirs
143 %dir %{_datadir}/glib-2.0/gettext/po
144 %{_datadir}/glib-2.0/gettext/po/*
This page took 0.053707 seconds and 3 git commands to generate.