]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blob - crossmingw32-gcc.spec
- updated to 4.8.2
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
1 #
2 # TODO:
3 # - openmp
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap build (using binary w32api/mingwrt)
7 #
8 Summary:        Cross MinGW32 GNU binary utility development utilities - gcc
9 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
10 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 gcc
11 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
12 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
13 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 gcc
14 Name:           crossmingw32-gcc
15 Version:        4.8.2
16 Release:        1
17 Epoch:          1
18 License:        GPL v3+
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
21 # Source0-md5:  a3d7d63b9cb6b6ea049469a0c4a43c9d
22 %define         mingw32_ver     4.0.3
23 Source1:        http://downloads.sourceforge.net/mingw/mingwrt-%{mingw32_ver}-1-mingw32-dev.tar.lzma
24 # Source1-md5:  c2c9aa82e0cb47abac01760525684858
25 # svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_8_2_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_8-branch > gcc-branch.diff
26 Patch100:       gcc-branch.diff
27 # Patch100-md5: d63540a52bfd83b772e310fde995ad65
28 Patch0:         %{name}-buildsystem1.patch
29 Patch1:         %{name}-buildsystem2.patch
30 Patch2:         %{name}-lfs.patch
31 BuildRequires:  autoconf >= 2.64
32 BuildRequires:  automake >= 1:1.9.3
33 BuildRequires:  bison
34 BuildRequires:  crossmingw32-binutils >= 2.15.91.0.2-2
35 BuildRequires:  flex
36 BuildRequires:  libmpc-devel
37 %if %{without bootstrap}
38 BuildRequires:  crossmingw32-runtime >= 3.5
39 BuildRequires:  crossmingw32-w32api >= 3.1
40 %endif
41 BuildRequires:  mpfr-devel
42 BuildRequires:  perl-tools-pod
43 BuildRequires:  ppl-devel >= 0.11
44 BuildRequires:  texinfo >= 4.2
45 %if %{with booststrap}
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 %endif
49 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
50 Requires:       gcc-dirs
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         target          i386-mingw32
54 %define         sysprefix       /usr
55 %define         arch            %{sysprefix}/%{target}
56 %define         gccarchdir      %{_libdir}/gcc/%{target}
57 %define         gcclibdir       %{gccarchdir}/%{version}
58 %define         _dlldir         /usr/share/wine/windows/system
59
60 %define         _noautostrip    .*/lib.*\\.a
61
62 %define         _enable_debug_packages 0
63
64 # functions with printf format attribute but with special parser and also
65 # receiving non constant format strings
66 %define         Werror_cflags   %{nil}
67
68 %define         _ssp_cflags     %{nil}
69
70 %description
71 crossmingw32 is a complete cross-compiling development system for
72 building stand-alone Microsoft Windows applications under Linux using
73 the MinGW32 build libraries. This includes a binutils, gcc with g++
74 and objc, and libstdc++, all cross targeted to i386-mingw32, along
75 with supporting Win32 libraries in 'coff' format from free sources.
76
77 This package contains cross targeted gcc.
78
79 %description -l de.UTF-8
80 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
81 anderem Rechner Code für Win32 zu generieren.
82
83 %description -l pl.UTF-8
84 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
85 pozwalającym budować aplikacje MS Windows pod Linuksem używając
86 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
87 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
88 z bibliotek w formacie COFF.
89
90 Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
91
92 %package -n crossmingw32-libgcc-dll
93 Summary:        libgcc DLL library for Windows
94 Summary(pl.UTF-8):      Biblioteka DLL libgcc dla Windows
95 Group:          Applications/Emulators
96 Requires:       wine
97
98 %description -n crossmingw32-libgcc-dll
99 libgcc DLL library for Windows.
100
101 %description -n crossmingw32-libgcc-dll -l pl.UTF-8
102 Biblioteka DLL libgcc dla Windows.
103
104 %package c++
105 Summary:        MinGW32 binary utility development utilities - g++
106 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - g++
107 Group:          Development/Languages
108 Requires:       %{name} = %{epoch}:%{version}-%{release}
109
110 %description c++
111 crossmingw32 is a complete cross-compiling development system for
112 building stand-alone Microsoft Windows applications under Linux using
113 the MinGW32 build libraries. This includes a binutils, gcc with g++
114 and objc, and libstdc++, all cross targeted to i386-mingw32, along
115 with supporting Win32 libraries in 'coff' format from free sources.
116
117 This package contains cross targeted g++ and (static) libstdc++.
118
119 %description c++ -l pl.UTF-8
120 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
121 pozwalającym budować aplikacje MS Windows pod Linuksem używając
122 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
123 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
124 z bibliotek w formacie COFF.
125
126 Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
127 libstdc++.
128
129 %package -n crossmingw32-libstdc++-static
130 Summary:        Static standard C++ library - cross MinGW32 version
131 Summary(pl.UTF-8):      Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
132 Group:          Development/Libraries
133 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
134
135 %description -n crossmingw32-libstdc++-static
136 Static standard C++ library - cross MinGW32 version.
137
138 %description -n crossmingw32-libstdc++-static -l pl.UTF-8
139 Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
140
141 %package -n crossmingw32-libstdc++-dll
142 Summary:        libstdc++ DLL library for Windows
143 Summary(pl.UTF-8):      Biblioteka DLL libstdc++ dla Windows
144 Group:          Applications/Emulators
145 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
146 Requires:       wine
147
148 %description -n crossmingw32-libstdc++-dll
149 libstdc++ DLL library for Windows.
150
151 %description -n crossmingw32-libstdc++-dll -l pl.UTF-8
152 Biblioteka DLL libstdc++ dla Windows.
153
154 %package objc
155 Summary:        MinGW32 binary utility development utilities - objc
156 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - objc
157 Group:          Development/Languages
158 Requires:       %{name} = %{epoch}:%{version}-%{release}
159
160 %description objc
161 crossmingw32 is a complete cross-compiling development system for
162 building stand-alone Microsoft Windows applications under Linux using
163 the MinGW32 build libraries. This includes a binutils, gcc with g++
164 and objc, and libstdc++, all cross targeted to i386-mingw32, along
165 with supporting Win32 libraries in 'coff' format from free sources.
166
167 This package contains cross targeted objc compiler.
168
169 %description objc -l pl.UTF-8
170 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
171 pozwalającym budować aplikacje MS Windows pod Linuksem używając
172 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
173 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
174 z bibliotek w formacie COFF.
175
176 Ten pakiet zawiera kompilator objc generujący kod pod Win32.
177
178 %package -n crossmingw32-libobjc-static
179 Summary:        Static Objective C library - cross MinGW32 version
180 Summary(pl.UTF-8):      Statyczna biblioteka Objective C - wersja skrośna MinGW32
181 Group:          Development/Libraries
182 Requires:       %{name}-objc = %{epoch}:%{version}-%{release}
183
184 %description -n crossmingw32-libobjc-static
185 Static Objective C library - cross MinGW32 version.
186
187 %description -n crossmingw32-libobjc-static -l pl.UTF-8
188 Statyczna biblioteka Objective C - wersja skrośna MinGW32.
189
190 %package -n crossmingw32-libobjc-dll
191 Summary:        libobjc DLL library for Windows
192 Summary(pl.UTF-8):      Biblioteka DLL libobjc dla Windows
193 Group:          Applications/Emulators
194 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
195 Requires:       wine
196
197 %description -n crossmingw32-libobjc-dll
198 libobjc DLL library for Windows.
199
200 %description -n crossmingw32-libobjc-dll -l pl.UTF-8
201 Biblioteka DLL libobjc dla Windows.
202
203 %package fortran
204 Summary:        MinGW32 binary utility development utilities - Fortran
205 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Fortran
206 Group:          Development/Languages
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
209 Obsoletes:      crossmingw32-gcc-g77
210
211 %description fortran
212 crossmingw32 is a complete cross-compiling development system for
213 building stand-alone Microsoft Windows applications under Linux using
214 the MinGW32 build libraries. This includes a binutils, gcc with g++
215 and objc, and libstdc++, all cross targeted to i386-mingw32, along
216 with supporting Win32 libraries in 'coff' format from free sources.
217
218 This package contains cross targeted Fortran compiler.
219
220 %description fortran -l pl.UTF-8
221 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
222 pozwalającym budować aplikacje MS Windows pod Linuksem używając
223 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
224 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
225 z bibliotek w formacie COFF.
226
227 Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
228
229 %package -n crossmingw32-libgfortran-static
230 Summary:        Static Fortran library - cross MinGW32 version
231 Summary(pl.UTF-8):      Statyczna biblioteka Fortranu - wersja skrośna MinGW32
232 Group:          Development/Libraries
233 Requires:       %{name}-fortran = %{epoch}:%{version}-%{release}
234
235 %description -n crossmingw32-libgfortran-static
236 Static Fortran library - cross MinGW32 version.
237
238 %description -n crossmingw32-libgfortran-static -l pl.UTF-8
239 Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
240
241 %package -n crossmingw32-libgfortran-dll
242 Summary:        libgfortran DLL library for Windows
243 Summary(pl.UTF-8):      Biblioteka DLL libgfortran dla Windows
244 Group:          Applications/Emulators
245 Requires:       crossmingw32-libquadmath-dll
246
247 %description -n crossmingw32-libgfortran-dll
248 libgfortran DLL library for Windows.
249
250 %description -n crossmingw32-libgfortran-dll -l pl.UTF-8
251 Biblioteka DLL libgfortran dla Windows.
252
253 %package -n crossmingw32-libquadmath
254 Summary:        GCC __float128 support library - cross MinGW32 version
255 Summary(pl.UTF-8):      Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
256 License:        GPL v2+ with linking exception
257 Group:          Development/Libraries
258 Requires:       %{name} = %{epoch}:%{version}-%{release}
259
260 %description -n crossmingw32-libquadmath
261 This package contains cross MinGW32 version of GCC support library
262 which is needed for __float128 math support and for Fortran REAL*16
263 support.
264
265 %description -n crossmingw32-libquadmath -l pl.UTF-8
266 Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
267 operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
268 w Fortranie.
269
270 %package -n crossmingw32-libquadmath-static
271 Summary:        Static GCC __float128 support library - cross MinGW32 version
272 Summary(pl.UTF-8):      Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
273 License:        GPL v2+ with linking exception
274 Group:          Development/Libraries
275 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
276
277 %description -n crossmingw32-libquadmath-static
278 Static GCC __float128 support library - cross MinGW32 version.
279
280 %description -n crossmingw32-libquadmath-static -l pl.UTF-8
281 Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
282 MinGW32.
283
284 %package -n crossmingw32-libquadmath-dll
285 Summary:        DLL GCC __float128 support library for Windows
286 Summary(pl.UTF-8):      Biblioteka DLL GCC do obsługi typu __float128 dla Windows
287 License:        GPL v2+ with linking exception
288 Group:          Applications/Emulators
289 Requires:       wine
290
291 %description -n crossmingw32-libquadmath-dll
292 DLL GCC __float128 support library for Windows.
293
294 %description -n crossmingw32-libquadmath-dll -l pl.UTF-8
295 Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
296
297 %package java
298 Summary:        MinGW32 binary utility development utilities - Java
299 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Java
300 Group:          Development/Languages
301 Requires:       %{name} = %{epoch}:%{version}-%{release}
302
303 %description java
304 crossmingw32 is a complete cross-compiling development system for
305 building stand-alone Microsoft Windows applications under Linux using
306 the MinGW32 build libraries. This includes a binutils, gcc with g++
307 and objc, and libstdc++, all cross targeted to i386-mingw32, along
308 with supporting Win32 libraries in 'coff' format from free sources.
309
310 This package contains cross targeted Java compiler.
311
312 %description java -l pl.UTF-8
313 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
314 pozwalającym budować aplikacje MS Windows pod Linuksem używając
315 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
316 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
317 z bibliotek w formacie COFF.
318
319 Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
320
321 %prep
322 %setup -q -n gcc-%{version}
323 %patch100 -p0
324 %patch0 -p1
325 %patch2 -p1
326
327 %if %{with bootstrap}
328 # note: "winsup" dir is special, handled by gcc's configure
329 install -d winsup/mingw
330 tar xf %{SOURCE1} -C winsup/mingw
331 %endif
332
333 # override snapshot version.
334 echo %{version} > gcc/BASE-VER
335 echo "release" > gcc/DEV-PHASE
336
337 %build
338 rm -rf builddir && install -d builddir && cd builddir
339 %if %{with bootstrap}
340 install -d %{target}/winsup
341 ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
342 ln -sf ../../../winsup/mingw/include %{target}/winsup/w32api
343 WINSUPDIR=$(cd ..; pwd)/winsup
344 %endif
345
346 CC="%{__cc}" \
347 CFLAGS="%{rpmcflags}" \
348 CXXFLAGS="%{rpmcxxflags}" \
349 TEXCONFIG=false \
350 ../configure \
351         --prefix=%{sysprefix} \
352         --bindir=%{arch}/bin \
353         --libdir=%{_libdir} \
354         --includedir=%{arch}/include \
355         --libexecdir=%{_libdir} \
356         --infodir=%{_infodir} \
357         --mandir=%{_mandir} \
358         %{!?with_bootstrap:--with-headers=%{arch}/include} \
359         --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
360         --with-build-time-tools=%{arch}/bin \
361         --with-dwarf2 \
362         --with-gnu-as \
363         --with-gnu-ld \
364         --with-mangler-in-ld \
365         --with-long-double-128 \
366         --with-ppl \
367         --disable-ppl-version-check \
368         --enable-threads \
369         --enable-languages="c,c++,fortran,java,objc" \
370         --enable-c99 \
371         --enable-long-long \
372         --enable-fully-dynamic-string \
373         --enable-libstdcxx-allocator=new \
374         --enable-version-specific-runtime-libs \
375         --enable-shared \
376         --disable-nls \
377         --disable-symvers \
378         --disable-sjlj-exceptions \
379         --disable-win32-registry \
380         --disable-multilib \
381         --disable-libssp \
382         --target=%{target}
383
384 cd ..
385 %{__make} -C builddir all-host
386 patch -p1 <%{PATCH1}
387 %{__make} -C builddir
388
389 %install
390 rm -rf $RPM_BUILD_ROOT
391 install -d $RPM_BUILD_ROOT%{_bindir}
392
393 %{__make} -C builddir install \
394         DESTDIR=$RPM_BUILD_ROOT
395
396 # host (ELF) library
397 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
398
399 mv $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
400 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
401 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
402
403 # these must be symlinks: gcclibdir is calculated relatively to real binary path
404 ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
405 ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
406 ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
407 ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
408 ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
409 ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
410 ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
411
412 # DLLs
413 install -d $RPM_BUILD_ROOT%{_dlldir}
414 mv -f $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
415 mv -f $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
416 if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
417         echo "libgcc DLL not installed?"
418         install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
419 fi
420
421 %if 0%{!?debug:1}
422 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
423 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
424 %endif
425
426 # for pretty-printers see native gcc
427 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
428 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
429 # no plugin development for mingw32 (at least for now)
430 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
431 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
432 # already in native gcc
433 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
434 # common FSF man pages
435 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
436 # programs not packaged
437 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
438
439 %clean
440 rm -rf $RPM_BUILD_ROOT
441
442 %files
443 %defattr(644,root,root,755)
444 %attr(755,root,root) %{_bindir}/%{target}-gcc
445 %attr(755,root,root) %{_bindir}/%{target}-cpp
446 %attr(755,root,root) %{_bindir}/%{target}-gcov
447 %attr(755,root,root) %{arch}/bin/%{target}-gcc
448 %attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
449 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
450 %attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
451 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
452 %attr(755,root,root) %{arch}/bin/%{target}-cpp
453 %attr(755,root,root) %{arch}/bin/%{target}-gcov
454 %attr(755,root,root) %{arch}/bin/gcc
455 %dir %{gccarchdir}
456 %dir %{gcclibdir}
457 %attr(755,root,root) %{gcclibdir}/cc1
458 %attr(755,root,root) %{gcclibdir}/collect2
459 %attr(755,root,root) %{gcclibdir}/lto-wrapper
460 %attr(755,root,root) %{gcclibdir}/lto1
461 %attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
462 %{gcclibdir}/libgcc.a
463 %{gcclibdir}/libgcc_eh.a
464 %{gcclibdir}/libgcc_s.a
465 %{gcclibdir}/libgcov.a
466 %{gcclibdir}/crtbegin.o
467 %{gcclibdir}/crtend.o
468 %{gcclibdir}/crtfastmath.o
469 %dir %{gcclibdir}/include
470 %{gcclibdir}/include/*.h
471 %{_mandir}/man1/%{target}-cpp.1*
472 %{_mandir}/man1/%{target}-gcc.1*
473 %{_mandir}/man1/%{target}-gcov.1*
474
475 %files -n crossmingw32-libgcc-dll
476 %defattr(644,root,root,755)
477 %{_dlldir}/libgcc_s_dw2-1.dll
478
479 %files c++
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_bindir}/%{target}-g++
482 %attr(755,root,root) %{arch}/bin/%{target}-c++
483 %attr(755,root,root) %{arch}/bin/%{target}-g++
484 %attr(755,root,root) %{arch}/bin/c++
485 %attr(755,root,root) %{arch}/bin/g++
486 %attr(755,root,root) %{gcclibdir}/cc1plus
487 %{gcclibdir}/libstdc++.dll.a
488 %{gcclibdir}/libstdc++.la
489 %{gcclibdir}/libsupc++.la
490 %{gcclibdir}/libsupc++.a
491 %{gcclibdir}/include/c++
492 %{_mandir}/man1/%{target}-g++.1*
493
494 %files -n crossmingw32-libstdc++-static
495 %defattr(644,root,root,755)
496 %{gcclibdir}/libstdc++.a
497
498 %files -n crossmingw32-libstdc++-dll
499 %defattr(644,root,root,755)
500 %{_dlldir}/libstdc++-6.dll
501
502 %files objc
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{gcclibdir}/cc1obj
505 %{gcclibdir}/libobjc.dll.a
506 %{gcclibdir}/libobjc.la
507 %{gcclibdir}/include/objc
508
509 %files -n crossmingw32-libobjc-static
510 %defattr(644,root,root,755)
511 %{gcclibdir}/libobjc.a
512
513 %files -n crossmingw32-libobjc-dll
514 %defattr(644,root,root,755)
515 %{_dlldir}/libobjc-4.dll
516
517 %files fortran
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/%{target}-gfortran
520 %attr(755,root,root) %{arch}/bin/%{target}-gfortran
521 %attr(755,root,root) %{arch}/bin/gfortran
522 %attr(755,root,root) %{gcclibdir}/f951
523 %{gcclibdir}/finclude
524 %{gcclibdir}/libcaf_single.a
525 %{gcclibdir}/libcaf_single.la
526 %{gcclibdir}/libgfortran.dll.a
527 %{gcclibdir}/libgfortran.la
528 %{gcclibdir}/libgfortran.spec
529 %{gcclibdir}/libgfortranbegin.a
530 %{gcclibdir}/libgfortranbegin.la
531 %{_mandir}/man1/%{target}-gfortran.1*
532
533 %files -n crossmingw32-libgfortran-static
534 %defattr(644,root,root,755)
535 %{gcclibdir}/libgfortran.a
536
537 %files -n crossmingw32-libgfortran-dll
538 %defattr(644,root,root,755)
539 %{_dlldir}/libgfortran-3.dll
540
541 %files -n crossmingw32-libquadmath
542 %defattr(644,root,root,755)
543 %{gcclibdir}/libquadmath.dll.a
544 %{gcclibdir}/libquadmath.la
545
546 %files -n crossmingw32-libquadmath-static
547 %defattr(644,root,root,755)
548 %{gcclibdir}/libquadmath.a
549
550 %files -n crossmingw32-libquadmath-dll
551 %defattr(644,root,root,755)
552 %{_dlldir}/libquadmath-0.dll
553
554 %files java
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/%{target}-gcj
557 %attr(755,root,root) %{_bindir}/%{target}-jcf-dump
558 %attr(755,root,root) %{arch}/bin/%{target}-gcj
559 %attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
560 %attr(755,root,root) %{gcclibdir}/jc1
561 %attr(755,root,root) %{gcclibdir}/jvgenmain
562 %{_mandir}/man1/%{target}-gcj.1*
563 %{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.113554 seconds and 4 git commands to generate.