]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blob - crossmingw32-gcc.spec
- ignore ppl version
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
1 #
2 # TODO:
3 # - openmp
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap build (using binary w32api/mingwrt)
7 #
8 Summary:        Cross MinGW32 GNU binary utility development utilities - gcc
9 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
10 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 gcc
11 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
12 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
13 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 gcc
14 Name:           crossmingw32-gcc
15 Version:        4.7.3
16 Release:        2
17 Epoch:          1
18 License:        GPL v3+
19 Group:          Development/Languages
20 Source0:        ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
21 # Source0-md5:  86f428a30379bdee0224e353ee2f999e
22 %define         apiver  3.17
23 Source1:        http://downloads.sourceforge.net/mingw/w32api-%{apiver}-2-mingw32-dev.tar.lzma
24 # Source1-md5:  c3a86ffa6b8c21de868df54e4e38f05e
25 %define         runver  3.20
26 Source2:        http://downloads.sourceforge.net/mingw/mingwrt-%{runver}-mingw32-dev.tar.gz
27 # Source2-md5:  2d2f5c8165ff9c29661a5be96336a4f7
28 # svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_4_7_3_release svn://gcc.gnu.org/svn/gcc/branches/gcc-4_7-branch > gcc-branch.diff
29 Patch100:       gcc-branch.diff
30 # Patch100-md5: ed71b602ecff35de8f4678e27dd9c2ef
31 Patch0:         %{name}-buildsystem1.patch
32 Patch1:         %{name}-buildsystem2.patch
33 Patch2:         %{name}-lfs.patch
34 BuildRequires:  autoconf >= 2.64
35 BuildRequires:  automake >= 1:1.9.3
36 BuildRequires:  bison
37 BuildRequires:  crossmingw32-binutils >= 2.15.91.0.2-2
38 BuildRequires:  flex
39 BuildRequires:  libmpc-devel
40 %if %{without bootstrap}
41 BuildRequires:  crossmingw32-runtime >= 3.5
42 BuildRequires:  crossmingw32-w32api >= 3.1
43 %endif
44 BuildRequires:  mpfr-devel
45 BuildRequires:  perl-tools-pod
46 BuildRequires:  ppl-devel >= 0.11
47 BuildRequires:  texinfo >= 4.2
48 %if %{with booststrap}
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 %endif
52 Requires:       crossmingw32-binutils >= 2.15.91.0.2-2
53 Requires:       gcc-dirs
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         target          i386-mingw32
57 %define         sysprefix       /usr
58 %define         arch            %{sysprefix}/%{target}
59 %define         gccarchdir      %{_libdir}/gcc/%{target}
60 %define         gcclibdir       %{gccarchdir}/%{version}
61 %define         _dlldir         /usr/share/wine/windows/system
62
63 %define         _noautostrip    .*/lib.*\\.a
64
65 %define         _enable_debug_packages 0
66
67 # functions with printf format attribute but with special parser and also
68 # receiving non constant format strings
69 %define         Werror_cflags   %{nil}
70
71 %define         _ssp_cflags     %{nil}
72
73 %description
74 crossmingw32 is a complete cross-compiling development system for
75 building stand-alone Microsoft Windows applications under Linux using
76 the MinGW32 build libraries. This includes a binutils, gcc with g++
77 and objc, and libstdc++, all cross targeted to i386-mingw32, along
78 with supporting Win32 libraries in 'coff' format from free sources.
79
80 This package contains cross targeted gcc.
81
82 %description -l de.UTF-8
83 Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
84 anderem Rechner Code für Win32 zu generieren.
85
86 %description -l pl.UTF-8
87 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
88 pozwalającym budować aplikacje MS Windows pod Linuksem używając
89 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
90 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
91 z bibliotek w formacie COFF.
92
93 Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
94
95 %package -n crossmingw32-libgcc-dll
96 Summary:        libgcc DLL library for Windows
97 Summary(pl.UTF-8):      Biblioteka DLL libgcc dla Windows
98 Group:          Applications/Emulators
99 Requires:       wine
100
101 %description -n crossmingw32-libgcc-dll
102 libgcc DLL library for Windows.
103
104 %description -n crossmingw32-libgcc-dll -l pl.UTF-8
105 Biblioteka DLL libgcc dla Windows.
106
107 %package c++
108 Summary:        MinGW32 binary utility development utilities - g++
109 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - g++
110 Group:          Development/Languages
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112
113 %description c++
114 crossmingw32 is a complete cross-compiling development system for
115 building stand-alone Microsoft Windows applications under Linux using
116 the MinGW32 build libraries. This includes a binutils, gcc with g++
117 and objc, and libstdc++, all cross targeted to i386-mingw32, along
118 with supporting Win32 libraries in 'coff' format from free sources.
119
120 This package contains cross targeted g++ and (static) libstdc++.
121
122 %description c++ -l pl.UTF-8
123 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
124 pozwalającym budować aplikacje MS Windows pod Linuksem używając
125 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
126 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
127 z bibliotek w formacie COFF.
128
129 Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
130 libstdc++.
131
132 %package -n crossmingw32-libstdc++-static
133 Summary:        Static standard C++ library - cross MinGW32 version
134 Summary(pl.UTF-8):      Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
135 Group:          Development/Libraries
136 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
137
138 %description -n crossmingw32-libstdc++-static
139 Static standard C++ library - cross MinGW32 version.
140
141 %description -n crossmingw32-libstdc++-static -l pl.UTF-8
142 Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
143
144 %package -n crossmingw32-libstdc++-dll
145 Summary:        libstdc++ DLL library for Windows
146 Summary(pl.UTF-8):      Biblioteka DLL libstdc++ dla Windows
147 Group:          Applications/Emulators
148 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
149 Requires:       wine
150
151 %description -n crossmingw32-libstdc++-dll
152 libstdc++ DLL library for Windows.
153
154 %description -n crossmingw32-libstdc++-dll -l pl.UTF-8
155 Biblioteka DLL libstdc++ dla Windows.
156
157 %package objc
158 Summary:        MinGW32 binary utility development utilities - objc
159 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - objc
160 Group:          Development/Languages
161 Requires:       %{name} = %{epoch}:%{version}-%{release}
162
163 %description objc
164 crossmingw32 is a complete cross-compiling development system for
165 building stand-alone Microsoft Windows applications under Linux using
166 the MinGW32 build libraries. This includes a binutils, gcc with g++
167 and objc, and libstdc++, all cross targeted to i386-mingw32, along
168 with supporting Win32 libraries in 'coff' format from free sources.
169
170 This package contains cross targeted objc compiler.
171
172 %description objc -l pl.UTF-8
173 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
174 pozwalającym budować aplikacje MS Windows pod Linuksem używając
175 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
176 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
177 z bibliotek w formacie COFF.
178
179 Ten pakiet zawiera kompilator objc generujący kod pod Win32.
180
181 %package -n crossmingw32-libobjc-static
182 Summary:        Static Objective C library - cross MinGW32 version
183 Summary(pl.UTF-8):      Statyczna biblioteka Objective C - wersja skrośna MinGW32
184 Group:          Development/Libraries
185 Requires:       %{name}-objc = %{epoch}:%{version}-%{release}
186
187 %description -n crossmingw32-libobjc-static
188 Static Objective C library - cross MinGW32 version.
189
190 %description -n crossmingw32-libobjc-static -l pl.UTF-8
191 Statyczna biblioteka Objective C - wersja skrośna MinGW32.
192
193 %package -n crossmingw32-libobjc-dll
194 Summary:        libobjc DLL library for Windows
195 Summary(pl.UTF-8):      Biblioteka DLL libobjc dla Windows
196 Group:          Applications/Emulators
197 Requires:       crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
198 Requires:       wine
199
200 %description -n crossmingw32-libobjc-dll
201 libobjc DLL library for Windows.
202
203 %description -n crossmingw32-libobjc-dll -l pl.UTF-8
204 Biblioteka DLL libobjc dla Windows.
205
206 %package fortran
207 Summary:        MinGW32 binary utility development utilities - Fortran
208 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Fortran
209 Group:          Development/Languages
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
212 Obsoletes:      crossmingw32-gcc-g77
213
214 %description fortran
215 crossmingw32 is a complete cross-compiling development system for
216 building stand-alone Microsoft Windows applications under Linux using
217 the MinGW32 build libraries. This includes a binutils, gcc with g++
218 and objc, and libstdc++, all cross targeted to i386-mingw32, along
219 with supporting Win32 libraries in 'coff' format from free sources.
220
221 This package contains cross targeted Fortran compiler.
222
223 %description fortran -l pl.UTF-8
224 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
225 pozwalającym budować aplikacje MS Windows pod Linuksem używając
226 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
227 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
228 z bibliotek w formacie COFF.
229
230 Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
231
232 %package -n crossmingw32-libgfortran-static
233 Summary:        Static Fortran library - cross MinGW32 version
234 Summary(pl.UTF-8):      Statyczna biblioteka Fortranu - wersja skrośna MinGW32
235 Group:          Development/Libraries
236 Requires:       %{name}-fortran = %{epoch}:%{version}-%{release}
237
238 %description -n crossmingw32-libgfortran-static
239 Static Fortran library - cross MinGW32 version.
240
241 %description -n crossmingw32-libgfortran-static -l pl.UTF-8
242 Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
243
244 %package -n crossmingw32-libgfortran-dll
245 Summary:        libgfortran DLL library for Windows
246 Summary(pl.UTF-8):      Biblioteka DLL libgfortran dla Windows
247 Group:          Applications/Emulators
248 Requires:       crossmingw32-libquadmath-dll
249
250 %description -n crossmingw32-libgfortran-dll
251 libgfortran DLL library for Windows.
252
253 %description -n crossmingw32-libgfortran-dll -l pl.UTF-8
254 Biblioteka DLL libgfortran dla Windows.
255
256 %package -n crossmingw32-libquadmath
257 Summary:        GCC __float128 support library - cross MinGW32 version
258 Summary(pl.UTF-8):      Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
259 License:        GPL v2+ with linking exception
260 Group:          Development/Libraries
261 Requires:       %{name} = %{epoch}:%{version}-%{release}
262
263 %description -n crossmingw32-libquadmath
264 This package contains cross MinGW32 version of GCC support library
265 which is needed for __float128 math support and for Fortran REAL*16
266 support.
267
268 %description -n crossmingw32-libquadmath -l pl.UTF-8
269 Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
270 operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
271 w Fortranie.
272
273 %package -n crossmingw32-libquadmath-static
274 Summary:        Static GCC __float128 support library - cross MinGW32 version
275 Summary(pl.UTF-8):      Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
276 License:        GPL v2+ with linking exception
277 Group:          Development/Libraries
278 Requires:       crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
279
280 %description -n crossmingw32-libquadmath-static
281 Static GCC __float128 support library - cross MinGW32 version.
282
283 %description -n crossmingw32-libquadmath-static -l pl.UTF-8
284 Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
285 MinGW32.
286
287 %package -n crossmingw32-libquadmath-dll
288 Summary:        DLL GCC __float128 support library for Windows
289 Summary(pl.UTF-8):      Biblioteka DLL GCC do obsługi typu __float128 dla Windows
290 License:        GPL v2+ with linking exception
291 Group:          Applications/Emulators
292 Requires:       wine
293
294 %description -n crossmingw32-libquadmath-dll
295 DLL GCC __float128 support library for Windows.
296
297 %description -n crossmingw32-libquadmath-dll -l pl.UTF-8
298 Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
299
300 %package java
301 Summary:        MinGW32 binary utility development utilities - Java
302 Summary(pl.UTF-8):      Zestaw narzędzi MinGW32 - Java
303 Group:          Development/Languages
304 Requires:       %{name} = %{epoch}:%{version}-%{release}
305
306 %description java
307 crossmingw32 is a complete cross-compiling development system for
308 building stand-alone Microsoft Windows applications under Linux using
309 the MinGW32 build libraries. This includes a binutils, gcc with g++
310 and objc, and libstdc++, all cross targeted to i386-mingw32, along
311 with supporting Win32 libraries in 'coff' format from free sources.
312
313 This package contains cross targeted Java compiler.
314
315 %description java -l pl.UTF-8
316 crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
317 pozwalającym budować aplikacje MS Windows pod Linuksem używając
318 bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
319 libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
320 z bibliotek w formacie COFF.
321
322 Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
323
324 %prep
325 %setup -q -n gcc-%{version}
326 %patch100 -p0
327 %patch0 -p1
328 %patch2 -p1
329
330 %if %{with bootstrap}
331 # note: "winsup" dirs below are special, handled by gcc's configure
332 install -d winsup/{mingw,w32api}
333 tar xf %{SOURCE1} -C winsup/w32api
334 tar xf %{SOURCE2} -C winsup/mingw
335 %endif
336
337 # override snapshot version.
338 echo %{version} > gcc/BASE-VER
339 echo "release" > gcc/DEV-PHASE
340
341 %build
342 rm -rf builddir && install -d builddir && cd builddir
343 %if %{with bootstrap}
344 install -d %{target}/winsup
345 ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
346 ln -sf ../../../winsup/w32api %{target}/winsup/w32api
347 WINSUPDIR=$(cd ..; pwd)/winsup
348 %endif
349
350 CC="%{__cc}" \
351 CFLAGS="%{rpmcflags}" \
352 CXXFLAGS="%{rpmcxxflags}" \
353 TEXCONFIG=false \
354 ../configure \
355         --prefix=%{sysprefix} \
356         --bindir=%{arch}/bin \
357         --libdir=%{_libdir} \
358         --includedir=%{arch}/include \
359         --libexecdir=%{_libdir} \
360         --infodir=%{_infodir} \
361         --mandir=%{_mandir} \
362         %{!?with_bootstrap:--with-headers=%{arch}/include} \
363         --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
364         --with-build-time-tools=%{arch}/bin \
365         --with-dwarf2 \
366         --with-gnu-as \
367         --with-gnu-ld \
368         --with-mangler-in-ld \
369         --with-long-double-128 \
370         --with-ppl \
371         --disable-ppl-version-check \
372         --enable-threads \
373         --enable-languages="c,c++,fortran,java,objc" \
374         --enable-c99 \
375         --enable-long-long \
376         --enable-fully-dynamic-string \
377         --enable-libstdcxx-allocator=new \
378         --enable-version-specific-runtime-libs \
379         --enable-shared \
380         --disable-nls \
381         --disable-symvers \
382         --disable-sjlj-exceptions \
383         --disable-win32-registry \
384         --disable-multilib \
385         --disable-libssp \
386         --target=%{target}
387
388 cd ..
389 %{__make} -C builddir all-host
390 patch -p1 <%{PATCH1}
391 %{__make} -C builddir
392
393 %install
394 rm -rf $RPM_BUILD_ROOT
395 install -d $RPM_BUILD_ROOT%{_bindir}
396
397 %{__make} -C builddir install \
398         DESTDIR=$RPM_BUILD_ROOT
399
400 # host (ELF) library
401 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
402
403 mv $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
404 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
405 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
406
407 # these must be symlinks: gcclibdir is calculated relatively to real binary path
408 ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
409 ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
410 ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
411 ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
412 ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
413 ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
414 ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
415
416 # DLLs
417 install -d $RPM_BUILD_ROOT%{_dlldir}
418 mv -f $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
419 mv -f $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
420 if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
421         echo "libgcc DLL not installed?"
422         install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
423 fi
424
425 %if 0%{!?debug:1}
426 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
427 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
428 %endif
429
430 # for pretty-printers see native gcc
431 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
432 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
433 # no plugin development for mingw32 (at least for now)
434 %{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
435 %{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
436 # already in native gcc
437 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
438 # common FSF man pages
439 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
440 # programs not packaged
441 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
442
443 %clean
444 rm -rf $RPM_BUILD_ROOT
445
446 %files
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_bindir}/%{target}-gcc
449 %attr(755,root,root) %{_bindir}/%{target}-cpp
450 %attr(755,root,root) %{_bindir}/%{target}-gcov
451 %attr(755,root,root) %{arch}/bin/%{target}-gcc
452 %attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
453 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
454 %attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
455 %attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
456 %attr(755,root,root) %{arch}/bin/%{target}-cpp
457 %attr(755,root,root) %{arch}/bin/%{target}-gcov
458 %attr(755,root,root) %{arch}/bin/gcc
459 %dir %{gccarchdir}
460 %dir %{gcclibdir}
461 %attr(755,root,root) %{gcclibdir}/cc1
462 %attr(755,root,root) %{gcclibdir}/collect2
463 %attr(755,root,root) %{gcclibdir}/lto-wrapper
464 %attr(755,root,root) %{gcclibdir}/lto1
465 %attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
466 %{gcclibdir}/libgcc.a
467 %{gcclibdir}/libgcc_eh.a
468 %{gcclibdir}/libgcc_s.a
469 %{gcclibdir}/libgcov.a
470 %{gcclibdir}/crtbegin.o
471 %{gcclibdir}/crtend.o
472 %{gcclibdir}/crtfastmath.o
473 %dir %{gcclibdir}/include
474 %{gcclibdir}/include/*.h
475 %{_mandir}/man1/%{target}-cpp.1*
476 %{_mandir}/man1/%{target}-gcc.1*
477 %{_mandir}/man1/%{target}-gcov.1*
478
479 %files -n crossmingw32-libgcc-dll
480 %defattr(644,root,root,755)
481 %{_dlldir}/libgcc_s_dw2-1.dll
482
483 %files c++
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_bindir}/%{target}-g++
486 %attr(755,root,root) %{arch}/bin/%{target}-c++
487 %attr(755,root,root) %{arch}/bin/%{target}-g++
488 %attr(755,root,root) %{arch}/bin/c++
489 %attr(755,root,root) %{arch}/bin/g++
490 %attr(755,root,root) %{gcclibdir}/cc1plus
491 %{gcclibdir}/libstdc++.dll.a
492 %{gcclibdir}/libstdc++.la
493 %{gcclibdir}/libsupc++.la
494 %{gcclibdir}/libsupc++.a
495 %{gcclibdir}/include/c++
496 %{_mandir}/man1/%{target}-g++.1*
497
498 %files -n crossmingw32-libstdc++-static
499 %defattr(644,root,root,755)
500 %{gcclibdir}/libstdc++.a
501
502 %files -n crossmingw32-libstdc++-dll
503 %defattr(644,root,root,755)
504 %{_dlldir}/libstdc++-6.dll
505
506 %files objc
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{gcclibdir}/cc1obj
509 %{gcclibdir}/libobjc.dll.a
510 %{gcclibdir}/libobjc.la
511 %{gcclibdir}/include/objc
512
513 %files -n crossmingw32-libobjc-static
514 %defattr(644,root,root,755)
515 %{gcclibdir}/libobjc.a
516
517 %files -n crossmingw32-libobjc-dll
518 %defattr(644,root,root,755)
519 %{_dlldir}/libobjc-4.dll
520
521 %files fortran
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_bindir}/%{target}-gfortran
524 %attr(755,root,root) %{arch}/bin/%{target}-gfortran
525 %attr(755,root,root) %{arch}/bin/gfortran
526 %attr(755,root,root) %{gcclibdir}/f951
527 %{gcclibdir}/finclude
528 %{gcclibdir}/libcaf_single.a
529 %{gcclibdir}/libcaf_single.la
530 %{gcclibdir}/libgfortran.dll.a
531 %{gcclibdir}/libgfortran.la
532 %{gcclibdir}/libgfortran.spec
533 %{gcclibdir}/libgfortranbegin.a
534 %{gcclibdir}/libgfortranbegin.la
535 %{_mandir}/man1/%{target}-gfortran.1*
536
537 %files -n crossmingw32-libgfortran-static
538 %defattr(644,root,root,755)
539 %{gcclibdir}/libgfortran.a
540
541 %files -n crossmingw32-libgfortran-dll
542 %defattr(644,root,root,755)
543 %{_dlldir}/libgfortran-3.dll
544
545 %files -n crossmingw32-libquadmath
546 %defattr(644,root,root,755)
547 %{gcclibdir}/libquadmath.dll.a
548 %{gcclibdir}/libquadmath.la
549
550 %files -n crossmingw32-libquadmath-static
551 %defattr(644,root,root,755)
552 %{gcclibdir}/libquadmath.a
553
554 %files -n crossmingw32-libquadmath-dll
555 %defattr(644,root,root,755)
556 %{_dlldir}/libquadmath-0.dll
557
558 %files java
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/%{target}-gcj
561 %attr(755,root,root) %{_bindir}/%{target}-jcf-dump
562 %attr(755,root,root) %{arch}/bin/%{target}-gcj
563 %attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
564 %attr(755,root,root) %{gcclibdir}/jc1
565 %attr(755,root,root) %{gcclibdir}/jvgenmain
566 %{_mandir}/man1/%{target}-gcj.1*
567 %{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.075289 seconds and 4 git commands to generate.