]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
83d99238989ba8d4c09947e1addf3ee7bfcaef69
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.22.51.0.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 # git archive --prefix=binutils-2.22.51.0.1/ -o binutils-2.22.51.0.1.tar remotes/origin/linux/release/2.22.51.0.1
13 Source0:        binutils-%{version}.tar.bz2
14 # Source0-md5:  f1141fa48e6431525cd4d8be814bef89
15 URL:            http://sources.redhat.com/binutils/
16 BuildRequires:  automake
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gettext-devel
21 BuildRequires:  perl-tools-pod
22 BuildRequires:  texinfo >= 4.2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         target          i386-mingw32
26 %define         arch            %{_prefix}/%{target}
27
28 %description
29 crossmingw32 is a complete cross-compiling development system for
30 building stand-alone Microsoft Windows applications under Linux using
31 the MinGW32 build libraries. This includes a binutils, gcc with g++
32 and objc, and libstdc++, all cross targeted to i386-mingw32, along
33 with supporting Win32 libraries in 'coff' format from free sources.
34
35 This package contains cross targeted binutils.
36
37 %description -l pl.UTF-8
38 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
39 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
40 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
41 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
42 COFF.
43
44 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
45
46 %prep
47 %setup -q -n binutils-%{version}
48
49 %build
50 cp /usr/share/automake/config.sub .
51
52 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
53 # lib<target>bfd.so*. To prevent confusion with native binutils, we
54 # forget about shared libraries right now, and do not install libbfd.a
55 # [the same applies to binutils 2.10.1.0.4]
56
57 # ldscripts won't be generated properly if SHELL is not bash...
58 CFLAGS="%{rpmcflags}" \
59 LDFLAGS="%{rpmldflags}" \
60 CONFIG_SHELL="/bin/bash" \
61 ./configure \
62         --disable-nls \
63         --disable-shared \
64         --prefix=%{_prefix} \
65         --libdir=%{_libdir} \
66         --mandir=%{_mandir} \
67         --infodir=%{_infodir} \
68         --host=%{_target_platform} \
69         --build=%{_target_platform} \
70         --target=%{target}
71
72 %{__make} all \
73         tooldir=%{_prefix}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         INSTALL='$$s/install-sh -c' \
80         prefix=$RPM_BUILD_ROOT%{_prefix} \
81         mandir=$RPM_BUILD_ROOT%{_mandir} \
82         infodir=$RPM_BUILD_ROOT%{_infodir} \
83         libdir=$RPM_BUILD_ROOT%{_libdir}
84
85 # remove this man page unless we cross-build for netware platform.
86 # however, this should be done in Makefiles.
87 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
88
89 # libiberty.a is ELF not PE
90 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
91
92 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
93 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README
101 # mingw32 directory tree
102 %dir %{arch}
103 %dir %{arch}/lib
104 %dir %{arch}/lib/pkgconfig
105 %dir %{arch}/bin
106 # binutils files
107 %attr(755,root,root) %{arch}/bin/ar
108 %attr(755,root,root) %{arch}/bin/as
109 %attr(755,root,root) %{arch}/bin/dlltool
110 %attr(755,root,root) %{arch}/bin/ld
111 %attr(755,root,root) %{arch}/bin/ld.bfd
112 %attr(755,root,root) %{arch}/bin/nm
113 %attr(755,root,root) %{arch}/bin/objcopy
114 %attr(755,root,root) %{arch}/bin/objdump
115 %attr(755,root,root) %{arch}/bin/ranlib
116 %attr(755,root,root) %{arch}/bin/strip
117 %{arch}/lib/ldscripts
118 %attr(755,root,root) %{_bindir}/%{target}-addr2line
119 %attr(755,root,root) %{_bindir}/%{target}-ar
120 %attr(755,root,root) %{_bindir}/%{target}-as
121 %attr(755,root,root) %{_bindir}/%{target}-c++filt
122 %attr(755,root,root) %{_bindir}/%{target}-dlltool
123 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
124 %attr(755,root,root) %{_bindir}/%{target}-elfedit
125 %attr(755,root,root) %{_bindir}/%{target}-gprof
126 %attr(755,root,root) %{_bindir}/%{target}-ld
127 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
128 %attr(755,root,root) %{_bindir}/%{target}-nm
129 %attr(755,root,root) %{_bindir}/%{target}-objcopy
130 %attr(755,root,root) %{_bindir}/%{target}-objdump
131 %attr(755,root,root) %{_bindir}/%{target}-ranlib
132 %attr(755,root,root) %{_bindir}/%{target}-readelf
133 %attr(755,root,root) %{_bindir}/%{target}-size
134 %attr(755,root,root) %{_bindir}/%{target}-strings
135 %attr(755,root,root) %{_bindir}/%{target}-strip
136 %attr(755,root,root) %{_bindir}/%{target}-windmc
137 %attr(755,root,root) %{_bindir}/%{target}-windres
138 %{_mandir}/man1/%{target}-addr2line.1*
139 %{_mandir}/man1/%{target}-ar.1*
140 %{_mandir}/man1/%{target}-as.1*
141 %{_mandir}/man1/%{target}-c++filt.1*
142 %{_mandir}/man1/%{target}-dlltool.1*
143 %{_mandir}/man1/%{target}-elfedit.1*
144 %{_mandir}/man1/%{target}-gprof.1*
145 %{_mandir}/man1/%{target}-ld.1*
146 %{_mandir}/man1/%{target}-nm.1*
147 %{_mandir}/man1/%{target}-objcopy.1*
148 %{_mandir}/man1/%{target}-objdump.1*
149 %{_mandir}/man1/%{target}-ranlib.1*
150 %{_mandir}/man1/%{target}-readelf.1*
151 %{_mandir}/man1/%{target}-size.1*
152 %{_mandir}/man1/%{target}-strings.1*
153 %{_mandir}/man1/%{target}-strip.1*
154 %{_mandir}/man1/%{target}-windmc.1*
155 %{_mandir}/man1/%{target}-windres.1*
This page took 0.108434 seconds and 3 git commands to generate.