]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
38bcf34ef9ca652a24a4274aa48461e773fb0b94
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - GNU binutils
2 Summary(pl):    Zestaw narzêdzi mingw32 - GNU binutils
3 Name:           crossmingw32-binutils
4 Version:        2.14.90.0.2
5 Release:        1
6 License:        GPL
7 Group:          Development/Tools
8 ExclusiveArch:  %{ix86}
9 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
10 BuildRequires:  bash
11 BuildRequires:  bison
12 BuildRequires:  flex
13 BuildRequires:  perl-devel
14 Requires:       crossmingw32-runtime
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         target          i386-mingw32
18 %define         arch            %{_prefix}/%{target}
19
20 %description
21 crossmingw32 is a complete cross-compiling development system for
22 building stand-alone Microsoft Windows applications under Linux using
23 the Mingw32 build libraries. This includes a binutils, gcc with g++
24 and objc, and libstdc++, all cross targeted to i386-mingw32, along
25 with supporting Win32 libraries in 'coff' format from free sources.
26
27 This package contains cross targeted binutils.
28
29 %description -l pl
30 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalaj±cym
31 budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c bibliotek mingw32.
32 System sk³ada siê z binutils, gcc z g++ i objc, libstdc++ - wszystkie
33 generuj±ce kod dla platformy i386-mingw32, oraz z bibliotek w formacie
34 COFF.
35
36 Ten pakiet zawiera binutils generuj±ce binaria Win32.
37
38 %prep
39 %setup -q -n binutils-%{version}
40
41 %build
42 rm -rf $RPM_BUILD_ROOT
43
44 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
45 # lib<target>bfd.so*. To prevent confusion with native binutils, we
46 # forget about shared libraries right now, and do not install libbfd.a
47 # [the same applies to binutils 2.10.1.0.4]
48
49 # ldscripts won't be generated properly if SHELL is not bash...
50 CFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
51 CONFIG_SHELL="/bin/bash" \
52 ./configure \
53         --prefix=%{_prefix} \
54         --libdir=%{_libdir} \
55         --mandir=%{_mandir} \
56         --infodir=%{_infodir} \
57         --target=%{target}
58
59 %{__make} tooldir=%{_prefix} EXEEXT="" all
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         INSTALL='$$s/install-sh -c' \
66         prefix=$RPM_BUILD_ROOT%{_prefix} \
67         mandir=$RPM_BUILD_ROOT%{_mandir} \
68         infodir=$RPM_BUILD_ROOT%{_infodir} \
69         libdir=$RPM_BUILD_ROOT%{_libdir}
70
71 # remove this man page unless we cross-build for netware platform.
72 # however, this should be done in Makefiles.
73 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{arch}/bin/*
78 %{arch}/lib/*
79 %attr(755,root,root) %{_bindir}/%{target}-*
80 %{_mandir}/man1/%{target}-*
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
This page took 0.070387 seconds and 3 git commands to generate.