]> git.pld-linux.org Git - packages/crossmingw32-atkmm.git/blob - crossmingw32-atkmm.spec
c8c67c1b988726ab926966e3d29f82a7339fa6f3
[packages/crossmingw32-atkmm.git] / crossmingw32-atkmm.spec
1 Summary:        A C++ interface for atk library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32
3 Name:           crossmingw32-atkmm
4 Version:        2.28.1
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        https://download.gnome.org/sources/atkmm/2.28/atkmm-%{version}.tar.xz
9 # Source0-md5:  03d9d02736645083cbb824c926750624
10 URL:            https://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.9
13 BuildRequires:  crossmingw32-atk >= 2.18.0
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.7
15 BuildRequires:  crossmingw32-glibmm >= 2.46.2
16 # for gmmproc tools
17 BuildRequires:  glibmm-devel >= 2.46.2
18 BuildRequires:  libtool >= 2:2.0
19 BuildRequires:  mm-common >= 0.9.10
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-atk >= 2.18.0
24 Requires:       crossmingw32-gcc-c++ >= 1:4.7
25 Requires:       crossmingw32-glibmm >= 2.46.2
26 Provides:       crossmingw32-gtkmm-atk
27 Obsoletes:      crossmingw32-gtkmm-atk
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42 %define         __pkgconfig_provides    %{nil}
43 %define         __pkgconfig_requires    %{nil}
44
45 %define         _ssp_cflags             %{nil}
46 %ifnarch %{ix86}
47 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
48 %define         optflags        -O2
49 %endif
50 # -z options are invalid for mingw linker, most of -f options are Linux-specific
51 %define         filterout_ld    -Wl,-z,.*
52 %define         filterout_c             -f[-a-z0-9=]*
53
54 %description
55 A C++ interface for atk library - cross MinGW32 version.
56
57 %description -l pl.UTF-8
58 Interfejs C++ dla biblioteki atk - wersja skrośna MinGW32.
59
60 %package static
61 Summary:        Static atkmm library (cross MinGW32 version)
62 Summary(pl.UTF-8):      Statyczna biblioteka atkmm (wersja skrośna MinGW32)
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Provides:       crossmingw32-gtkmm-atk-static
66 Obsoletes:      crossmingw32-gtkmm-atk-static
67
68 %description static
69 Static atkmm library (cross MinGW32 version).
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka atkmm (wersja skrośna MinGW32).
73
74 %package dll
75 Summary:        DLL atkmm library for Windows
76 Summary(pl.UTF-8):      Biblioteka DLL atkmm dla Windows
77 Group:          Applications/Emulators
78 Requires:       crossmingw32-atk-dll >= 2.18.0
79 Requires:       crossmingw32-glibmm-dll >= 2.46.2
80 Requires:       wine
81 Provides:       crossmingw32-gtkmm-atk-dll
82 Obsoletes:      crossmingw32-gtkmm-atk-dll
83
84 %description dll
85 DLL atkmm library for Windows.
86
87 %description dll -l pl.UTF-8
88 Biblioteka DLL atkmm dla Windows.
89
90 %prep
91 %setup -q -n atkmm-%{version}
92
93 %build
94 # use host gmmprocdir (before changing PKG_CONFIG_LIBDIR to cross target)
95 GMMPROC_DIR=$(pkg-config --variable=gmmprocdir glibmm-2.4)
96 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
97 mm-common-prepare --copy --force
98 %{__libtoolize}
99 %{__aclocal} -I build
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 # std-threads required by glibmm requires at least WinXP API
104 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0501"
105 %configure \
106         --target=%{target} \
107         --host=%{target} \
108         --disable-documentation \
109         --enable-maintainer-mode \
110         --disable-silent-rules \
111         --enable-static
112
113 %{__make} \
114         GMMPROC_DIR="$GMMPROC_DIR"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install -d $RPM_BUILD_ROOT%{_dlldir}
123 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libatkmm-*.la
126
127 %if 0%{!?debug:1}
128 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
129 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
130 %endif
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README
138 %{_libdir}/libatkmm-1.6.dll.a
139 %{_libdir}/atkmm-1.6
140 %{_includedir}/atkmm-1.6
141 %{_pkgconfigdir}/atkmm-1.6.pc
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libatkmm-1.6.a
146
147 %files dll
148 %defattr(644,root,root,755)
149 %{_dlldir}/libatkmm-1.6-1.dll
This page took 0.06294 seconds and 3 git commands to generate.