]> git.pld-linux.org Git - packages/crossfire.git/blob - crossfire.spec
- update to current version
[packages/crossfire.git] / crossfire.spec
1 Summary:        Multiplayer roguelike game server
2 Summary(pl):    Serwer gry roguelike dla wielu graczy
3 Name:           crossfire
4 Version:        1.1.0
5 Release:        1
6 License:        GPL
7 Group:          Applications/Games
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/crossfire/%{name}-%{version}.tar.bz2
9 Source1:        ftp://ftp.sourceforge.net/pub/sourceforge/crossfire/%{name}-%{version}-arch.tar.bz2
10 Source2:        %{name}.init
11 Source3:        %{name}.sysconfig
12 Source4:        %{name}.logrotate
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-directories.patch
15 Patch2:         %{name}-tmp_maps.patch
16 Patch3:         %{name}-faces.patch
17 URL:            http://crossfire.real-time.com/
18 BuildRequires:  XFree86-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Prereq:         /sbin/chkconfig
21
22 %define         _prefix /usr/X11R6
23 %define         _localstatedir /var/lib
24
25 %description 
26 This is a multiplayer graphical arcade and adventure game made for the
27 X-Window environment. There are also Windows and Java clients
28 available.
29
30 It has certain flavours from other games, especially Gauntlet (TM) and
31 Nethack/Moria.
32
33 Any number of players can move around in their own window, finding and
34 sing items and battle monsters. They can choose to cooperate or
35 compete in the same "world".
36
37 %description -l pl
38 To jest graficzna gra przygodowa dla ¶rodowiska X-Window. S± tak¿e
39 dostêpni klienci pod Windows i w Javie.
40
41 %package editor
42 Summary:        Crossfire map editor
43 Summary(pl):    Edytor map crossfire
44 Group:          Applications/Games
45
46 %description editor
47 Crossfire map editor.
48
49 %description editor -l pl
50 Edytor map crossfire.
51
52 %package doc
53 Summary:        Crossfire game documentation
54 Summary(pl):    Dokumentacja gry crossfire
55 Group:          Applications/Games
56
57 %description doc
58 Crossfire documentation for players. Includes handbook and spoiler.
59
60 %description doc -l pl
61 Dokumentacja dla graczy Crossfire. Zawiera podrêczniek oraz spoiler.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69 cd lib
70 bunzip2 -c %{SOURCE1} | tar xf -
71
72 %build
73 autoconf
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{/var/log,/etc/{sysconfig,%{name},logrotate.d},/etc/rc.d/init.d}
80 install -d $RPM_BUILD_ROOT%{_localstatedir}/%{name}/tmp
81 %{__make} install DESTDIR="$RPM_BUILD_ROOT"
82 mv -f $RPM_BUILD_ROOT%{_datadir}/%{name}/{ban_file,settings,dm_file,motd,forbid} \
83         $RPM_BUILD_ROOT/etc/%{name}
84 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
85 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
86 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
87 touch $RPM_BUILD_ROOT/var/log/crossfire
88 rm doc/Developers/Makefile*
89 gzip -9nf CHANGES CREDITS DEVELOPERS README TODO \
90  doc/{PlayerStats,RunTimeCommands,SurvivalGuide,alchemy.doc,experience,multigod} \
91  doc/{skills.doc,spell-paths,spellcasters_guide_to_runes,spells,spell_params.doc} \
92  doc/{metaserver,Crossedit.doc,Developers/*} doc/*.ps \
93  crossedit/doc/*.doc
94  
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 /sbin/chkconfig --add crossfire
100 if [ -r /var/lock/subsys/crossfire ]; then
101         /etc/rc.d/init.d/crossfire restart >&2
102 else
103         echo "Run \"/etc/rc.d/init.d/crossfire start\" to start Crossfire server."
104 fi
105
106 %preun
107 if [ "$1" = "0" ]; then
108         if [ -r /var/lock/subsys/crossfire ]; then
109                 /etc/rc.d/init.d/crossfire stop >&2
110         fi
111         /sbin/chkconfig --del crossfire
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc *.gz
117 %doc doc/{alchemy.doc*,experience*,multigod*,spell_params.doc*} 
118 %doc doc/{spell-paths*,spellcasters_guide_to_runes*,metaserver*} 
119 %doc doc/Developers
120 %attr(750,root,games) %{_bindir}/crossfire
121 %attr(750,root,games) %{_bindir}/random_map
122 %dir %attr(750,root,games) %{_datadir}/crossfire
123 %{_datadir}/crossfire/*
124 %{_mandir}/man?/crossfire*
125 %dir %attr(750,root,games) %{_localstatedir}/crossfire
126 %dir %attr(770,root,games) %{_localstatedir}/crossfire/players
127 %dir %attr(770,root,games) %{_localstatedir}/crossfire/unique-items
128 %dir %attr(770,root,games) %{_localstatedir}/crossfire/tmp
129 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/bookarch
130 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/highscore
131 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) %{_localstatedir}/crossfire/temp.maps
132 %dir /etc/crossfire
133 %config(noreplace) %verify(not size mtime md5) /etc/crossfire/*
134 %attr(754,root,root) /etc/rc.d/init.d/crossfire
135 %attr(660,root,root) /etc/logrotate.d/crossfire
136 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/crossfire
137 %attr(660,root,games) %config(noreplace) %verify(not size mtime md5) /var/log/crossfire
138
139 %files editor
140 %defattr(644,root,root,755)
141 %doc doc/{Crossedit.doc*} crossedit/doc/*.doc*
142 %attr(755,root,root) %{_bindir}/crossedit
143 %{_mandir}/man?/crossedit*
144
145 %files doc
146 %doc doc/{handbook.ps*,spoiler.ps*}
147 %doc doc/{PlayerStats*,RunTimeCommands*,SurvivalGuide*} 
148 %doc doc/{skills.doc*,spellcasters_guide_to_runes*,spells*} 
This page took 0.039498 seconds and 4 git commands to generate.